Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

How can I open these two ports in CentOS? I have used Ubuntu before, but I never had to manually open any port.

When I enter iptables -L, I get output like this:

Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
[root@sachinvasudev test]#
share|improve this question
Don't say it is for webmin, they will close your question because they don't like control panels. – peterh Jul 5 at 16:00

4 Answers 4

when you want to change it manually, here is a good tutorial:

Otherwise you could use the programs system-config-securitylevel or system-config-firewall.

share|improve this answer
I have to agree with David. Have you tried accessing webmin or ftp? – Christian Jan 6 '10 at 21:17

Based on the iptables output you posted, everything is already open. In fact, your not blocking anything!

share|improve this answer

You might want to reconsider opening those ports since Webmin is notoriously full of bugs and ftp sends usernames and passwords in plain text. Better to ssh in and tunnel through that to gain access to Webmin (or just learn to manage the server without Webmin, which in the long-term is a far better option). For ftp, consider replacing it with sftp/scp.

share|improve this answer
iptables -I INPUT -p tcp --dport 10000 -s -j ACCEPT
iptables -I INPUT -p tcp --dport 21 -s -j ACCEPT

And save the changes to iptables :

iptables-save > /etc/sysconfig/iptables
share|improve this answer
A script is not enough without a textual elaboration. – peterh Jul 5 at 15:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.