-2
votes
0answers
29 views

Installing packages from URL? [closed]

Does there exist a commandline program which can install packages in Ubuntu? I have seen wrapper scripts for dpkg which first wget the packages, and then uses dpkg -i.
1
vote
0answers
30 views

What can prevent apt from installing higher version

I'm trying to install a specific version of a package (python-neutronclient), but apt is failing to do that due to old packages. This happens even though new packages are available. Aptitude also ...
0
votes
1answer
37 views

How to get the Package-List of a debian/ubuntu package?

It's possible to view the Package-List of a debian/ubuntu package, using the package management tools like apt, aptitude or dpkg? I need to list the packages provided by a package, the list is ...
0
votes
1answer
221 views

installing git from debian wheezy backports: anyway i see old package version

I need to install git 1.8.* version. I added backports to my sources.list; Removed current installed git via apt-get remove git; Executed apt-get update to update my packages list aptitude show git ...
2
votes
1answer
26 views

Exclude sources files for apt-get update

I use an specific command to check security updates: /usr/bin/apt-get update -o Dir::Etc::SourceList=/etc/apt/security.sources.list But when executed it use sources files in ...
0
votes
1answer
92 views

apt-get dependency issue when installing nginx passenger module

Sorry I Have no idea how to fix the dependency problem. My Ubuntu server is 12.04 64 bit $ sudo apt-get install libcurl4-openssl-dev Reading package lists... Done Building dependency tree Reading ...
1
vote
1answer
164 views

Ubuntu apt-get update vs upgrade

I have a VPS with Ubuntu Server 12.04 and I want maximal stability of my server, which's main purpose is a webserver. What are difference between Update and Upgrade? I can't understand difference. As ...
1
vote
1answer
90 views

On Debian, how to audit installed packages against packages in a particular repository?

I manage a number of Debian servers and usually track the Debian stable repository but occasionally install from the Debian testing repository or third party sources. For audit purposes, on each ...
2
votes
0answers
35 views

Disallow virtual package in Debian's /etc/apt/preferences

I know I can disallow a particular package in Debian by appending /etc/apt/preferences with: Package: *x11* Pin: release Pin-Priority: -1 But how can I do that for a virtual package like httpd? I'd ...
0
votes
1answer
131 views

Removing sources from sources.list doesn't work

I had recently upgraded to php 5.4 but it was not working for me so I thought I'd remove php 5.4 and re-install php 5.3. I uninstalled php5.4, removed the dotdeb sources from sources.list file, ran ...
1
vote
1answer
133 views

Prioritise repositories in Ubuntu

We have a few PPA sources on some of our servers which we stick into /etc/apt/sources.list.d . Some of these repos provide same packages (in terms of names) but different versions and possibly ...
0
votes
1answer
185 views

installed post-installation script returned error exit status 1

I found many complains with same error but for different packages. However, i couldn't understand essence of this error and how to fix it. Pls. help if you have any clue about it. It appeared first ...
0
votes
1answer
74 views

Ubuntu 12.04 Server on VMWare - apt-get failing to hit repos

So, I have an Ubuntu 12.04 LTS 64-bit server instance running on VMWare player. Everything appears fine at the surface. Even internet connectivity appears good as I can perform both pings out to ...
0
votes
1answer
81 views

Downgrade php5-cgi using APT on Debian

I have lighttpd install with PHP5.4 installed I need to downgrade it to 5.3.2 (possibly older/newer) but I can't install it I tried this apt-get install php5-cgi=5.3.2 but it says "E: Version ...
2
votes
3answers
244 views

How to install packages with APT without user interaction?

I have a script that downloads and replaces kernel headers in Debian squeeze. function fixHeaders(){ #Replace the kernel headers from OVH with standard kernel headers... aptitude -y install ...
1
vote
3answers
143 views

How does aptitude determine what version of a package/application to install? i.e. Apache 2.2 vs 2.4

So I wasted several days dealing with a lame Apache2 bug that was fixed in Februry 2012. I couldn't figure out why I was experiencing the bug still until I discovered my version Apache2 was a 2.2.x ...
1
vote
3answers
425 views

Upgrade to the latest php by aptitude

I'm install php5 by aptitude, but php release the new version and recommend we upgrade. But I unwant to compile the new version by myself. How to upgrade the php to the newest version by aptitude?
0
votes
1answer
67 views

Install from backport with apt fail

So little question, I've got this: redis-server: Installed: 2:1.2.6-1 Candidate: 2:1.2.6-1 Version table: 2:2.4.15-1~bpo60+2 0 100 http://backports.debian.org/debian-backports/ ...
4
votes
2answers
463 views

How to version lock packages in Ubuntu? [duplicate]

On CentOS exists the yum versionlock option, where you can lock a package to a specific version, so it is never upgraded past that. I would like that puppet-server-2.7.19-1 puppet-2.7.19-1 stays ...
0
votes
2answers
64 views

How can I make aptitude show me the files that will be installed for a given package

On ubuntu I would like to know which files that will be installed when running sudo aptitude install ruby-rvm. So first I do sudo aptitude download ruby-rvm. Now I can do aptitude show ruby-rvm, but ...
1
vote
2answers
362 views

Debian asks to autoremove a lot of packages

My Debian wants me to invoke apt-get autoremove There are a lot of packages was installed automatically: apache2.2-bin baobab binfmt-support bluez cheese cheese-common cli-common dasher ...
1
vote
3answers
4k views

How do I install the latest version of Sphinx Seach in Apt-get?

When I do "sudo apt-get install sphinxsearch", I get version 0.9. I want the latest stable version (which is 2.4, I believe) How can I do that using aptitude?
3
votes
2answers
2k views

How do I override apt-get removing dependent packages?

I want to replace postfix with exim4 on my Ubuntu test server to reflect the setup I have on my production server, but apt-get and aptitude (quite understandably) insist on removing several packages ...
1
vote
1answer
90 views

Difference between package updates and release upgrades on Debian

I've been trying to decide on a new OS for my production machine, and I was wondering what the difference is between straight up upgrading packages and upgrading to a new release. If I install Debian ...
0
votes
0answers
939 views

apt-get install from ppa.launchpad.net repository

Some time ago I installed zfs from ppa.launchpad.net repository for Ubuntu Server Oneric 11.10 by add-apt-repository ppa:zfs-native/stable apt-get update apt-get install spl-linux ubuntu-zfs ...
1
vote
2answers
75 views

Does Debian or Ubuntu have a means of logging apt/aptitude commands?

Does Debian or Ubuntu have a means of logging apt/aptitude commands? I could also ask the same about yum commands in Redhat? Do they have a history file?
1
vote
1answer
135 views

Cent OS. Removed yum packages with apt-get. Server at work is down

I ran: sudo apt-get --fix-broken install and ended up removing: MySQL-client (5.0.92-0.glibc23) MySQL-server (5.0.92-0.glibc23) bandmin (1.6.1-1_newinit) exim (4.69-30_cpanel_maildir) mdadm ...
1
vote
2answers
477 views

Debian etch apt-get issues

I'm new to this area of Linux. I have a linux box which says kernel version is 2.6.18-4-amd64. It's been working as it for a long time. I needed to install subversion on the box, hence I tried ...
2
votes
1answer
166 views

Debian aptitude: determine which repository a package is coming from? [closed]

In Aptitude, how can I tell where a package is coming from? I've set up my apt sources.list and preferences files for pinning, but I just want to make sure I'm not unknowingly upgrading to packages ...
1
vote
1answer
56 views

Debian - Upgrade cpp-4.3 to cpp-4.4

I have Debian Squeeze and I have cpp-4.3 which sits on it: I want to know if I can remove cpp-4.3 and others and install something like cpp-4.4 or higher. And why does aptitude does not upgrade ...
4
votes
2answers
131 views

how do I find where apt-get installs files belonging to a package

I installed a package with apt-get, and now I need to locate where these files have been placed. I tried: sudo apt-cache show <package> and, sudo find / -name <package> but it did ...
2
votes
3answers
755 views

Upgrade from Debian Lenny to Squeeze with apt-get

I just upgraded my system from Lenny to Squeeze following the steps posted here. I followed all the steps using apt-get (in the upgrade from Etch to Lenny i used aptitude as suggested) and the upgrade ...
6
votes
1answer
1k views

How do I generate a response file to be used with apt-get or aptitude?

I need to install exim4 through puppet. Because this installation requires interactive configuration, I need a response file, but I don't know how to generate one. So, how do I generate a response ...
1
vote
2answers
1k views

How do I check to see if an apt lock file is locked?

I am writing a script to do some apt commands, but I am running into potential issues of the apt/dpkg databases being locked so my script bails. I want to check the lock files (i.e. ...
1
vote
2answers
832 views

How to include Debian repository from different architecture

I am running AMD64 Debian. I need to install software from external vendor which supports i386 architecture only. While I can add their repository to sources.list, those i386 packages do not appear ...
1
vote
2answers
827 views

Aptitude update 404

All I get are the errors below. How can I debug / what might be wrong? I don't know when this happend, probably just some days ago. Nothing has been changed in the system, that I know of. The only ...
0
votes
2answers
2k views

How to permanently ignore grub-pc package for aptitude?

I'm running Ubuntu 10.4 virtualized under Xen and the grub-pc package is broken and apt-get notifies me every time I run it. I just want to configure apt-get / aptitude to ignore this package ...
3
votes
2answers
360 views

Generating a record of the full(-ish) package management state

I'm about to make some system changes and I'd like to have a record of my current happy system state. Is there a convenient way to create a record of this? I'd like to keep track of info like ...
2
votes
5answers
3k views

apt-get, aptitude package version

How can I find out package versions available from repositories?
0
votes
2answers
729 views

E: Internal Error, Could not perform immediate configuration (2) on libattr1 ? in Ubuntu

I am working with Ubuntu latest version. While installing via apt-get install i tried to abort that by pressing Ctrl+Z. It terminate successfully ;). But next time when i tried to use apt-get, i got ...
0
votes
2answers
3k views

Update php 5.2.0 to 5.2.4 with aptitude

I would like to update my php 5 in my server. At this moment, I use php 5.2.0 so I want to update it to php 5.2.4 (not php 5.3). I tried to do this: aptitude update aptitude upgrade 63 packets were ...
2
votes
1answer
468 views

Unrespected pinning in Ubuntu with aptitude

I'm running an Ubuntu 9.10 (Karmic) system, but would like the beta Lucid repositories enabled for some packages I need bleeding-edge versions of. I'm trying to use apt-pinning so that they will ...
1
vote
2answers
267 views

Is it prudent to ignore all kernel updates on Amazon EC2 instances?

Given that it's impossible to "aptitude update" your way to a new kernel on an Amazon EC2 instance, I was wondering if it ever makes sense to apply kernel updates. My guess is no, and that I should ...
0
votes
2answers
788 views

What does apt's “failed in buffer_write(fd)” error message mean?

I have a server and am trying to do an apt-get upgrade, and get the following error message. What does it mean? E: ...
3
votes
2answers
3k views

How can I list all installed packages from lenny-backports?

In Debian or one of its derivatives, how can I list all packages which I have installed from lenny-backports? The closest I've come up with is: aptitude search ~i~Alenny-backports However, that ...
0
votes
3answers
752 views

Is it possible to use aptitude on a redhat machine?

We're having to manage a server for a client that is running RHEL 4. Is it possible to run aptitude on this server to install/manage packages?
1
vote
2answers
778 views

apt-get install giving 404

I'm something of a ubuntu newb. I'm trying to get subversion, so I enter: apt-get install subversion I'm getting a 404 on subversion and all its dependencies. E.g. Failed to fetch ...
10
votes
3answers
4k views

How do I show the actions that installing a .deb package will take?

I would like to be able to view the scripts/triggers associated with a package due for upgrade so that I can tell, for example, whether it will result in the web server being restarted. I can't find ...
1
vote
3answers
504 views

How can I list which packages are from experimental?

I have a system which is a mishmash of testing and unstable and some from experimental. How can I get a list of which packages I've installed from experimental?
6
votes
7answers
551 views

It is true that I shouldn't run apt-get and aptitude on the same machine?

I have been using apt-get for some years on Ubuntu now, and tried aptitude a few times. I have read in some blogs that once you have used one of the tools on your system, you should stick to it and ...