1
vote
1answer
194 views

Package pinning in Debian lenny

I need your advice as I don't know if I hit a bug, or I am misunderstanding something. On a Debian Lenny, I am trying to prevent the installation of two particular packages, when they are requested ...
19
votes
3answers
33k views

apt-get update getting 404 on debian lenny

Here is my /etc/apt/sources.list ###### Debian Main Repos deb http://ftp.us.debian.org/debian/ lenny main contrib non-free ###### Debian Update Repos deb http://security.debian.org/ lenny/updates ...
15
votes
3answers
38k views

Debian 5.0 (lenny) apt sources fail?

For the past few days, I couldn't update our apt-sources on Debian 5.0 (lenny). I get the following errors. W: Failed to fetch http://ftp.debian.org/debian/dists/lenny/main/binary-amd64/Packages 404 ...
0
votes
2answers
758 views

ERROR: Can't find the archive-keyring

I'm trying to upgrade my Debian Lenny to Squeeze. I've replaced the word lenny to squeeze in sources.list and ran apt-get clean apt-get update apt-get dist-upgrade But after a while, I get this ...
0
votes
2answers
287 views

Debian Installer not working

I get: dpkg: error processing linux-image-2.6-amd64 (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: linux-image-2.6.26-1-amd64 ...
2
votes
2answers
3k views

Why do I get GPG error when running apt-update for lenny-backports?

Alright, so I'm trying to upgrade (if you could call it so) to lenny-backports as seen here, but I ran into this error when running apt-get update: W: GPG error: http://backports.debian.org ...
0
votes
2answers
355 views

apt-get fails to, well, apt-get

I'm working on a virgin debian 5 image on a VPS. To be honest, this may not be the brightest VPS provider in the world and I suspect their image isn't perfect. apt-get fails for everything: # ...
2
votes
2answers
535 views

How to run Postgresql 8.2 on Debian lenny?

We are running a legacy application which requires PostgreSQL 8.2 on Debian Etch. Since Debian dropped support for etch, we're seriously considering to upgrade to Debian Lenny. However, we are stuck ...
2
votes
2answers
1k views

dist-upgrade to squeeze wants to remove apt

why does dist-upgrade to squeeze want to remove apt and how can I fix it? $ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done ...
2
votes
3answers
755 views

Upgrade from Debian Lenny to Squeeze with apt-get

I just upgraded my system from Lenny to Squeeze following the steps posted here. I followed all the steps using apt-get (in the upgrade from Etch to Lenny i used aptitude as suggested) and the upgrade ...
1
vote
2answers
431 views

Debian etch source list

I've an webserver that is still debian etch. My problem is I need to upgrade some packages but I can't find a source for debian etch anywhere. I have the following: ###### Debian Main Repos deb ...
3
votes
2answers
1k views

Can't get PostgreSQL to run in Debian Lenny

I'm trying to install PostgreSQL 8.3 on Debian Lenny (kernel 2.6.26-2-686) using the package manager: sudo apt-get install postgresql-8.3 postgresql-client-8.3 postgresql-contrib-8.3 ...
1
vote
1answer
765 views

Apt-Get “sources.list needs at least 1 source-URI” error when building dependecies for Xen

What i'm trying to do is install Xen in a test environment, now I am trying to run the: apt-get build-dep xen-3.3 command, but it keep throwing a error which literally translated from dutch ...
2
votes
3answers
4k views

Install Previous Version of PHP Package from Debian Testing Using Apt

Is there a way to install an older Debian testing repository version of a package using apt-get? Specifically, I am looking to install the latest version of PHP 5.2.x on Debian Lenny. The last time ...
3
votes
1answer
1k views

Installing Mercurial 1.5.1 on Debian Lenny

What's the easiest way to install Mercurial 1.5.1 on Debian Lenny? Can I safely install the package from the sid repository using apt-get, or should I compile it from the sources?
1
vote
1answer
660 views

Upgrading Subversion 1.5 to 1.6 on Debian 5

I would like to upgrade Subversion 1.5.1dfsg1-4 (from lenny) to 1.6.4dfsg-1~bpo50+1 (from lenny-backports) on my Debian 5 machine. Which steps do I need to take? Do I need to backup my repository, or ...
1
vote
4answers
2k views

how to upgrade already installed apache2 on debian (lenny)

I have an debian lenny box up and running with apache2 2.11.6 (this was testing stream some month agotesting some) Now on testing stream is 2.12.1 I want to upgrade my apache2, but not the other ...