0
votes
1answer
106 views

update nginx 1.4.4 to 1.4.5 trying to overwrite X which is also in package Y

I get this error while trying to upgrade: Preparing to replace nginx 1.4.4-4~raring (using .../nginx_1.4.5-1~raring_amd64.deb) ... Unpacking replacement nginx ... dpkg: error processing ...
0
votes
1answer
60 views

Adding modules to nginx-light (Debian / dotdeb)

http://packages.debian.org/testing/nginx-light http://packages.debian.org/testing/nginx-full Can I add modules to nginx-light installation that would only be available in nginx-full without ...
-1
votes
2answers
245 views

Can't install Nginx on Wheezy

I'm trying to install nginx on wheezy using this code in my deployment script: echo "deb http://nginx.org/packages/debian/ wheezy nginx" | sudo tee -a /etc/apt/sources.list echo "deb-src ...
0
votes
1answer
555 views

Upgrading nginx-full 1.2.1 to nginx 1.2.6 from PPA on Ubuntu 12.10

I'm trying to upgrade nginx 1.2.1 to version 1.2.6 on ubuntu 12.10, but with no luck. I've previously installed nginx using apt-get install nginx-full because I needed the modules instead of building ...
3
votes
1answer
221 views

nginx 1.2.3 installed but remains at 1.1.19

I've installed nginx 1.2.3 by adding a new ppa sudo add-apt-repository ppa:nginx/stable sudo apt-get update sudo apt-get install nginx However, nginx -v still gives me 1.1.19. What happened? ...
0
votes
1answer
1k views

How to install php5-fpm on debian?

I am trying to install php5-fpm on Debian 6.0.5 and after trying to install php5-fpm: E: couldn't find package php5-fpm Ok, so I tried to add non official repository: add-apt-repository ...
3
votes
4answers
1k views

I accidentally deleted /etc/nginx, reinstalling nginx won't recover it

I'm on Ubuntu and I was trying to recover the original settings of /etc/nginx/sites-enabled/default when I accidentally deleted the entire folder. Uninstalling and reinstalling nginx through apt-get ...
4
votes
3answers
6k views

How to install nginx and install the configuration files too

I've just completely uninstalled nginx 1.0.6 from my server (Ubuntu 11.04) using apt-get remove nginx rm -rf /etc/nginx/ rm -rf /usr/sbin/nginx rm /usr/share/man/man1/nginx.1.gz apt-get remove ...
0
votes
1answer
769 views

Installing nginx get “Broken packages”

I'm trying to install nginx apt-get install nginx on my Debian Lenny, but I can't cause of this: The following information may help to resolve the situation: The following packages have unmet ...
1
vote
2answers
1k views

Why do I get dependency warnings/errors while removing nginx from Ubuntu?

root@ubuntus:~# apt-get remove nginx-light Reading package lists... Done Building dependency tree Reading state information... Done Package nginx-light is not installed, so not removed You ...
2
votes
3answers
2k views

Recompile NGINX with “--with-http_stub_status_module” configure line

I've installed NGINX with sudo apt-get install nginx and now I'd like to recompile it with the configure option --with-http_stub_status_module. How can I do this, and is there a way I can not loose ...
0
votes
3answers
229 views

Apt getting wrong nginx source

I'm working on updating Nginx on my server from 0.7.65 (Ubuntu 10.04 repo) to 1.0.2 (from the PPA). I installed it just fine, but I would like to add/activate some modules. I found this tutorial for ...
1
vote
2answers
953 views

dpkg error installing on Ubuntu 10.04

I'm trying to install the nginx on ppa:nginx/stable on Lucid after removing the one that comes from the default sources but I get this error: ` Setting up nginx-common (0.8.54-4ppa13~lucid) ... ...
3
votes
3answers
3k views

how to get latest nginx using apt - ubuntu

I want to install the latest nginx using apt on ubuntu lucid. I followed the instructions on the nginx wiki and added the source: echo "deb http://ppa.launchpad.net/nginx/stable/ubuntu lucid main" ...
0
votes
3answers
85 views

Package Managers and Custom Installs?

Is it possible to use custom installs in conjunction with the package manager? For example, I would like to use apt-get to install EngineX because it will also install all the applicable ...