2
votes
2answers
80 views

Cannot install puppet because of unmet dependencies

I'm trying to install puppet on a fresh ubuntu 14.04 machine but I get the following error Some packages could not be installed. This may mean that you have requested an impossible situation or ...
0
votes
1answer
37 views

Notifying apt module “apt_update” from custom puppet module

I'm trying to configure APT to not install recommended packages. I'm using puppetforge puppetlabs/apt module so I wish to notify the Exec['apt_update'] resource from that module. I'm using this: ...
0
votes
2answers
789 views

Using puppet to ensure vagrant box is upgraded

I'm using puppet to provision a vagrant box (Ubuntu in this case). After initially starting the vagrant box (vagrant up), running apt-get upgrade will list several updates. I would like to run these ...
1
vote
2answers
315 views

Puppet - How to install git 1.8.x which isn't in default packages

How would you automate the installation of a specific version of git using puppet? apt-get update && apt-get install git-core on my 12.04 ubuntu server results in git version 1.7.9. I must ...
2
votes
1answer
163 views

Puppet: maintaining apt sources.list

I'm using puppet to maintain a growing pile of debian machines. These will be maintained from their initialization onwards. This means that one step will be setting the apt 'sources.list' file and ...
3
votes
1answer
74 views

Managing (and pinning) package versions with puppet

I have an installation that I'm trying to manage with puppet. For some of the packages we want to have very tight control over the versions. Since they are critical to our application, we only ...
3
votes
2answers
512 views

No APT Recommends with puppet

I use puppet to manage a bunch of Debian servers at work, part if that includes installing packages. One package I install on several systems is nmap which is used to verify that firewall rules are ...
3
votes
2answers
2k views

how to pass parameters to puppet modules?

What is the best practice for configuration of puppet modules? I have puppet 2.7.11. I find this way quite messy, it looks like using global variables. node default { $always_apt_update = true ...
4
votes
1answer
616 views

Why do signed deb packages say they're not authenticated when copied to my private deb repo?

Quick Version I have set up a private deb repository and copied some signed deb packages into it. I have installed the signing key locally. However when I try to install from the repo I get this ...
1
vote
1answer
410 views

How to install puppet devel from apt.puppetlabs.com?

According to the README at apt.puppetlabs.com the repo is added by wget http://apt.puppetlabs.com/puppetlabs-release-precise.deb dpkg -i puppetlabs-release-precise.deb but I only see the stable 2.7 ...
0
votes
1answer
281 views

fail to install jenkins with puppet

i'm on a ubuntu machine when i fail to install jenkins with puppet with the following error: /etc/puppet/modules/jenkins/manifests# puppet agent --no-daemonize --verbose notice: Starting Puppet ...
6
votes
2answers
2k views

Different puppet modules with one common resource

I am writing particular modules for the different roles of my servers. So I have a puppet and a puppet-dashboard-Module. The puppet module ensures that puppet is correct installed. The ...
3
votes
2answers
337 views

How to monitor package versions across multiple (Linux) servers

We use Puppet for installing the base level OS and packages, but our own application packages are deployed manually by individual developers. I'm looking for a web dashboard to view/monitor the ...
1
vote
1answer
199 views

Installed ruby from source on debian, apt-get no longer works due to failed dependencies, how do I fix it?

I installed ruby from source, and everything ruby related seems to work just fine. I can't install anything that depends on ruby using apt because I don't want 2 versions of ruby installed. After I ...
7
votes
1answer
2k views

How do I generate a response file to be used with apt-get or aptitude?

I need to install exim4 through puppet. Because this installation requires interactive configuration, I need a response file, but I don't know how to generate one. So, how do I generate a response ...