APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

1
vote
1answer
887 views

I manually deleted my /etc/php5/ config files and now they don't reinstall

I wanted a clean reinstall of php5-cli, php5-common, php5-fpm. So what I did was: rm -rf /etc/php5 rm -rf /usr/local/lib/php5 rm -rf /usr/local/php5 rm -rf /usr/lib/php apt-get autoremove php5* ...
1
vote
5answers
3k views

Cannot install mercurial properly - PYTHONPATH error

I have a server running on Ubuntu 10.04 on which I wanted to install Mercurial via % sudo apt-get install mercurial It seems to have installed successfully and doesn't show me any error messages. ...
1
vote
1answer
967 views

Can't get MySQL to install

I'd like to think I know what I'm doing in a Unix shell but maybe not. I made a mistake in a configuration file for MySQL, so I decided to just uninstall it and then reinstall it, so I did: sudo ...
1
vote
4answers
2k views

Ubuntu cannot resolve unmet dependency

I'm trying to install a package on my Ubuntu 8.10 server. However, I get this message: The following packages have unmet dependencies. webmin: Depends: apt-show-versions but it is not going to ...
1
vote
2answers
856 views

apt-get install giving 404

I'm something of a ubuntu newb. I'm trying to get subversion, so I enter: apt-get install subversion I'm getting a 404 on subversion and all its dependencies. E.g. Failed to fetch ...
1
vote
2answers
138 views

Make Aptitude respect get-selections list

We are several admins working on hundreds of debian servers. Some are using aptitude, some are using apt-get. To mark packages on hold, some use "echo $package hold | dpkg --set-selections", some use ...
1
vote
4answers
3k views

how to upgrade already installed apache2 on debian (lenny)

I have an debian lenny box up and running with apache2 2.11.6 (this was testing stream some month agotesting some) Now on testing stream is 2.12.1 I want to upgrade my apache2, but not the other ...
0
votes
3answers
5k views

Failed mysql upgrade to 5.5 on debian wheezy

When upgrading debian squeeze to wheezy, the upgrade of mysql to mysql-server-5.5 fails: # apt-get dist-upgrade -u ... Setting up mysql-server-5.5 (5.5.31+dfsg-0+wheezy1) ... [ ok ] Stopping MySQL ...
0
votes
3answers
3k views

Why do I get an initscript error when installing Samba using apt-get?

I'm attempting to solve this problem... Why does samba server fail to start with PANIC error? ... by reinstalling Samba, but I'm getting the following error: # apt-get install samba Reading ...
0
votes
2answers
2k views

wget works with company proxy but apt-get and dpkg doesn't

I am trying to install some software in a fresh install of Linux dnoseda 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux. I already set the variables http_proxy, ...