APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

1
vote
0answers
29 views

Pinning specific subsection in Debian

I'm trying to pin some packages from a specific subsection (gnome in this case) in Debian jessie. For subsection I mean: gnome, admin, x11, etc… This value is showed by apt-cache in the 'Section' ...
0
votes
1answer
139 views

Adding modules to nginx-light (Debian / dotdeb)

http://packages.debian.org/testing/nginx-light http://packages.debian.org/testing/nginx-full Can I add modules to nginx-light installation that would only be available in nginx-full without ...
1
vote
1answer
47 views

Update computers on private network

I have a small grid of computers that form an analysis cluster. One master node with internet on eth0, and a couple of private static IP workers connected to a switch. The master is also connected to ...
0
votes
1answer
119 views

Slow download speeds (own debian mirror)

I am using ftpsync to have a local version of the debian packages for all of our debian clients. Internally, the traffic from the mirror is at our normal LAN speeds (100 MB/s); however, when a ...
-2
votes
1answer
3k views

How to add debian “testing” repository to apt-get

I had difficulty searching for this answer on google and debian documentation! The FAQ page wasnt very clear either. I mean it wasnt 100% idiot-proof clear. https://wiki.debian.org/DebianTesting
-1
votes
1answer
27 views

Getting error while running apt-get update

I am getting the following error while running apt-get update on all of the servers. W: A error occurred during the signature verification. The repository is not updated and the previous index files ...
0
votes
1answer
366 views

Ubuntu 12.04: apt-get “failed to fetch”; apt is trying to fetch via old static IP

Sample error: W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/universe/i18n/Translation-en Unable to connect to 192.168.1.70:8118: Now this was working just fine ...
0
votes
0answers
39 views

Passenger package not found after adding phusion repo Ubuntu 12.04

I'm trying to install the official Passenger (and Nginx) packages from Phusion on an Ubuntu 12.04.3 server. I have the following in /etc/apt/sources.list.d/passenger: deb ...
0
votes
2answers
699 views

Debian: How to get rid of half-installed packages after aborted installation of kde-standard?

I accidentally executed "apt-get install kde-standard" on a system with a very small root partition (6 GB). The installation stopped when the disk was full. You can imagine the mess I have on the ...
0
votes
1answer
1k views

Virtualbox / Vagrant “closed by remote host” during routine use

I am attempting to install OpenTreeMap in a Ubuntu environment. Hosted at DigitalOcean, one of their "Droplets". As part of the install process I have installed and configured Virtual Box and Vagrant ...
1
vote
1answer
182 views

On Debian, how to audit installed packages against packages in a particular repository?

I manage a number of Debian servers and usually track the Debian stable repository but occasionally install from the Debian testing repository or third party sources. For audit purposes, on each ...
0
votes
1answer
2k views

Unable to locate package openjdk-7-jdk

I am using a base edition of Debian and am trying to install Java 7 on it using this command: root@server:~# apt-get install openjdk-7-jdk However, I end up getting this error: Reading package ...
0
votes
0answers
151 views

mysql-server-5.5 (5.5.32-0ubuntu0.12.04.1) … start: Job failed to start

Seems this issue is common but I cannot solve it. How do I reinstall mysql-server. Every time I try, I receive this crash message. Setting up mysql-server-5.5 (5.5.32-0ubuntu0.12.04.1) ... start: ...
1
vote
2answers
319 views

Puppet - How to install git 1.8.x which isn't in default packages

How would you automate the installation of a specific version of git using puppet? apt-get update && apt-get install git-core on my 12.04 ubuntu server results in git version 1.7.9. I must ...
2
votes
1answer
170 views

Puppet: maintaining apt sources.list

I'm using puppet to maintain a growing pile of debian machines. These will be maintained from their initialization onwards. This means that one step will be setting the apt 'sources.list' file and ...
0
votes
1answer
105 views

Fix security vulnerability in dnsmasq on Ubuntu 12.04

I have an Ubuntu 12.04 server using dnsmasq and recently ran into the following security vulnerability which does not seem to have a fix on 12.04. ...
0
votes
1answer
45 views

Deferring updates in cron-apt

Every day I get an email from cron-apt if there are updates available for my Debian systems (I use it in download-only mode). A typical email might look like CRON-APT RUN [/etc/cron-apt/config]: Tue ...
0
votes
2answers
147 views

nagios plugin for apt return code 3

I'm using a nagios plugin to check for apt updates. But sometimes (i think once a day) I get an error like this: Aug 11 14:05:27 Client nrpe[16668]: Connection from Server-IP port 2731 Aug 11 ...
2
votes
1answer
91 views

Can a single Apt-Cacher serve multiple Debian versions?

I have multiple machines running Debian 6 (Squeeze) and 7 (Wheezy). I set up an Apt-Cacher server on a Debian 7 box, for the Debian 7 instances to use. Can this also be used (with the same wheezy ...
1
vote
1answer
640 views

AWS Ubuntu 11.04 failing to apt-get update/upgrade

First, let it be known that it has been quite some time since I upgraded this particular server. When I execute sudo apt-get update most of the endpoints seem to be reached fine. However there are a ...
0
votes
1answer
113 views

How to create a init.d script for openssh-server which was compiled and installed from source using configure + make + make install?

I have installed openssh-server in my Ubuntu PC using apt-get install openssh-server. The version is 5.9. Now, I would like to compile and install openssh-server version 6.2 from source codes. I have ...
0
votes
1answer
193 views

How to automate changed config files during apt-get upgrade in Ubuntu 12

I like to use "knife cloudstack server create ..." to build a new VM. My bootstrap template starts off with an "apt-get update" and "apt-get -y upgrade". The upgrade then halts with: 10.190.113.11 ...
0
votes
0answers
418 views

Debian Wheezy - apt-get upgrade fault

Today I want to upgrade a server, but it lag on java 8 upgrade, I use Ctrl + C and stop upgrade, now when I want to upgrade, I have this problem: Can anybody help me? root@mg1:/home/system# apt-get ...
0
votes
0answers
306 views

apt-get upgrade broken due to failed apt upgrade

Ran an apt-get update and apt-get upgrade today on Ubuntu 12.04. And the process has become stuck trying to upgrade the apt package. It appears the post install script for apt is broken. And I can't ...
3
votes
0answers
75 views

reprepro use when multiple sources have the same codename

I'm investigating the use of reprepro to control what updates get propagated to our servers, and when. The idea is to vet updates by Debian and Ubuntu, and only apply the ones we choose. We want to ...
0
votes
2answers
3k views

why apt is not installing dependencies on Wheezy?

if I run # apt-get install sendmail Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
2
votes
0answers
289 views

Ubuntu 13.04: apt-get and check-new-release CPU bound

I own a virtual server hosted by a provider. A few hours ago I was notified about the VM being CPU-bound. I couldn't log in and rebooted the server. After the boot, apt-get and check-new-release were ...
0
votes
1answer
261 views

Failed to install ntp via apt-get in Debian

When trying to install ntp (because my server clock is wrong), it just pukes this massive error. Any idea how to fix this? root@pan-prodweb01:~# apt-get install ntp Reading package lists... Done ...
0
votes
1answer
26 views

Installation issue in Ubuntu

i wanted to install ufw in my ubuntu 10.04. but, when i try to instal ufw the apt-get installer stalls my progress by trying too install my-sql server, which i dont want to install right now. Is ...
0
votes
1answer
319 views

openvz: making directory /run/shm persistant?

I just upgraded my server to ubuntu 12.04. But the last updates failed because of an error with the update of the package 'initscripts': Setting up initscripts (2.88dsf-13.10ubuntu11) ... mkdir: ...
1
vote
1answer
44 views

One liner to display which debian packages are missing from one system when compared which another?

I am looking for a one line command that I could use to list all deb packages that are missing from a newly installed system, packages that are installed on a reference system (old one).
2
votes
0answers
63 views

Disallow virtual package in Debian's /etc/apt/preferences

I know I can disallow a particular package in Debian by appending /etc/apt/preferences with: Package: *x11* Pin: release Pin-Priority: -1 But how can I do that for a virtual package like httpd? I'd ...
0
votes
1answer
215 views

Removing sources from sources.list doesn't work

I had recently upgraded to php 5.4 but it was not working for me so I thought I'd remove php 5.4 and re-install php 5.3. I uninstalled php5.4, removed the dotdeb sources from sources.list file, ran ...
3
votes
1answer
74 views

Managing (and pinning) package versions with puppet

I have an installation that I'm trying to manage with puppet. For some of the packages we want to have very tight control over the versions. Since they are critical to our application, we only ...
0
votes
1answer
166 views

Squid3 for Debian updates with upstream proxy

I often need to setup new Debian servers, so I'm trying to setup a Squid proxy to cache apt-get updates/upgrades. But I always have a problem with some specific files it can retrieve. Details: i'm ...
3
votes
3answers
803 views

Is it usually safe to run “apt-get upgrade” (in terms of stability) on a production server?

I often log into my Ubuntu 12.04.2 server (with Postgres 9.2.4 running with live production data) and see something akin to: 4 packages can be updated. 4 updates are security updates. This happens ...
3
votes
2answers
519 views

No APT Recommends with puppet

I use puppet to manage a bunch of Debian servers at work, part if that includes installing packages. One package I install on several systems is nmap which is used to verify that firewall rules are ...
2
votes
1answer
131 views

Building the necessary dependencies when apt-get installing on Ubuntu

I've got an Ubuntu 12.04.2 server and I want to install Postgres 9.2.4. If I wanted to build all dependencies, I couldn't use apt-get build-dep (at least without some finagling) because only 9.1 is ...
2
votes
1answer
115 views

Concern about “apt-get update” in production server

I have a server which is getting a bit outdated as I haven't updated it since a few months. I wanted to try cron-apt but first wanted to do it manually, so I issued a sudo apt-get update as a ...
0
votes
3answers
3k views

Failed mysql upgrade to 5.5 on debian wheezy

When upgrading debian squeeze to wheezy, the upgrade of mysql to mysql-server-5.5 fails: # apt-get dist-upgrade -u ... Setting up mysql-server-5.5 (5.5.31+dfsg-0+wheezy1) ... [ ok ] Stopping MySQL ...
1
vote
1answer
901 views

Error after trying to install php5-mcrypt on Debian Squeeze

I want to install php5-mcrypt, but I get this error after entering a apt-get install php5-mcrypt Error: php5-mcrypt : Hängt ab von: php5-common (= 5.3.3-7+squeeze15) aber 5.3.9-1~dotdeb.2 soll ...
3
votes
1answer
282 views

Prioritise repositories in Ubuntu

We have a few PPA sources on some of our servers which we stick into /etc/apt/sources.list.d . Some of these repos provide same packages (in terms of names) but different versions and possibly ...
-1
votes
2answers
286 views

Can't install Nginx on Wheezy

I'm trying to install nginx on wheezy using this code in my deployment script: echo "deb http://nginx.org/packages/debian/ wheezy nginx" | sudo tee -a /etc/apt/sources.list echo "deb-src ...
1
vote
1answer
201 views

`apt remove` everything except nginx, its dependencies and packages vital to running the system

I have an Ubuntu server with the default package list installed. I'd like to uninstall everything that isn’t nginx, its dependencies, and any other packages required to boot to a tty and run nginx. ...
2
votes
2answers
198 views

Debian Squeeze: apt-get hangs on download packages from our local repository

hope you guys can help me find out a solution to this problem that's causing me headache. My company has a number of front end servers based upon Debian Squeeze, we also set up a local repository ...
1
vote
2answers
2k views

Configure apt to use proxy in vagrant box

I'm using Vagrant to setup a virtual machine for testing. I would like apt inside the virtual machine to use a proxy on the host machine to allow caching of all the downloads to persist between ...
0
votes
1answer
41 views

How to show uninstalled package size in Debian

Is there a way to show the package size without installing a package in Debian, using apt-get,dpkg or something similar (please don't say install YUM)?
0
votes
1answer
2k views

Removing MongoDB from Ubuntu

I recently started to mess with setting up ReplicaSets. After some testing and playing, I was wanting to remove MongoDB and all settings, and start with a fresh install on all systems to get it ...
-1
votes
1answer
92 views

Script to install and activate backports on debian squeeze?

I am looking for a script that would enable debian backports for debian squeeze, something that I could just run and will enable me to install new packages like a decent version of mercurial after, ...
13
votes
2answers
5k views

dpkg-reconfigure: unable to re-open stdin: No file or directory

I am building a provisioning script for a ubuntu vagrant vm, on a ubuntu host, both 12.10 64bit When installing the following packages: sudo apt-get -y install php5-xsl graphviz php-pear unison I ...