APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

-3
votes
1answer
327 views

mysql server restart failed

I want to recover my mysql root password so I have followed this tutorial and stopped the mysql server . when I am trying to start it its show a error message and won't start. I believe the error is ...
1
vote
3answers
770 views

apt-get not found on my VPS?

Today, I bought a Ubuntu 12.04 VPS from http://www.frontrangehosting.com, but when I access it via SSH, I can't use apt-get. [root@vps /]# apt-get install python-software-properties -bash: apt-get: ...
1
vote
1answer
358 views

Bug in PHP 5.3.10, how do I upgrade without apt?

I have a few Ubuntu boxes that run the newest version of PHP present in the Ubuntu package distributions (PHP 5.3.10). However, there is a bug in that PHP version that makes my application break. ...
1
vote
0answers
385 views

Server problems after upgrade [closed]

I have an Ubuntu 12.04 server at home. It was working fine utile yesterday when I did an apt-get upgrade. First problem : grub timeout is disabled. Bootup hangs on grub. Second problem : the ...
3
votes
2answers
174 views

Prevent a package from being uninstalled in Ubuntu

So, after an accidential fat finger with aptitude today, it wanted to uninstall mysql-server, this was on our database server. Since it was a pile of text, I just pressed Y, blindly trusting apt to ...
3
votes
1answer
197 views

Link all LXC node APT caches to the host machine's APT cache

I have a number of LXC containers (ubuntu template) which all have their own separate APT caches. /var/lib/lxc/*/rootfs/var/cache/apt/archives/ I would like to have these linked to the host ...
1
vote
0answers
100 views

why “apt-get update” can't be on demand? [closed]

Excuse me if my question is a bit dummy... But I always wonder why all package managers can't refresh their indexes on-demand. For example, when I do "apt-get install something", why it can't verify ...
0
votes
1answer
3k views

Fatal: module iscsi_trgt not found — trying to get my iscsi target to run on debian

Sorry about the formatting below... Linux Microknoppix 2.6.39.3 #21 SMP PREEMPT Sat Jul 23 09:48:39 CEST 2011 i686 GNU/Linux modprobe iscsi_trgt results in FATAL: Module iscsi_trgt not ...
4
votes
2answers
790 views

Chef recipe to install varnish 3.0 on ubuntu lucid?

Here's my problem. I want Varnish 3.0, but Lucid only has the 2.1 package available. So using Chef, I need to make an install recipe that adds the varnish-cache.org repository to the apt sources and ...
0
votes
1answer
2k views

How to install php5-fpm on debian?

I am trying to install php5-fpm on Debian 6.0.5 and after trying to install php5-fpm: E: couldn't find package php5-fpm Ok, so I tried to add non official repository: add-apt-repository ...
2
votes
2answers
2k views

How to update sources.list for Debian 4.0 Etch?

I am trying to update my /etc/apt/sources.list on my VPS. As I run apt-get update I get all kinds of 404s not found, for example: Failed to fetch ...
-3
votes
4answers
124 views

How do I install a package in Debian? [closed]

How do I install a package in Debian via SSH? In my case I'm looking to install OpenSSL, but the instructions could be for installing any other package as well. UPDATE: I did run into some issues ...
2
votes
1answer
636 views

Tunnel apt traffic from private network through public to the internet

I've got 4 Servers under the following config: Servers 1 and 3(Web Server, Mail server respectivelly): NIC1: Public Network, Connected to the Internet NIC2: Private Network, Communication between ...
0
votes
2answers
722 views

Xvfb on debian not installing properly from apt-get

I try to install xfvb for headless firefox and selenium tests, but after installing by: apt-get install xvfb I got only those files on server (search by xvfb): /usr/bin/xvfb-run /usr/share/doc/xvfb ...
1
vote
1answer
399 views

How to install puppet devel from apt.puppetlabs.com?

According to the README at apt.puppetlabs.com the repo is added by wget http://apt.puppetlabs.com/puppetlabs-release-precise.deb dpkg -i puppetlabs-release-precise.deb but I only see the stable 2.7 ...
0
votes
2answers
429 views

Ubuntu LTS repository package update policy

I recently realized that even though Ubuntu LTS is receiving 5 years of support, a lot of the packages in Ubuntu LTS package repository are not updated with the latest stable releases. For example, ...
0
votes
1answer
507 views

Dependency issue installing libpq-dev on Ubuntu 11.10

I'm trying to install libpq-dev (PostgreSQL library) on Ubuntu 11.10. When I run apt-get I get the following: The following packages have unmet dependencies. libpq-dev : Depends: libkrb5-dev but it ...
3
votes
2answers
2k views

Vagrant/VirtualBox can't resolve some domains from w/in VM

Just trying out VirtualBox & Vagrant and my initial lucid64 VM can't resolve us.archive.ubuntu.com but can resolve security.ubuntu.com, google.com and www.apple.com (but not apple.com w/out the ...
1
vote
1answer
663 views

Where does apt-get or aptitude update download package lists to?

I am having trouble with aptitude update and apt-get update not downloading a certain list file (specifically http://gb.archive.ubuntu.com precise/universe Sources [5,019 kB]). I can download it ...
2
votes
2answers
2k views

Installing php5-imagick in Ubuntu 12.04 w/ ondrej packages results in dependency error

I've been trying to setup an Ubuntu 12.04 VM that is running PHP 5.4 with the imagick module. All the results I find on google say to use the ondrej packages, which for the most part works perfectly. ...
12
votes
2answers
4k views

Passing default answers to apt-get package install questions?

I'm trying to write a configuration script for new servers, and one of the first steps is to install a series of required packages, such as MySQL, phpMyAdmin, etc. using apt-get install However, when ...
7
votes
2answers
539 views

apt: how to search using package tags?

Some (most?) packages in Debian, have tags. For example: =# apt-cache show squirrelmail | perl -lne 'print if /^Tag:/.../^\S/' Tag: implemented-in::php, interface::web, mail::imap, mail::smtp, ...
5
votes
1answer
112 views

Minimising downtime during apt-get upgrades

Running apt-get update, there are a few hundred minor patches to apply. APT decides to stop postgres from running, spend 20 minutes applying all the patches, then starts postgres at the end. If I ...
0
votes
1answer
184 views

Can't seem to install the correct version of PHP, using apt-get install

I'm using Ubuntu 11.04 LTS server, it's a new install on a VPS box from MediaTemple (their ve server). I'm trying to install PHP 5.4.3 on this box, but I'm having a common problem not matter what ...
-1
votes
1answer
60 views

prevent apt dependency from being satisfied (permanently)

I want to install mailman (just to use it's mail archiving feature) but Ubuntu wants to pull down a load of extra dependencies. sudo apt-get install mailman Reading package lists... Done Building ...
-1
votes
1answer
971 views

Debian: How to get rid of openoffice/libreoffice?

After upgrade from Squeeze to Wheezy (testing), I end up with few errors when running apt-get upgrade further. Most of the errors concern openoffice.org and libreoffice, both of which I do not need. ...
0
votes
2answers
2k views

update from debian lenny to squeeze

I'm trying to update from debian lenny to squeeze on my 64bit root server and did the following so far: modifying sources.list apt-get update apt-get upgrade apt-get install linux-image-2.6-amd64 ...
1
vote
2answers
2k views

Where to find URLs for sources.list for debian for running apt-get update?

Can anyone tell me where to find URLs to put in /etc/apt/sources.list for debian so that I could run apt-get update? I couldn't find the precise answer by searching Google. When I currently try ...
-1
votes
0answers
1k views

Regarding Reinstalling PostgreSQL [closed]

I was using PostgreSQL 8.4. I tried removing it through Synaptic Manager and then I tried to install 9.1, but I still version 8.4. I deleted all the files associated with postgresql. Now I am unable ...
1
vote
3answers
441 views

Prevent dependency from being installed with APT

I have this script line to install all packages for a new server. apt-get install mysql-server openjdk-7-jre-headless tomcat7 tomcat7-admin jsvc apache2 ntp subversion As you can see it installs ...
0
votes
1answer
226 views

apt-get update Error

I get the following error when typing: # apt-get update W: Failed to fetch http://etc.inittab.org/~agi/debian/libapache-mod-security2/etch/Packages 404 Not Found [IP: 80.28.139.208 80] E: Some ...
0
votes
1answer
423 views

Can't remove partially-installed extension

I'm on an Ubuntu 11.10 server with PHP 5.4 installed from a PPA. I had the MySQL library installed (php5-mysql) but wanted to try out the native driver (php5-mysqlnd), so I ran sudo apt-get install ...
0
votes
1answer
246 views

Resolving unmet dependancy in ubuntu 10.04

I am geeting the folowing error when i tried installing beanstalkd (sudo apt-get install beanstalkd) and I even tried -f option but none helped what can id do Reading package lists... Done Building ...
0
votes
1answer
1k views

Issues installing apache debian

I'm having issues installing apache2, and pretty much everything in general, I'm using debian. I run sudo apt-get install apache2 and then it returns root@debian:~# apt-get install apache2 Reading ...
1
vote
2answers
750 views

Node.js installation on Debian 6

I used to use this method for node.js installation on Debian, since it was easy and everything worked fine. Even with multiple users. Since version 0.6.18~dfsg1-1 of the sid package, installation ...
-1
votes
1answer
178 views

Bash installing script that fits all common Linux flavors

I was asked by my boss to make a bash script that could install Apache, PHP and MySQL (AMP) binaries in a Linux box (just some common linux flavors). Compile and install all by the sources ...
0
votes
1answer
258 views

fail to install jenkins with puppet

i'm on a ubuntu machine when i fail to install jenkins with puppet with the following error: /etc/puppet/modules/jenkins/manifests# puppet agent --no-daemonize --verbose notice: Starting Puppet ...
3
votes
1answer
7k views

apt-get cannot connect “failure resolving 'archive.ubuntu.com'”

Just got a new VPS running Ubuntu 11.04 and tried to update it. I got this error. I get the same error whenever using apt-get login as: root root@199.193.248.80's password: Welcome to Ubuntu 11.04 ...
0
votes
2answers
149 views

apt-get being strange

Normally sudo apt-get install gets me what I want with no issues, it installs dependencies and takes away a lot of the hassle. For some reason it's stopped working now. $ sudo apt-get install ...
6
votes
2answers
2k views

Different puppet modules with one common resource

I am writing particular modules for the different roles of my servers. So I have a puppet and a puppet-dashboard-Module. The puppet module ensures that puppet is correct installed. The ...
1
vote
4answers
5k views

How do I install the latest version of Sphinx Seach in Apt-get?

When I do "sudo apt-get install sphinxsearch", I get version 0.9. I want the latest stable version (which is 2.4, I believe) How can I do that using aptitude?
5
votes
2answers
794 views

Should I install MongoDB using Ubuntu's repository or MongoDB's private repository?

I was reading the MongoDB install instructions and noticed they have a private repository that the instructions tell you to add. I'm wondering if this is really needed because MongoDB is also in the ...
0
votes
1answer
613 views

I alternated my system default python version to python2.7, but the apt-get still use python2.6

Ubuntu , I changed my system default python version from python2.6 -> python2.7. after sh-3.1$: update-alternatives --install /usr/bin/python python /usr/bin/python2.7 2 sh-3.1$: sudo ...
0
votes
1answer
491 views

E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm getting an error while trying to update the linux-image-2.6.32-5-amd64 package on Debian 6, x64. Setting up linux-image-2.6.32-5-amd64 (2.6.32-41squeeze2) ... Running depmod. Running ...
0
votes
3answers
2k views

How to Undo apt-get remove?

I know it is funny situation but i removed python with all associated programs from Ubuntu using sudo apt-get remove python? Obviously i can install back python, but it will take me a lot of time to ...
0
votes
1answer
256 views

404 for packages install libmysqlclient15-dev

I try to install mysql-dev package on Debian Lenny webserver. On my local home server, the same version it installs right but on the webserver I get a strange error. I hope someone can help me with ...
3
votes
1answer
211 views

Creating custom DEB packages of common programs

I have an increasing number of servers running Debian or Ubuntu with customized versions of Apache, PHP, etc. I thought I might be able to save time by creating my own APT source and putting ...
2
votes
1answer
2k views

apt-get install build-essentials fails on Ubuntu 11.10 on aws ami-baba68d3

I was trying to install and configure Xabbix on an ubuntu server. Following their instructions on the wiki the first step fails: sudo apt-get install build-essential I get the following error ...
2
votes
1answer
925 views

mdadm warning after apt-get upgrade - can't boot RAID

I'm running Ubuntu 12.04 precise. A recent apt-get upgrade ended successfully, but printed the following warning at the end: update-initramfs: Generating /boot/initrd.img-3.2.0-21-generic W: mdadm: ...
0
votes
1answer
366 views

Installation of mysql-server crashed, can't reinstall

I tried to install the mysql-server package on my Ubuntu VPS. The apt-get process crashed and I had to kill it. Now I have this error message whenever I try to install it again: $ sudo apt-get ...