APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

0
votes
1answer
28 views

Installation issue in Ubuntu

i wanted to install ufw in my ubuntu 10.04. but, when i try to instal ufw the apt-get installer stalls my progress by trying too install my-sql server, which i dont want to install right now. Is ...
0
votes
1answer
468 views

openvz: making directory /run/shm persistant?

I just upgraded my server to ubuntu 12.04. But the last updates failed because of an error with the update of the package 'initscripts': Setting up initscripts (2.88dsf-13.10ubuntu11) ... mkdir: ...
1
vote
1answer
47 views

One liner to display which debian packages are missing from one system when compared which another?

I am looking for a one line command that I could use to list all deb packages that are missing from a newly installed system, packages that are installed on a reference system (old one).
3
votes
1answer
81 views

Disallow virtual package in Debian's /etc/apt/preferences

I know I can disallow a particular package in Debian by appending /etc/apt/preferences with: Package: *x11* Pin: release Pin-Priority: -1 But how can I do that for a virtual package like httpd? I'd ...
0
votes
1answer
409 views

Removing sources from sources.list doesn't work

I had recently upgraded to php 5.4 but it was not working for me so I thought I'd remove php 5.4 and re-install php 5.3. I uninstalled php5.4, removed the dotdeb sources from sources.list file, ran ...
3
votes
1answer
96 views

Managing (and pinning) package versions with puppet

I have an installation that I'm trying to manage with puppet. For some of the packages we want to have very tight control over the versions. Since they are critical to our application, we only ...
0
votes
1answer
218 views

Squid3 for Debian updates with upstream proxy

I often need to setup new Debian servers, so I'm trying to setup a Squid proxy to cache apt-get updates/upgrades. But I always have a problem with some specific files it can retrieve. Details: i'm ...
7
votes
3answers
2k views

Is it usually safe to run “apt-get upgrade” (in terms of stability) on a production server?

I often log into my Ubuntu 12.04.2 server (with Postgres 9.2.4 running with live production data) and see something akin to: 4 packages can be updated. 4 updates are security updates. This happens ...
6
votes
2answers
970 views

No APT Recommends with puppet

I use puppet to manage a bunch of Debian servers at work, part if that includes installing packages. One package I install on several systems is nmap which is used to verify that firewall rules are ...
2
votes
1answer
260 views

Building the necessary dependencies when apt-get installing on Ubuntu

I've got an Ubuntu 12.04.2 server and I want to install Postgres 9.2.4. If I wanted to build all dependencies, I couldn't use apt-get build-dep (at least without some finagling) because only 9.1 is ...
2
votes
1answer
173 views

Concern about “apt-get update” in production server

I have a server which is getting a bit outdated as I haven't updated it since a few months. I wanted to try cron-apt but first wanted to do it manually, so I issued a sudo apt-get update as a ...
0
votes
3answers
5k views

Failed mysql upgrade to 5.5 on debian wheezy

When upgrading debian squeeze to wheezy, the upgrade of mysql to mysql-server-5.5 fails: # apt-get dist-upgrade -u ... Setting up mysql-server-5.5 (5.5.31+dfsg-0+wheezy1) ... [ ok ] Stopping MySQL ...
1
vote
1answer
1k views

Error after trying to install php5-mcrypt on Debian Squeeze

I want to install php5-mcrypt, but I get this error after entering a apt-get install php5-mcrypt Error: php5-mcrypt : Hängt ab von: php5-common (= 5.3.3-7+squeeze15) aber 5.3.9-1~dotdeb.2 soll ...
3
votes
1answer
536 views

Prioritise repositories in Ubuntu

We have a few PPA sources on some of our servers which we stick into /etc/apt/sources.list.d . Some of these repos provide same packages (in terms of names) but different versions and possibly ...
-1
votes
2answers
343 views

Can't install Nginx on Wheezy

I'm trying to install nginx on wheezy using this code in my deployment script: echo "deb http://nginx.org/packages/debian/ wheezy nginx" | sudo tee -a /etc/apt/sources.list echo "deb-src ...
1
vote
1answer
211 views

`apt remove` everything except nginx, its dependencies and packages vital to running the system

I have an Ubuntu server with the default package list installed. I'd like to uninstall everything that isn’t nginx, its dependencies, and any other packages required to boot to a tty and run nginx. ...
2
votes
2answers
321 views

Debian Squeeze: apt-get hangs on download packages from our local repository

hope you guys can help me find out a solution to this problem that's causing me headache. My company has a number of front end servers based upon Debian Squeeze, we also set up a local repository ...
1
vote
2answers
3k views

Configure apt to use proxy in vagrant box

I'm using Vagrant to setup a virtual machine for testing. I would like apt inside the virtual machine to use a proxy on the host machine to allow caching of all the downloads to persist between ...
0
votes
1answer
46 views

How to show uninstalled package size in Debian

Is there a way to show the package size without installing a package in Debian, using apt-get,dpkg or something similar (please don't say install YUM)?
0
votes
1answer
3k views

Removing MongoDB from Ubuntu

I recently started to mess with setting up ReplicaSets. After some testing and playing, I was wanting to remove MongoDB and all settings, and start with a fresh install on all systems to get it ...
-1
votes
1answer
129 views

Script to install and activate backports on debian squeeze?

I am looking for a script that would enable debian backports for debian squeeze, something that I could just run and will enable me to install new packages like a decent version of mercurial after, ...
21
votes
4answers
10k views

dpkg-reconfigure: unable to re-open stdin: No file or directory

I am building a provisioning script for a ubuntu vagrant vm, on a ubuntu host, both 12.10 64bit When installing the following packages: sudo apt-get -y install php5-xsl graphviz php-pear unison I ...
0
votes
1answer
53 views

Force apt-get not to upgrade a custom package dkpg [duplicate]

I've created my own deb package for Redis 2.6.11 instead of the very old default version for Ubuntu. All works well except when I do an apt-get upgrade it tries to install what it thinks is the latest ...
0
votes
1answer
351 views

Apt-get hangs at first repo

When I perform an apt-get upgrade or apt-get update, I notice that it can take almost a minute when connecting to a repo. For example, when doing a aot-get upgrade, it will be stuck for about a ...
0
votes
1answer
115 views

Difference between unattended-upgrade & apt-get dist-upgrade

Assume I need to write a cron job to automate the installation of security update daily, which command I should use for better reliability?
0
votes
1answer
446 views

installed post-installation script returned error exit status 1

I found many complains with same error but for different packages. However, i couldn't understand essence of this error and how to fix it. Pls. help if you have any clue about it. It appeared first ...
1
vote
2answers
81 views

Updating db server with no internet connection

I have a database server running Ubuntu 12.04. The db server is connected to a load-balancer(HAProxy) on a LAN network and the LB is connected to the internet. So the db server has no direct ...
1
vote
1answer
5k views

Debian apt-get update won't work

I have a Debian machine (Linux debian 2.6.32-5-amd64 #1 SMP Fri Feb 15 15:39:52 UTC 2013 x86_64 GNU/Linux) running behind a NAT with a couple of ports forwarded for SSH and Web. I can access the web ...
0
votes
1answer
569 views

Apt-get error when upgrading mysql from running out of room

I ran out of room on my drive on an ec2 instance and it mounted the overflow /tmp space. I noticed this when I did an apt-get update/upgrade and the upgrade failed because it had no more room on tmp. ...
1
vote
1answer
75 views

How to apt-get install a package for Ubuntu Quantal from Ubuntu Precise 12.04

On Ubuntu Precise 12.04, the package osm2pgsql is currently at 0.70.5+r25090-2ubuntu2. However I need to install a newer version 0.80 but apt-get update does not provide the newer version. Question: ...
0
votes
1answer
221 views

Ubuntu 12.04 Server on VMWare - apt-get failing to hit repos

So, I have an Ubuntu 12.04 LTS 64-bit server instance running on VMWare player. Everything appears fine at the surface. Even internet connectivity appears good as I can perform both pings out to ...
0
votes
1answer
133 views

Downgrade php5-cgi using APT on Debian

I have lighttpd install with PHP5.4 installed I need to downgrade it to 5.3.2 (possibly older/newer) but I can't install it I tried this apt-get install php5-cgi=5.3.2 but it says "E: Version ...
11
votes
2answers
608 views

SSH session never closes when executing “apt-get install”

Problem When running apt-get install in an SSH session, the session never closes. Example: ssh user@target "sudo apt-get -y install my_package" The my_package does get installed properly, but the ...
1
vote
1answer
454 views

Using snapshots with reprepro to enable rollbacks

I'm using reprepro to maintain a Private Package Archive of internal packages. There is no straightforward way to keep multiple version of a package available using reprepro (see here), but it does ...
1
vote
2answers
130 views

Search for installed unavailable packages (backports and 3rd party)

I would like to remove any packages that I installed from third party repositories. I recently installed some backports from PPA repositories, and I suspect one of them broke my Ubuntu 12.04 server ...
1
vote
1answer
1k views

TurnKey LAMP can't install PHP GD Library

When I try to install the GD Library for PHP on my TurnKey LAMP appliance, I get the following message: root@lamp ~# apt-get install php5-gd Reading package lists... Done Building dependency tree ...
0
votes
2answers
293 views

How to inform Ubuntu 12.04 apt-get about older installed version of php

I asked this on stackoverflow, but I think it was the wrong audience/forum Recently installed php5.3.22 on Ubuntu 12.04 from an excellent install script. This works perfectly. The issue I have is ...
0
votes
1answer
296 views

Debian // synchronize packages/version between multiple servers

I'm currently managing a dozen servers. apt-cacher-ng is installed on the development server to maintain the packages. The idea is to have exactly the same version and number of packages on the ...
4
votes
3answers
6k views

how to pass parameters to puppet modules?

What is the best practice for configuration of puppet modules? I have puppet 2.7.11. I find this way quite messy, it looks like using global variables. node default { $always_apt_update = true ...
1
vote
1answer
70 views

Debian 6 Synaptic Package Monitor checkboxes are acting like no software is installed

I was playing with package manager on my debian squeeze, was trying to install php 5.4 instead of php 5.3 and now it acts like everything is removed, I dont see any green "checkboxes" on already ...
0
votes
1answer
121 views

apt-get authentication error in OpenVZ Debian container

Whenever I receive upgraded packages from security.debian.org, I get the following error: WARNING: The following packages cannot be authenticated! apache2 apache2-mpm-prefork apache2.2-common ... ...
1
vote
1answer
1k views

I manually deleted my /etc/php5/ config files and now they don't reinstall

I wanted a clean reinstall of php5-cli, php5-common, php5-fpm. So what I did was: rm -rf /etc/php5 rm -rf /usr/local/lib/php5 rm -rf /usr/local/php5 rm -rf /usr/lib/php apt-get autoremove php5* ...
1
vote
1answer
1k views

apt upgrade error on My Book Live [closed]

I have a WD My Book Live network drive (http://www.wdc.com/en/products/products.aspx?id=280) on my LAN. I can SSH on the network drive which seems to run Debian: >> cat /etc/issue Debian ...
4
votes
1answer
1k views

Unattended upgrades doesn't upgrade (or does nothing at all)

I've been trying to make the package unattended-upgrades running under Debian GNU/Linux (7.0) with no success so far. The steps I have followed: Install unattended-upgrades Enable it sudo ...
0
votes
2answers
285 views

install package from debian backports pool

I want to upgrade my dovecote installation to version 2. I discovered the package here. I also already added deb http://backports.debian.org/debian-backports squeeze-backports main to my sources.list. ...
2
votes
1answer
1k views

apt-get proxy for specific repos?

Please bear with me, I've searched as best I can with no apparent solutions. I'm behind my companies firewall, we have a couple of proxy servers that we can use to get out onto the big wide internet. ...
2
votes
1answer
4k views

Chef Opscode apt cookbook - apt-get install returned 100, expected 0

I'm running Chef solo (version 11.4.0) on a clean VPS with Ubuntu 12 installed, and I'm having some problems with apt. The problem was that any package command raised an error: Chef::Exceptions::Exec ...
1
vote
0answers
67 views

Can't run any apt-get update without killing server

I have an ubuntu 12.04.2 that dies after I tried to do an upgrade on it. E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. So I run that and get the ...
0
votes
1answer
183 views

debsecan won't launch on debian wheezy

I've insalled the package debsecan in debian wheezy with 3.7.1 kernel. when I try to run it it gives me this output: error: while downloading ...
1
vote
2answers
553 views

Can't find the archive-keyring on amazon instance

Im relatively new to this so please bear with me .. Im running an amazon instance with ubuntu 11.10 and after performing apt-get upgrade everything with my package manager went haywire if i try ...