APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

5
votes
4answers
3k views

In Ubuntu Linux, how do I list packages installed from the “universe” repository?

On an Ubuntu 10.04 LTS server, I want to list installed packages and see what repository they come from. It’s easy to list installed packages, but it does not include the name of the repository (such ...
2
votes
1answer
16 views

Finding source repository for Debian packages

I have a Debian wheezy server which has many sources configured under /etc/apt There's seems to be a lot of duplicate sources, and I would like to simplify this. In order to avoid breaking anything, ...
1
vote
2answers
28 views

Debian: error in upgrade script?

I just ran apt-get update and upgrade to get the latest updates for my Debian stable server. It included a bunch of PHP5 updates. One (libapache2-mod-php5) threw an error: ERROR: php5 module already ...
6
votes
3answers
138 views

Conflicts with PAM configuration files when upgrading system

I have a VPS that runs Ubuntu 14.04.4 LTS; it was installed as a whole with Plesk by OVH. I juste did a apt-get upgrade, and at some point I had a message regarding PAM. The system is in French, but ...
2
votes
2answers
5k views

Ubuntu14.04 - unable to apt-get update

sudo apt-get update returns some erors : W: Failed to fetch http:// archive.ubuntu.com/ubuntu/dists/trusty/Release Unable to find expected entry 'restricted/source/Sources' in Release file ...
5
votes
3answers
3k views

What does -qq argument for apt-get mean?

I just received a Vagrantfile and post install bash script. The vagrantfile downloads standard Ubuntu from Ubuntu Cloud but I found something in the bash script. Few lines of script reads as: ...
0
votes
0answers
18 views

Curator cannot be installed even python is installed OK

I'm trying to install curator via apt repo on my debian wheezy. I went thru official documentation on elastic.co, added repo and GPG key and tried to install curator with apt-get install ...
0
votes
1answer
1k views

ssh'ing via a proxy, but connect is not found

I installed debian from a business card cd iso (basically a very stripped down version of it). I am trying to ssh to a machine via a proxy (set up in my .ssh/config), but am receiving an error: ssh ...
26
votes
11answers
13k views

Find last time update was performed with apt-get

I need to find the last time that the apt-get update command was run on my server. How can I determine this information?
12
votes
5answers
4k views

Running apt-get autoremove with ansible

I maintain a flock of EC2 servers with ansible. The servers are regularly updates and upgraded using the apt module. When I manually tried to upgrade a server, I received the following message: $ ...
15
votes
4answers
24k views

Unable to install mysql-server in Ubuntu

I am unable to install mysql-server on my ubuntu 9.10 server machine. When using apt-get install mysql-server the output is : # apt-get install mysql-server Reading package lists... Done Building ...
1
vote
1answer
1k views

Ubuntu 12.04 PHP 5.3 to 5.5 update fails

on a Ubuntu 12.04 Server I´m trying to update PHP 5.3 to 5.5 this is what I have done: sudo add-apt-repository ppa:ondrej/php5 sudo apt-get update sudo apt-get install php5 unfortuntely the ...
0
votes
0answers
7 views

Quite Apt-get Install but Prompt for Input

I am trying to figure out a way to quietly install Java, without all the installation text, but still get the user agreement prompt. Is this possible?
0
votes
3answers
44 views

Bash if condition to check if a ubuntu package needs an upgrade?

I need a bash line to check if a ubuntu package needs an upgrade or not. For example, I want to check if the package 'firefox' needs an upgrade using dpkg or apt-get commands. Hypthetical Example: ...
1
vote
1answer
18 views

apt-get remove package that didn't install properly

I accidentally installed zabbix-frontend-php that pulled apache2 as a dependency. I don't want to use either, and I want to completely delete both packages. Unfortunately, it seems that apt-get ...
0
votes
2answers
1k views

Cannot upgrade PostgreSQL on Ubuntu

When I run apt-get upgrade, I get the following error : dpkg: dependency problems prevent configuration of postgresql-9.1: postgresql-client-9.1 (9.1.7-0ubuntu12.04) breaks postgresql-9.1 (<< ...
0
votes
1answer
2k views

apt-get update can not connect

i run a dedicated ubuntu 10.04 server. i use kvm/libvirt/virsh to run a virtual machine that's also ubuntu 10.04. i bridged the network (1 of 2 IPs is routed via NAT to the LAN, where my VM ...
1
vote
0answers
48 views

Issues installing R package, r-base; Ubuntu 14

I am having a massive headache trying to install R. I go to install r-base and I get the following. root@10:/etc/apt > apt-get install r-base Reading package lists... Done Building dependency ...
40
votes
6answers
36k views

How do I get the history of “apt-get install” on Ubuntu?

I am about do move a server from one Ubuntu box to another. I'm not cloning the old box to the new; I'm creating a new system and will move data as needed. I want to install all the software that I ...
0
votes
1answer
43 views

apt-cacher ng “an error occured while reading this file, some contents may have been ignored.”

I've been getting the following message every day from the apt-cacher-ng cron job: /etc/cron.daily/apt-cacher-ng: Error(s) occured while updating volatile index files for apt-cacher-ng. Please visit ...
0
votes
2answers
2k views

Duplicate sources.list during apt-get update

I wanted to install PostGIS on my server which already have a PostgreSQL installed. I followed this PostGIS installation manual. I inputted this script: sudo sh -c 'echo "deb ...
0
votes
0answers
110 views

Unable to locate package landscape-server-quickstart

Any idea why landscape-server-quickstart isn't being found? According to both this AskUbuntu post and the official Landscape 15.11 installation instructions, the following commands should install ...
4
votes
1answer
139 views

reprepro use when multiple sources have the same codename

I'm investigating the use of reprepro to control what updates get propagated to our servers, and when. The idea is to vet updates by Debian and Ubuntu, and only apply the ones we choose. We want to ...
1
vote
0answers
48 views

Using Debian's unattended-upgrades package

I'm trying to have all official packages from Debian be upgraded on a Wheezy box - I've set the following: "o=Debian,a=oldstable"; "o=Debian,a=oldstable-updates"; "o=Debian,a=oldstable-backports"; ...
0
votes
1answer
17 views

How to tell apt-get that a package is OK and does not need any more attention

I have a broken Ubuntu 14.04 server. Everything is OK except for apt-get, which for some reason thinks that it repeatedly fails to update mysql server package. The mysql server is updated and works ...
13
votes
3answers
775 views

SSH session never closes when executing “apt-get install”

Problem When running apt-get install in an non-interactive SSH session, the session never closes. Example: ssh user@target "sudo apt-get -y install my_package" The my_package does get installed ...
11
votes
6answers
38k views

Debian. How can I securely get debian-archive-keyring, so that I can do an apt-get update? NO_PUBKEY

I have a catch 22 trying to: # apt-get update [... good lines omitted] W: GPG error: http://backports.debian.org lenny-backports Release: The following signatures couldn't be verified ...
6
votes
2answers
15k views

yum equivalent to apt-get upgrade vs apt-get dist-upgrade?

I'm a *.deb guy and I feel quite uncomfortable while managing rpms. I'm used to run apt-get upgrade in my debian based servers for "normal" upgrades and apt-get dist-upgrade for allowing kernel ...
1
vote
1answer
35 views

When does a Debian server require restart? [duplicate]

I have Debian 8.3 installed on my vServer, hosting websites and other applications. For instance, my VM didn't boot properly after my hoster rebooted the node. So there must be something that gets ...
0
votes
0answers
42 views

sh: x-terminal-emulator: command not found

I got this message during apt-get upgrade in my Ubuntu server 14.04, and I have no idea what is it. E: changelog for this version is not (yet) available; try ...
2
votes
3answers
2k views

EC2 Ubuntu 14.04 instances: running `apt-get update` results in “Hash Sum mismatch”

Every time I create a new AWS EC2 instance with Ubuntu 14.04 (using ami-a182b391, as found from here) and then immediately run sudo apt-get -y update, it gives me an error. Here's the OS info: $ ...
0
votes
1answer
39 views

Unattended upgrades not running under Ubuntu 14.04

I have a bunch of servers running Ubuntu 14.04. They all have the unattended-upgrades package installed. I've created a file called: /etc/apt/apt.conf.d/local-50-unattended And I've added the file ...
1
vote
2answers
86 views

Does Debian or Ubuntu have a means of logging apt/aptitude commands?

Does Debian or Ubuntu have a means of logging apt/aptitude commands? I could also ask the same about yum commands in Redhat? Do they have a history file?
1
vote
1answer
15 views

Percona Server keeps throwing errors on Ubuntu, but i cant remove it

I attempted to install percona's tools on ubuntu and had issues. I abandoned the idea of using it. Now upon removal it keeps kicking this error: The following packages will be REMOVED: ...
0
votes
1answer
41 views

docker - unable to find package (two servers with same setup except version)

Does newer Docker have different source list or something? a# docker --version Docker version 1.10.1, build 9e83765 b# docker --version Docker version 1.9.1, build a34a1d5 Install goes through the ...
1
vote
0answers
107 views

apt update blocked by cyclical dependices

I have Debian running on a VPS instance that is kept alive for a little site/project that is used by a small user base on an irregular basis. The server is largely left alone but I try to login every ...
39
votes
9answers
73k views

How do I get apt-get to ignore some dependencies?

How do I make apt-get ignore some dependencies? For example, I wanted to install mailx so I can use it to send email from cron scripts/report-generating tools. However, installing mailx also installs ...
0
votes
1answer
371 views

failed to install docker on Debian 8

This is the first time I deal with Debian, and I need a docker. I was following https://docs.docker.com/engine/installation/linux/debian/ to get it installed, however I faced the error: % apt-get ...
2
votes
2answers
6k views

How to install build-essential on Ubuntu 12.04? (gcc and g++ dependency issues)

I have just installed Ubuntu server 12.04 LTS. I am trying to install build-essential package; however, when I try to install it I receive the following error: Some packages could not be installed. ...
1
vote
1answer
29 views

postgresql installation failed with apt-get

I'm running on an AWS Ubuntu image. In an attempt to set up my machine, I played around with apt-get to add and remove PostgreSql and some of its modules. Now, when I run sudo apt-get install ...
0
votes
1answer
47 views

apt-get maddeningly doesn't work with tsocks proxy set up with ssh

I have a machine that cannot access the internet, yet can connect to a machine that does. I don't want to use a proxy server, I've been told that I can just use ssh. So I've proceeded simply by ssh ...
8
votes
6answers
8k views

Using a self-signed SSL cert for an HTTPS-based internal APT repository

I've set up a Debian repository (Ubuntu actually) for internal use with some private packages, and now want to make it available over the web to some specific servers. I would like apt-get / aptitude ...
0
votes
1answer
21 views

Do I need to remove Apache2 before changing the PPA to latest version - Ubuntu 14.04

Just finished installing Ubuntu 14.04. I did a distribution install with LAMP stack. I decided I want to run PHP7, MariaBD and latest Apache2. I have got the PHP7 and MariaDB in place, now I want ...
0
votes
0answers
37 views

Enabling apt backports on a case by case basis in linux mint

I'm running Linux Mint 17 and would like to install a package from the backports but I don't want backports installed by default when I use the package manager or apt-get. are there settings or flags ...
0
votes
1answer
15 views

Apt-Dater: Error executing Error executing 'lsb_release -a'

I successfully deployed apt-dater (Debian-machine) and apt-dater-host (CentOS) to 2 different nodes via puppet. Now apt-dater is showing the new host, but the state is always "unknown". If I enter ...
0
votes
2answers
48 views

IPTables: apt-get and wget not working

When resetting IPTables, the apt-get and wget command functions correctly and also downloads what I want. But once I activate this firewall, it isn't functional. Pings still work. I want to allow all ...
0
votes
0answers
83 views

MySQL 5.7 under Debian Jessie with postfix-mysql

I currently have MySQL installed from the MySQL APT repository and am on the 5.6 branch. It comes with libmysqlclient18 and postfix-mysql requires it. If I want to switch to the 5.7 branch, APT will ...
0
votes
1answer
25 views

sudo apt-get install -d zsh. Can not find where it downloaded the file

After running command sudo apt-get install -d zsh I get the following output: Reading package lists... Done Building dependency tree Reading state information... Done Suggested packages: ...
10
votes
4answers
13k views

installing msttcorefonts on ubuntu

I'm generating PDF's with something called PrinceXML, it seems it requires a package called: msttcorefonts I have been unable to use aptitude to get it and I recived this as an error: $ sudo apt-get ...
0
votes
1answer
75 views

How to upgrade version of libpng on ubuntu

I installed libpng using apt-get install libpng12-dev which installed version libpng 1.2.50. I would instead like to install version libpng 1.6.18. How can I install libpng 1.6.18 on ubuntu? My ...