APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

7
votes
7answers
11k views

How to get a list of security updates on the command line in Debian/Ubuntu

In the GUI tool you can get a list packages with security updates. Can this be done on the command line in Debian or Ubuntu? Normally I might use "apt-get upgrade" which would show me what is being ...
1
vote
3answers
80 views

Update apt gpg key over puppet

The puppet apt repository PGP key has expired some days ago /etc/apt/trusted.gpg.d//puppetlabs-keyring.gpg ---------------------------------------------- pub 4096R/4BD6EC30 2010-07-10 [expired: ...
2
votes
5answers
4k views

SSL connection hangs as client hello (curl, openssl client, apt-get, wget, everything)

I've run into a problem on my Debian VPS (a xen domU) regarding SSL. Namely almost all SSL connections hangs at client hello. For example: # curl -vI https://graph.facebook.com About to connect() ...
2
votes
4answers
6k views

Ubuntu14.04 - unable to apt-get update

sudo apt-get update returns some erors : W: Failed to fetch http:// archive.ubuntu.com/ubuntu/dists/trusty/Release Unable to find expected entry 'restricted/source/Sources' in Release file (...
12
votes
5answers
5k views

Running apt-get autoremove with ansible

I maintain a flock of EC2 servers with ansible. The servers are regularly updates and upgraded using the apt module. When I manually tried to upgrade a server, I received the following message: $ ...
13
votes
3answers
438 views

How to install two packages that write the same file

I have two packages that each create /usr/bin/ffprobe. One of them is ffmpeg from the Deb Multimedia repository, while the other is ffmbc 0.7-rc5 built from source. The hand-rolled one is business-...
0
votes
1answer
1k views

ssh'ing via a proxy, but connect is not found

I installed debian from a business card cd iso (basically a very stripped down version of it). I am trying to ssh to a machine via a proxy (set up in my .ssh/config), but am receiving an error: ssh ...
0
votes
0answers
7 views

Attempting to purge mysql* with apt-get, unable to do so without interaction

I'm attempting to purge MySQL completely from Ubuntu 14.04 non-interactively but can't get past a dialog that requires me to say Yes/No. I'm running this command: sudo apt-get purge -y mysql* ...
2
votes
0answers
205 views

Centralized ubuntu update server [closed]

I am in the process of configuring a Central Update Server so we can better manage the security updates on our ubuntu based cloud servers. Here is my plan so far Install apt-mirror on cloud instance ...
0
votes
2answers
1k views

Cannot upgrade PostgreSQL on Ubuntu

When I run apt-get upgrade, I get the following error : dpkg: dependency problems prevent configuration of postgresql-9.1: postgresql-client-9.1 (9.1.7-0ubuntu12.04) breaks postgresql-9.1 (<< ...
0
votes
1answer
13 views

Recreating ubuntu mirror structure on local mirror using aptly

I am currently trying to mirror the ubuntu-cloud repos to a local mirror but I am unable to recreate their structure. I have been using the following commands to create the local apt repo using aptly:...
0
votes
1answer
63 views

Debian 8 - Setup Preferences for installing php7.0

Please help setup preferences for installing php7.0 and relative packages (some of it not a stable release). I have OS Debian 8. I setup sources lists for packages in etc\apt\sources.list.d\: ...
0
votes
1answer
2k views

apt-get update can not connect

i run a dedicated ubuntu 10.04 server. i use kvm/libvirt/virsh to run a virtual machine that's also ubuntu 10.04. i bridged the network (1 of 2 IPs is routed via NAT to the LAN, where my VM (192....
1
vote
6answers
3k views

Cannot install mercurial properly - PYTHONPATH error

I have a server running on Ubuntu 10.04 on which I wanted to install Mercurial via % sudo apt-get install mercurial It seems to have installed successfully and doesn't show me any error messages. ...
5
votes
4answers
4k views

Nodejs : Depends: rlwrap but it is not installable

Just bought a new fresh virtual server in the cloud, Ubuntu 14.04. I updated my packages with apt-get update. Got problems when trying to install node js. I followed this guide: https://github.com/...
0
votes
0answers
47 views

Cannot install libopencv-dev on Ubuntu Xenial

Has anyone else seen this problem? I'm trying to install OpenCV in Ubuntu Xenial LTS. I've tried to uncomment the deb-src entries in my /etc/apt/sources.list and still not working. sudo apt-get -f ...
0
votes
1answer
27 views

ubuntu apt-get for an offline installation

We are using apt-get install -d do download all the required packeges from our installation in order not to need internet. The thing is that apt-get isn't downloading what is already installed and it'...
1
vote
1answer
1k views

Package issue with Ubuntu 10.10 and passenger requirements

I'm trying to get Passenger working with Ubuntu 10.10 (Maverick Meerkat), and I'm running into a problem. It seems that the Passenger installer is not recognizing the virtual package. I'm getting ...
1
vote
0answers
92 views

How do I ignore unmet dependencies while using apt-get remove?

I have a thin VPS running Ubuntu 14.04 with automatic security updates. It has filled up the /boot partition with a lot of kernel updates. I am trying to remove the older ones, but I'm running into an ...
2
votes
2answers
4k views

Ubuntu 12.04 LTS - apt-get update can't find sources

Update: Running sudo rm /var/lib/apt/lists/partial/* temporarily allows sudo apt-get update to work. Original: I've seen answers to similar questions like this one, but the answers have been 'your ...
0
votes
1answer
59 views

Skipping the InRelease step when apt-get update (and go directly to Release)

I've just installed a fresh Xenial on a server box and almost immediately tried to install Docker on it. The Docker installation page says that you have to create a /etc/apt/sources.list.d/docker....
-2
votes
1answer
47 views

sudo yum install apache2 on amazon linux fails [closed]

I've tried running the command:sudo yum install apache2 and got the following error: Loaded plugins: priorities, update-motd, upgrade-helper amzn-main/latest | 2.1 kB 00:00 ...
2
votes
2answers
104 views

Why does Debian have RPM and Yum packages?

I know that Debian comes with an awesome package manager called APT which is capable of installing .deb packages. I know that RHEL comes with a package manager called Yum and is capable of installing ...
0
votes
0answers
22 views

I see security updates but there arent any - Ubuntu 14.04

I updated the system with apt-get upgrade and did a restart. Motd shows me 22 updates and 19 security updates, same with /usr/lib/update-notifier/apt-check --human-readable. 15 updates are shown ...
0
votes
2answers
599 views

ERROR Found no accessible config files for 'fail2ban' under /etc/fail2ban

So my fail2ban wasn't working and in attempts to make it work the config files got messy. Decided to start from scratch. I ran these as sudo apt-get remove fail2ban apt-get purge fail2ban rm -r /...
4
votes
0answers
82 views

debian/ubuntu: Prevent UI prompting in command-line apt-get

So, in order to prevent console-UI (newt, snack, dialog) prompts during the dpkg post-install, you have to do something like: debconf-set-selections <<< 'mysql-server mysql-server/...
0
votes
0answers
307 views

How can I install nginx 1.9.5 on debian jessie?

I added theses lines to the "/etc/apt/sources.list": deb http://nginx.org/packages/mainline/debian/ jessie nginx deb-src http://nginx.org/packages/mainline/debian/ jessie nginx After that I've ...
0
votes
0answers
18 views

Unable to install php5-mysql on Ubuntu 14.04

When I'm trying to install php5-mysql on my local PC with Ubuntu version: # cat /etc/*-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=14.04 DISTRIB_CODENAME=trusty DISTRIB_DESCRIPTION="Ubuntu 14.04.4 LTS" ...
23
votes
4answers
31k views

Installing optional Nginx modules with apt-get

I currently have Nginx installed via the instructions on the Nginx site: nginx=stable sudo su - add-apt-repository ppa:nginx/$nginx apt-get update apt-get install I have configured Nginx and it ...
5
votes
4answers
3k views

In Ubuntu Linux, how do I list packages installed from the “universe” repository?

On an Ubuntu 10.04 LTS server, I want to list installed packages and see what repository they come from. It’s easy to list installed packages, but it does not include the name of the repository (such ...
2
votes
1answer
27 views

Finding source repository for Debian packages

I have a Debian wheezy server which has many sources configured under /etc/apt There's seems to be a lot of duplicate sources, and I would like to simplify this. In order to avoid breaking anything, ...
3
votes
2answers
179 views

Debian: error in upgrade script?

I just ran apt-get update and upgrade to get the latest updates for my Debian stable server. It included a bunch of PHP5 updates. One (libapache2-mod-php5) threw an error: ERROR: php5 module already ...
6
votes
3answers
344 views

Conflicts with PAM configuration files when upgrading system

I have a VPS that runs Ubuntu 14.04.4 LTS; it was installed as a whole with Plesk by OVH. I juste did a apt-get upgrade, and at some point I had a message regarding PAM. The system is in French, but ...
7
votes
3answers
4k views

What does -qq argument for apt-get mean?

I just received a Vagrantfile and post install bash script. The vagrantfile downloads standard Ubuntu from Ubuntu Cloud but I found something in the bash script. Few lines of script reads as: apt-...
0
votes
0answers
31 views

Curator cannot be installed even python is installed OK

I'm trying to install curator via apt repo on my debian wheezy. I went thru official documentation on elastic.co, added repo and GPG key and tried to install curator with apt-get install python-...
26
votes
11answers
14k views

Find last time update was performed with apt-get

I need to find the last time that the apt-get update command was run on my server. How can I determine this information?
16
votes
4answers
26k views

Unable to install mysql-server in Ubuntu

I am unable to install mysql-server on my ubuntu 9.10 server machine. When using apt-get install mysql-server the output is : # apt-get install mysql-server Reading package lists... Done Building ...
1
vote
1answer
1k views

Ubuntu 12.04 PHP 5.3 to 5.5 update fails

on a Ubuntu 12.04 Server I´m trying to update PHP 5.3 to 5.5 this is what I have done: sudo add-apt-repository ppa:ondrej/php5 sudo apt-get update sudo apt-get install php5 unfortuntely the ...
0
votes
0answers
10 views

Quite Apt-get Install but Prompt for Input

I am trying to figure out a way to quietly install Java, without all the installation text, but still get the user agreement prompt. Is this possible?
0
votes
3answers
61 views

Bash if condition to check if a ubuntu package needs an upgrade?

I need a bash line to check if a ubuntu package needs an upgrade or not. For example, I want to check if the package 'firefox' needs an upgrade using dpkg or apt-get commands. Hypthetical Example: #...
1
vote
1answer
91 views

apt-get remove package that didn't install properly

I accidentally installed zabbix-frontend-php that pulled apache2 as a dependency. I don't want to use either, and I want to completely delete both packages. Unfortunately, it seems that apt-get won'...
1
vote
0answers
73 views

Issues installing R package, r-base; Ubuntu 14

I am having a massive headache trying to install R. I go to install r-base and I get the following. root@10:/etc/apt > apt-get install r-base Reading package lists... Done Building dependency ...
40
votes
6answers
38k views

How do I get the history of “apt-get install” on Ubuntu?

I am about do move a server from one Ubuntu box to another. I'm not cloning the old box to the new; I'm creating a new system and will move data as needed. I want to install all the software that I ...
0
votes
1answer
84 views

apt-cacher ng “an error occured while reading this file, some contents may have been ignored.”

I've been getting the following message every day from the apt-cacher-ng cron job: /etc/cron.daily/apt-cacher-ng: Error(s) occured while updating volatile index files for apt-cacher-ng. Please visit ...
1
vote
2answers
2k views

Duplicate sources.list during apt-get update

I wanted to install PostGIS on my server which already have a PostgreSQL installed. I followed this PostGIS installation manual. I inputted this script: sudo sh -c 'echo "deb http://apt.postgresql....
0
votes
0answers
332 views

Unable to locate package landscape-server-quickstart

Any idea why landscape-server-quickstart isn't being found? According to both this AskUbuntu post and the official Landscape 15.11 installation instructions, the following commands should install ...
4
votes
1answer
153 views

reprepro use when multiple sources have the same codename

I'm investigating the use of reprepro to control what updates get propagated to our servers, and when. The idea is to vet updates by Debian and Ubuntu, and only apply the ones we choose. We want to ...
1
vote
0answers
62 views

Using Debian's unattended-upgrades package

I'm trying to have all official packages from Debian be upgraded on a Wheezy box - I've set the following: "o=Debian,a=oldstable"; "o=Debian,a=oldstable-updates"; "o=Debian,a=oldstable-backports"; ...
0
votes
1answer
23 views

How to tell apt-get that a package is OK and does not need any more attention

I have a broken Ubuntu 14.04 server. Everything is OK except for apt-get, which for some reason thinks that it repeatedly fails to update mysql server package. The mysql server is updated and works ...
13
votes
3answers
827 views

SSH session never closes when executing “apt-get install”

Problem When running apt-get install in an non-interactive SSH session, the session never closes. Example: ssh user@target "sudo apt-get -y install my_package" The my_package does get installed ...