APT, the Advanced Packaging Tool, is Debian's high-level package management system. It is also used by several other Linux-based and Debian-based operating systems.

learn more… | top users | synonyms (1)

23
votes
2answers
10k views

Can someone clarify Ubuntu (Debian) dist-upgrade for me?

I've got an Ubuntu 8.04 LTS server. There are several packages which are "kept back" ("the following updates have been kept back:") when I do an apt-get upgrade. It's my understanding that I can do ...
23
votes
1answer
7k views

How do I ask apt-get to skip any interactive post-install configuration steps?

I have a server build script which uses apt-get to install packages. It then puts pre-written configuration files directly in place, so the interactive post-install configuration dialog in packages ...
25
votes
9answers
41k views

How do I get apt-get to ignore some dependencies?

How do I make apt-get ignore some dependencies? For example, I wanted to install mailx so I can use it to send email from cron scripts/report-generating tools. However, installing mailx also installs ...
8
votes
7answers
2k views

Disable prompts while installing a Debian package

How can i disable totally the prompts that appear while installing a Debian package, i've used all the options that i've found but there are some packages that are still prompting. I'm using this ...
20
votes
3answers
34k views

apt-get update getting 404 on debian lenny

Here is my /etc/apt/sources.list ###### Debian Main Repos deb http://ftp.us.debian.org/debian/ lenny main contrib non-free ###### Debian Update Repos deb http://security.debian.org/ lenny/updates ...
4
votes
4answers
530 views

How do I tell apt to never upgrade a particular package?

I prefer to install my own version of Firefox. How can I tell apt to never attempt to upgrade it, even if i type "apt-get update ; apt-get upgrade" later? Edit: Okay, so dpkg -l firefox prints this: ...
25
votes
5answers
25k views

Linux: how to restore config file using apt-get/aptitude?

I've occasionally lost my config file "/etc/mysql/my.cnf", and want to restore it. The file belongs to package mysql-common which is needed for some vital functionality so I can't just purge ...
20
votes
5answers
21k views

How do I get the history of “apt-get install” on Unbuntu?

Greetings again. I am about do move a server from one Ubuntu box to another. I'm not cloning the old box to the new; I'm creating a new system and will move data as needed. I want to install all the ...
12
votes
3answers
5k views

How do I show the actions that installing a .deb package will take?

I would like to be able to view the scripts/triggers associated with a package due for upgrade so that I can tell, for example, whether it will result in the web server being restarted. I can't find ...
6
votes
5answers
3k views

Securely restrict access to a private Debian repository

I was looking for a method to restrict access to a private Debian repository and be able to authenticate to it non-interactively (i.e. using a script) The most useful article I found if actually one ...
5
votes
2answers
2k views

Caching proxy for yum and debian repositories

Does a caching proxy for yum exist, similar to approx for Debian repositories? Is there a way to have reprepro behave the same as approx? I have heard that approx was not as stable; besides, I would ...
5
votes
2answers
7k views

How to completely remove a package in Debian?

I tried to use this: aptitude remove denyhosts And it seemed successfully but after a reboot after I use: ps aux | grep "denyhosts" I see denyhosts is still loaded after startup. So what am I ...
4
votes
2answers
968 views

How do I install a package from Ubuntu Karmic onto Jaunty?

I'd like to know if the following is easy/possible/recommended. The version of Ubuntu I'm using (jaunty) has an out of date package that I need to upgrade: ...
4
votes
2answers
2k views

Recompile NGINX with “--with-http_stub_status_module” configure line

I've installed NGINX with sudo apt-get install nginx and now I'd like to recompile it with the configure option --with-http_stub_status_module. How can I do this, and is there a way I can not loose ...
18
votes
10answers
8k views

Managing upgrades on hundreds of Debian servers

What do you think are the best practices to maintain dozens (if not hundreds) of debian servers up-to-date ? Keeping in mind that : There are groups of servers (i.e identical webservers, DB ...
20
votes
3answers
9k views

List of files installed from apt package

How do I get a list of files that were or will-be installed when I apt-get a package? Conversely, can I find what package(s) caused a particular file to be installed?
9
votes
3answers
3k views

100% non-interactive Debian dist-upgrade

Is there a way to do an apt-get dist-upgrade in Debian that not only automatically answers "yes" to all questions asked, but also uses reasonable defaults as answers to questions that are ...
2
votes
4answers
7k views

Ubuntu, is adding the debian repository to my apt source.list dangerous?

I'm trying to install a package from a debian repository. Trying to install manually with dpkg errors because of missing or incomplete dependencies. This got me wondering, is it a mistake to just add ...
12
votes
2answers
3k views

Automate the installation of postfix on Ubuntu

My system configuration script does an "apt-get install -y postfix". Unfortunately the script is halted when the postfix installer displays a configuration screen. Is there a method to force postfix ...
15
votes
4answers
23k views

How to force downgrade of packages on Ubuntu (Karmic)?

After doing an update on a bunch of pulseaudio packages my microphone stopped working. It's fine, after all Karmic is still in Alpha. I have reported the bug to launchpad. In the meanwhile I would ...
10
votes
2answers
25k views

How do I enable non-free packages on Debian?

How can I enable non-free packages on Debian? I want to install Sun's Java JDK but it's not available to me.
19
votes
9answers
7k views

Find last time update was performed with apt-get

I need to find the last time that the apt-get update command was run on my server. How can I determine this information?
11
votes
4answers
5k views

Given a debian source package - How do I install the build-deps?

I have a debian (well technically ubuntu) source package, i.e. the .dsc, the .tar.gz, etc., I want to build this. The dpkg-buildpackage fails, since I don't have all the build dependencies. Normally ...
5
votes
5answers
2k views

Disable/Remove Apt(-get)

Is there anyway to disable/remove apt-get on a debian based server. I'd prefer to use aptitude, and don't want the other users to be installing packages with apt-get, to avoid package/database issues. ...
1
vote
3answers
1k views

Ubuntu 8.04 (Hardy): How to automatically apt-get / aptitude upgrade packages for bugs/security?

I have a lab full of workstations running Ubuntu 8.04 (Hardy Heron). My predecessors made a hackish bit of cron script to update, upgrade, and clean daily. I like the fact that it requires zero ...
17
votes
3answers
39k views

Debian 5.0 (lenny) apt sources fail?

For the past few days, I couldn't update our apt-sources on Debian 5.0 (lenny). I get the following errors. W: Failed to fetch http://ftp.debian.org/debian/dists/lenny/main/binary-amd64/Packages 404 ...
7
votes
1answer
10k views

Debian/Ubuntu - How to restore /var/cache/apt structure after deleting it?

I was running out of space on an Ubuntu server, so I did this command to save space sudo rm -rf /var/cache/apt/archives However now when trying to do things with apt, I get the following errors: ...
5
votes
3answers
3k views

/etc/cron.daily/apt and /etc/cron.daily/aptitude on ubuntu hardy

I am a sys admin newb, otherwise I would figure this out on my own. I have a slicehost slice and I noticed that there are a couple scripts that get run (the ones I mentioned in my question title) ...
1
vote
2answers
2k views

Configure apt to use proxy in vagrant box

I'm using Vagrant to setup a virtual machine for testing. I would like apt inside the virtual machine to use a proxy on the host machine to allow caching of all the downloads to persist between ...
1
vote
1answer
321 views

Using snapshots with reprepro to enable rollbacks

I'm using reprepro to maintain a Private Package Archive of internal packages. There is no straightforward way to keep multiple version of a package available using reprepro (see here), but it does ...
3
votes
2answers
3k views

Can reprepro accept a new version of a package into the repository?

I have installed a package into my own debian package repository like so: $ sudo reprepro -b /var/packages/ubuntu includedeb maverick my-package_0.8-0_all.deb my-package_0.8-0_all.deb: component ...
3
votes
3answers
797 views

Debian apt-get repository

We have our own internal package repository hosted on a webserver running apache. Internal users who want to install one of these packages point these sources.list to the webserver & do a apt-get ...
2
votes
3answers
288 views

Use apt-get source on a debian repo without using /etc/apt/source.list

I'm trying to use apt-get source as a regular user on a debian squeeze system. I want to retrieve the sources for cyrus-imapd-2.4 from the testing/wheezy repository. apt-get source works without ...
2
votes
2answers
2k views

How to update sources.list for Debian 4.0 Etch?

I am trying to update my /etc/apt/sources.list on my VPS. As I run apt-get update I get all kinds of 404s not found, for example: Failed to fetch ...
0
votes
2answers
464 views

Ubuntu LTS repository package update policy

I recently realized that even though Ubuntu LTS is receiving 5 years of support, a lot of the packages in Ubuntu LTS package repository are not updated with the latest stable releases. For example, ...
6
votes
1answer
488 views

How can I apt-pin stable?

I changed my mind some time after install, and would prefer stable to testing for this particular system. Unfortunately, I currently have packages at old testing versions. I need to force a downgrade ...
5
votes
2answers
816 views

Should I install MongoDB using Ubuntu's repository or MongoDB's private repository?

I was reading the MongoDB install instructions and noticed they have a private repository that the instructions tell you to add. I'm wondering if this is really needed because MongoDB is also in the ...
4
votes
3answers
2k views

Vagrant/VirtualBox can't resolve some domains from w/in VM

Just trying out VirtualBox & Vagrant and my initial lucid64 VM can't resolve us.archive.ubuntu.com but can resolve security.ubuntu.com, google.com and www.apple.com (but not apple.com w/out the ...
4
votes
4answers
2k views

apt-get update mdadm scary warnings

Just ran an apt-get update on one of my dedicated servers to be left with a relatively scary warning: Processing triggers for initramfs-tools ... update-initramfs: Generating ...
4
votes
3answers
3k views

apt-get update/upgrade list without changing anything

I would like to view what packages are available for update/upgrade without actually changing any files becuase there are some packages I wouldn't like to update. Would it then be possible to apt-get ...
3
votes
2answers
912 views

debian wheezy, heartbleed, openssl refuses to update

I am having a strange problem, my system is exposed to heartbleed, and I am trying to fix it by using: apt-get clean, apt-get update and apt-get upgrade openssl but the response is: Reading ...
3
votes
2answers
455 views

How to install package version that was removed from backports?

There is only one version of the libreoffice package in Debian Squeeze Backports: apt-cache madison libreoffice libreoffice | 1:3.5.4-7~bpo60+1 | http://backports.debian.org/debian-backports/ ...
3
votes
4answers
3k views

Couldn't find package gitolite on Ubuntu 10.04

I've been following this tutorial and I'm stuck on sudo apt-get install gitolite with the error Couldn't find package gitolite I've been Googling around for a while now, no one else seems to ...
3
votes
2answers
3k views

Why do I get GPG error when running apt-update for lenny-backports?

Alright, so I'm trying to upgrade (if you could call it so) to lenny-backports as seen here, but I ran into this error when running apt-get update: W: GPG error: http://backports.debian.org ...
2
votes
2answers
1k views

Debian: How to use “apt-get install” without upgrading dependencies? [duplicate]

Possible Duplicate: How do I get apt-get to ignore some dependencies? I need to install some packages. The package A has the package B as a dependency and requires to be (>2.0). I have ...
1
vote
2answers
675 views

Ubuntu Trusty on EC2 - apt-upgrade with 403 forbidden

When I run apt-get upgrade, I'm getting this error: 1 upgraded, 0 newly installed, 0 to remove and 73 not upgraded. Need to get 413 kB of archives. After this operation, 0 B of additional disk space ...
1
vote
5answers
2k views

Cannot install mercurial properly - PYTHONPATH error

I have a server running on Ubuntu 10.04 on which I wanted to install Mercurial via % sudo apt-get install mercurial It seems to have installed successfully and doesn't show me any error messages. ...
1
vote
1answer
876 views

Can't get MySQL to install

I'd like to think I know what I'm doing in a Unix shell but maybe not. I made a mistake in a configuration file for MySQL, so I decided to just uninstall it and then reinstall it, so I did: sudo ...
1
vote
4answers
2k views

Ubuntu cannot resolve unmet dependency

I'm trying to install a package on my Ubuntu 8.10 server. However, I get this message: The following packages have unmet dependencies. webmin: Depends: apt-show-versions but it is not going to ...
1
vote
2answers
824 views

apt-get install giving 404

I'm something of a ubuntu newb. I'm trying to get subversion, so I enter: apt-get install subversion I'm getting a 404 on subversion and all its dependencies. E.g. Failed to fetch ...