0
votes
0answers
14 views

Redirect loop on empty website set up in Pleask on Windows 2008 Server

I have a really weird situation. I've moved lots of domains from an old server to a new server (windows 2008). Most of them are working nicely but 2 are not. These two happen to be complex ...
0
votes
0answers
318 views

Asp.NET WebApi application gives 404 error when deployed to IIS7

I have an Asp.NET MVC WebApi application that works perfectly in development environment does nothing but return 404 errors when deployed to testing server. Application is Framework 4.5 dotNET ...
0
votes
0answers
108 views

How to deploy an MVC 4 application to a Windows Web Server based dedicated hosting?

I want to deploy an MVC 4 web application to a Windows Web Server based dedicated hosting. I am using SQL Server 2008 R2 Express as my back-end database. What steps will I need to take regarding the ...
1
vote
2answers
1k views

Nginx on Windows with ASP.NET and the Microsoft .NET framework?

Question: Is it possible to use nginx on Windows to serve ASP.NET / ASP.NET MVC pages using the Microsoft .NET framework ? I know one can do it with mono-fastcgi, but I was wondering if it is ...
1
vote
0answers
189 views

ASP.Net/ASP.Net MVC Sites Hanging Indefinitely on IIS 8 on Windows 8

Environment I have recently been experiencing weird behaviour in my development environment when running ASP.Net websites locally on my Windows 8 development computer via IIS8. I have observed the ...
3
votes
1answer
265 views

Two application pools or root virtual directories under one site

This might sound like a very dumb question, so let me first say what I want to achieve and then proceed to my question on how I'd envision something like this working. I am trying to achieve ...
1
vote
1answer
68 views

Configuring ISS and SQLSERVER for ASP.NET MVC application and windows authentication

I have freshly installed ISS with SQL server and asp.net mvc application. I want my app to use windows authentication. On my application side, i know that i have good connection string, because i was ...
1
vote
1answer
75 views

Changing the user IIS runs over

I am trying to change the user IIS runs over. I read that IIS might run using IUSR_computer_name user but I am not sure if this rule applies to IIS 7.0 The question is, trying to map the whole ...
1
vote
1answer
903 views

How to configure ASP.NET MVC 3 on IIS 6 (Windows 2003 R2) [duplicate]

Possible Duplicate: Deploying ASP.NET MVC to Windows Server 2003 I am getting 403 Directory Listing Denied for the root and 404 for an action that I know should exist. Background: I have ...
0
votes
1answer
862 views

How to Deploy an ASP.NET Web API- and Browser-based Application to a Production Environment [duplicate]

Possible Duplicate: How to Deploy an ASP.NET Web API- and Browser-based Application to a Production Environment We have an ASP.NET Web API server that serves up a SQL Server data driven ...
1
vote
1answer
233 views

ASP.NET 4 IIS 7 web server timeout

I have 3 applications on the same web server. Two of them are configured in separate ASP.NET 4 application pools and and one of them is on an ASP.NET 2 application pool. I'm experiencing intermitent ...
4
votes
3answers
4k views

Intermittent high CPU (100%) on production webserver

X-Post from StackOverflow: http://stackoverflow.com/questions/9465123/intermittent-high-cpu-100-on-production-webserver We have a web cluster with 3 web-servers, each with 24 cores & 24GB mem. ...
0
votes
1answer
505 views

IIS6 Application Pool: App breaks until recycled

I've been experiences some problem with website that use ASP.net MVC or Webform. Problem: Sometime the website isn't showing. If I go to the website, I'll get the Directory Browsing is not permitted ...
3
votes
2answers
6k views

What differences are between IIS 7.0 and IIS 7.5?

I thought that IIS 7.0 and IIS 7.5 have (from the application developer point of view) nearly same features. Then, I found that certain features are not working on IIS 7.0. Are there more features ...
0
votes
1answer
286 views

How do I set Application Configuration Mappings in IIS6 from the command line?

I am rolling out .NET 4 to around 60 servers, and I need register the .mvc extension to run with ASP.NET on each server after the install. Does anyone know a way to do this from the command line? Is ...
0
votes
2answers
2k views

How to publish an ASP.NET MVC application to a free host

I'm using a free web host (0000free) which supports ASP.NET MVC, but it uses Mono. This is the first time I deploy an MVC application, so I'm a little confused as to where I need to deploy it. I have ...
1
vote
1answer
100 views

Intermittent IIS Event 1062

IIS 6 with about 25 sites, one of which is .net framework 2.0 with a .net framework 4.0 app below it running mvc 3 in its own app pool. It runs fine for some time, then we see event 1062 and the .net ...
0
votes
1answer
350 views

IIS 6 with ASP.NET 4 - what are the disadvantages?

I'm looking at a hosting company that I plan on going with, but they use IIS 6 with ASP.NET 4. I plan on running a ASP.NET 4 MVC web application that uses SQL Server (which the hosting company has). ...
5
votes
1answer
3k views

What are the key performance metrics to monitor for a deployed ASP.NET web application?

I have full logging ( using log4net) throughout the application. What are the key WMI variables etc that should be monitored. If you had to pick 10 things that you would look at everyday what would ...
0
votes
1answer
224 views

ASP.NET MVC app on IIS7 with WebForms content is throwing NTLM authenticate box

I have an ASP.NET MVC app that also contains some WebForms content (for SSRS ReportViewer). This is deployed to IIS7 and the MVC pages of the app work fine, but when I try to browse to the aspx page I ...
1
vote
2answers
2k views

Cannot access static content of an ASP.NET MVC app on IIS7

I have an ASP.NET MVC 2 app that I have just deployed to IIS7. The app works fine except all static content (js, css, images) are returning blank. I have the static content handler configured above ...
2
votes
1answer
969 views

asp.net mvc 2 web application inside a Web site?

I have a Asp.Net Web Site deployed as a WebSite inside IIS 7.5. http://localhost/WebSite Then I have a second Asp.Net MVC 2 web application which is deployed as Sub Application inside the above ...
0
votes
2answers
705 views

Traditional ASP.NET application in subdirectory of an MVC application

Windows Server 2003, IIS6. We're trying to deploy a non-MVC ASP.NET web application as a subdirectory of an MVC application. However the ASP.NET application in the subdirectory is failing with the ...
1
vote
1answer
229 views

IIS Application requires Forms Authentication for everything

At the moment, I'm trying to develop an ASP.NET MVC application using a local IIS server (Dev Server was just too slow). However, every page request, including CSS/JS results in a redirect to the ...
3
votes
4answers
224 views

Use PC as Web Server

How can I use my own PC (Win 7 Home Premium, SQL Server 2008 Express,IIS 7.5) as web server for my ASP.NET MVC Website? [Update] : I know how to run IIS in Win 7 and locally I can host my web. My ...
7
votes
2answers
11k views

Where is ASP.NET Server Log File is Located?

My ASP.NET MVC application on my development box is running wild; I can't even connected to localhost. In order to know what is the problem, I want to find the log file and examine it. Where is the ...
1
vote
2answers
2k views

DELETE method not allow in IIS (7)?

some how im developing ASp.net mvc application, the DELETE method work fine in VS server, but however, when i test it in an IIS. it's not working and absolutly return a 405 Error.. and currently, I ...
0
votes
1answer
226 views

Do I need to have the asp.net mvc framework to run my asp.net mvc apps on a web server?

I have been looking for a web hosting service for a while and I would like to know if I need the asp.net framework besides the .net framework to run my asp.net mvc applications? And I also want to ask ...
4
votes
2answers
5k views

IIS7 returns blank when static content requested

I am trying to configure a demo machine which is EEEPC with Windows 7 Home Premium edition all the drivers properly loaded (don't ask me why it's Home edition) with IIS7 installed. I've deploy the ...