-1
votes
1answer
31 views

Auto starting rc at startup

So here are the steps i am following . So i add a conf file inside /etc/init.d/myconffile And then to get System start/stop links i have to use the command sudo update-rc.d myconffile defaults 99 ...
3
votes
2answers
84 views

Server won't start. IPMI showing Blue Screen with Ubuntu Linux

I have a remote SuperMicro server that is failing to boot. It's located on a different continent and access is limited. I can get into the BIOS and do whatever I need to, but as it gets through the ...
0
votes
1answer
67 views

Did grub updating bring my server down?

I have an Ubuntu 12.04 server. Last night I installed a few updates using apt-get dist-upgrade, including grub, and rebooted. After rebooting, I couldn't boot into Ubuntu. I just get a big flashing ...
0
votes
1answer
197 views

sed fix for BusyBox - boot fail unable to mount LVM

BusyBox why u no vi?! Summary: Ubuntu 14.04 Server after upgrade first boot, only boots to BusyBox v1.21.1 initramfs with "gave up waiting for root device" due to missing /dev/mapper/xxx-root as ...
1
vote
1answer
29 views

First Boot Script for variety of platforms

I'd like to make a firstboot script for CentOS 5/6 and Ubuntu 12.04/12.10/14.04. If possible, I'd like to use one method to trigger this script to run. From what I can tell, this rules out ...
1
vote
2answers
2k views

Ubuntu 13.10 - How to disable LVM and cryptsetup? cryptsetup: evms_activate is not available

I am trying to remove whole drive encryption from my Ubuntu installation. I've run Ubuntu from Live CD, mounted crypt partition and copied it to another partition /dev/sda3. sudo cryptsetup luksOpen ...
1
vote
2answers
181 views

How do I fix my server to boot properly after removing / adding a drive on my mdadm software RAID

I configured a RAID-5 array for a data partition mounted on /mnt/data. My system is not booting on it (/ and /boot is on a dedicated drive not part of any RAID array). I added a 4th drive to my 3 ...
4
votes
1answer
304 views

Slow boot and dns doesn't work

I don't understand what happened because i didn't change anything in system for quite a long time. Now system boots too slow and when it's booted - dns requests don't work. I can ping remote hosts by ...
0
votes
1answer
329 views

Why is my machine not showing anything when booting?

I'm using Ubuntu Server 11.10 x86, and after I make my normal selection (Ubuntu, with Linux 3.0.0-12-generic-pae) from the GRUB menu, the screen just goes blank - there's not even a cursor showing up. ...
-1
votes
2answers
92 views

Is a bad NFS mount preventing a clean boot?

I'm on Ubuntu server (I think it's 12.04, but not positive) and I basically ran into this problem here Unmount a nfs mount where the nfs server has disappeared The umount command didn't work, so I ...
3
votes
1answer
480 views

How to load the environment variables at boot time before X11 on Ubuntu Precise?

Using Ubuntu Precise 64 bit, I'm facing a problem that I'm unable to solve and that I'll try to describe below: I'm using a console mode program (let's say abc) that uses Go, NodeJS, Java and Scala. ...
0
votes
0answers
45 views

could not write pid file /dev/.initanfs/plymouth.pid

I got an error when I boot my Ubundu 10.04 LTS server could not write pid file /dev/.initanfs/plymouth.pid no such file or directory Can anyone tell me how to fix it?
0
votes
2answers
364 views

linux server hangs after “running local boot scripts”

after a sudden electricity break down one of the company servers (ubuntu) hangs at boot. I have an OK message for "running local boot scripts (/etc/rc.local)" but it freeze there and a black screep ...
1
vote
2answers
233 views

How to set a binary to init on boot like Apache does (run as a service)

I am trying to setup PhantomJS to run as a service. I found the skeleton file in /etc/init.d and I am running on Ubuntu 12.10. In trying to figure this out I found the symlinks in the /etc/rc*.d ...
0
votes
1answer
240 views

Force apache start after mysql

I have the problem that my apache2 doesn't start at boot. After debugging I found out that a webpage init script tried to connect to MySQL which isn't running at that time. My OS is Ubuntu Server ...
0
votes
1answer
837 views

apache2 not starting at boot. Even if set up in runlevels

On my Ubuntu 10.04.4 server apache2 2.2.14 is installed. A few months ago starting apache2 at boot worked fine. Now I've found out that after a reboot apache2 doesn't start automatically anymore. ...
1
vote
2answers
780 views

dhclient not working at boot

Here's the problem: root@home:~# ping 8.8.8.8 connect: Network is unreachable root@home:~# dhclient eth0 RTNETLINK answers: File exists root@home:~# ping 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) ...
1
vote
2answers
312 views

fix kernel on Xen Server hypervisor vps

I have a cloud server hosted at Rackspace, and they use Xen Server hypervisor. I was running Ubuntu 12.04, and really messed up by attempting to do a release upgrade manually. The hypervisor ...
1
vote
0answers
161 views

Gearmand autostart at system boot

Gearman server is installed and working fine on Ubuntu 12.04. But it won`t start at system boot. I try this: Startup applications (/etc/init.d/gearman-job-server owned by root), sudo update-rc.d ...
0
votes
0answers
248 views

Ubuntu 12.04, after reboot, ping but don't have any service up ( ssh / apache )

I need a little help, I just reboot a ubuntu server 12.04 without any special modification, it doesn't start anymore, I have a ping return but connection refused on SSH and apache is not started Here ...
0
votes
3answers
1k views

Cant run rc.local manually and doesn't run automatically on ubuntu

This is quite a simple one. I created an rc.local file here: /etc/rc.local I made it executable. However, it doesn't run when I boot the server. I can see it in the directory and when I try to run ...
0
votes
2answers
167 views

MDADM not assembling raid0 that is part of a raid5 on boot

I use a RAID0 (md2) as a device in a RAID5 (md3) setup (see below). Now everytime the computer boots, mdadm will mark md3 as degraded and i am forced to re-add md2 as a new spare. Of course mdadm then ...
0
votes
1answer
355 views

Ubuntu / GRUB reboot loop

I had to shutdown a server due to a power outage... The machine's been working just fine, an Ubuntu 12.04 box. Now when I boot back up, I get the GRUB 1.99 boot menu with several options, all of which ...
3
votes
2answers
3k views

Lost Linux root password - Recovery mode and init=/bin/bash fail

I lost/forgot the root password to a server sitting beside me and am trying to reset it. I would rather not have to wipe and re-install or use a Live CD (server is running Ubuntu Server 12.04). What ...
2
votes
2answers
256 views

Nginx and NSD3 don't start on boot because they cannot use the assigned IP

Server is a Xen VPS running Ubuntu 12.04 and neither nginx nor NSD3 come up after reboot. The apparent reason for that is that they're not able to bind to their assigned IP addresses right after boot, ...
0
votes
0answers
267 views

How to troubleshoot EC2 fails to reboot?

I really don't understand EC2, or whether it actually uses GRUB to boot my Ubuntu server, but trying to boot my instance gives the following log output: Fri Oct 26 17:05:57 UTC 2012: shutting down ...
1
vote
0answers
164 views

Thin configuration doesn't start on boot, but they do on manual start [closed]

I have some thin config files (generated with sudo thin install) which are slightly modified (only paths where they're located). I can start them just fine with /etc/init.d/thin start, but if the ...
1
vote
1answer
1k views

Rackspace Ubuntu 12.04 server stuck in initramfs after kernel upgrade

Can't boot after I did a aptitude full-upgrade and let it update menu.lst (did a diff first and it looked good). This is what I've done so far in the BusyBox shell: mkdir /tmp/xvda1 mount /dev/xvda1 ...
2
votes
3answers
2k views

Daemon doesn't start at boot - how can I debug this?

I installed new relic according to their quick install instructions. If I start the daemon manually after boot with /etc/init.d/newrelic-daemon restart it works, but it doesn't run automatically ...
0
votes
0answers
49 views

Ubuntu is stuck in the bootup process

Please see this picture. It's just stuck there, and won't go to the next step. What should I do about it? Any suggestion would be greatly appreciated!
2
votes
2answers
793 views

Ubuntu installer over PXE doesn't see network adapters => can't download preseed

I'm booting one virtualbox VM from another virtualbox VM (with cobbler) over PXE. Both machines have 2 adapters: 1) external network and 2) host-only network. The "client" VM successfully boots into ...
3
votes
2answers
418 views

Ubuntu: How to set up an init script that only runs on the first boot?

I need to install an init script that only runs on the first boot after it's installation. How can I accomplish that on Ubuntu?
1
vote
0answers
186 views

can't update MYSQL startup settings in ubuntu

I updated to mysql 5.5 and noticed that the server wasn't starting anymore at boot but I had to do it manually. It is actually not set to start at any level. So I did chkconfig -s mysql 2345 but ...
2
votes
1answer
514 views

Postfix won't start at boot

I have a server with ubuntu 10.04 and i've installed postfix. It works but when the server is restarted it doesn't start automatically. I've tried with: update-rc.d postfix defaults But doesn't ...
2
votes
1answer
939 views

mdadm warning after apt-get upgrade - can't boot RAID

I'm running Ubuntu 12.04 precise. A recent apt-get upgrade ended successfully, but printed the following warning at the end: update-initramfs: Generating /boot/initrd.img-3.2.0-21-generic W: mdadm: ...
0
votes
1answer
708 views

Workaround for starting zabbix agent on Ubuntu. update-rc.d LSB mismatch

I am trying to run the zabbix-agent (1.8.1) on boot on Ubuntu (lucid 10.04). Zabbix is installed just fine, and it manually starts just fine with /etc/init.d/zabbix-agent start However it doesn't ...
0
votes
1answer
417 views

rc.local is not executed on bootup ubuntu

Im on Ubuntu 10.04. I want to execute script on system boot. I added it to rc.local. If I execute rc.local manually it works fine. If I boot system in recovery mode(2nd string in boot menu) it ...
0
votes
1answer
225 views

Linux Server's network daemons won't boot on load

This happened a while ago, but I installed some software and it messed up my entire app-get command so I had to do all this manual deleting and stuff. Everything is fixed except now when I restart the ...
1
vote
2answers
779 views

Best way to start a program at boot on Ubuntu Server

I have a server running Ubuntu Server 11.10 and I have some programs I want to start at boot time such as Nginx, my Unicorn workers etc. In fact, I know how to start my programmes either by adding a ...
3
votes
3answers
1k views

Ubuntu 10.04 LTS full /boot/

I've got a Ubuntu server 10.04 that have been running since 10.04. Today when apticron mailed me about new packages the installation of a new kernel update failed due to a full /boot partition. ...
4
votes
2answers
1k views

What to do with suddenly unreachable non-logging EC2 instance?

I have an EC2 "micro instance" running Canonical's Ubuntu 10.04 LTS. Has been running for 6-9 months now, infrequently rebooted (once every few weeks at the most). I just did what I thought was a ...
0
votes
2answers
264 views

VSFTPD Ubuntu won't start on boot

I have a server running Ubuntu 11.04 Server and I have installed vsftpd (FTP). I am trying to get vsftpd to run on startup, but can't seem to configure it right. There is already an upstart vsftpd ...
2
votes
3answers
676 views

Linux boot: md raid FS not ready (sometimes)

Using Ubuntu 11.04 (latest patched) I have 5 RAID-1 file systems that are automatically assembled during the boot process (Note: none of the system FS /, /usr... are raid, only user FSes). Once in ...
1
vote
1answer
277 views

I deleted files from my Linux box's /boot directory and now it won't boot

I did that to save space. Now I see GRUB loading, please wait ... ERROR 15 on boot. /boot still has files corresponding to 2.6.32-27 version of Linux. But I deleted all others that did not have ...
0
votes
1answer
163 views

Running a script as root at bootup

I have a simple script to help me do some power saving: #!/bin/bash echo 1 > /sys/module/snd_hda_intel/parameters/power_save echo min_power > ...
0
votes
1answer
358 views

Blank screen after grub menu

I just rebooted an Ubuntu Server 10.04. After choosing boot options in the grub menu, though, it just displays a black screen with the blinking white underscore in the upper-left corner. The machine ...
0
votes
2answers
355 views

My server was used to boot (problem after MDADM raid rebuild)

My home-backup server, with 8*2TB disks won't boot anymore. Two disks failed at the same time and i rebuilt the raid 6 array with no problem, but now i can't boot the os. I'm using ubuntu server, ...
2
votes
3answers
617 views

How to start a s3ql script automatically on boot?

I've been experimenting with s3ql on Ubuntu 10.04, using it to mount Amazon S3 buckets. However, I'd really like it to mount them automatically. Does anyone know how to do that? Solution: Thanks ...
0
votes
1answer
673 views

rc scripts dependencies

On a Ubuntu 10.04.1 LTS server install certain services fail to start properly after a reboot. I have a couple of virtual interfaces defined on eth0: /etc/network/interfaces # This file describes ...
1
vote
1answer
5k views

New install Ubuntu 10.10 Server, won't boot. “ls /dev/disk/by-uuid” generates Bus Error

I installed Ubuntu 10.10 Server on a very old computer (bought it in 2002), but it won't boot. It tells me it can't find the root mount volume by it's UUID and also gives me the follwing type of ...