The tag has no wiki summary.

learn more… | top users | synonyms

0
votes
0answers
31 views

Gem installation on vanilla ubuntu fails - EACCESS

I'm trying to install the Middleman gem on a completely generic installation of Ubuntu Trusty (i386). Here's my console input/output: vagrant@vagrant-ubuntu-trusty-32:~/rj$ which ruby /usr/bin/ruby ...
2
votes
1answer
149 views

Share Ruby Programs between Linux users

Our Linux (Mint) system has 2 admin users - mint & admin. What do we need to do for admin & mint to be able to share gems? Mint has chef, berkshelf & knife-ec2 installed via bundler in ...
0
votes
0answers
24 views

Gem generating different output on different machines with same configuration

I'm using the premailer gem to generate inline CSS for a project I work. That project is also cloned on a CI server. The wierd stuff that is happening is that from some time now, it started failing ...
1
vote
1answer
409 views

Continue Bundler Installation

I'm trying to install Gitorious on Debian Wheezy. gitorious uses bundler for automated installation. When I run "bundle install" (not only when installing gitorious, also redmine for example) I ...
1
vote
2answers
2k views

Capistrano error “bundle: not found”

I'm trying to deploy octopress on a VPS but getting this error bundle: not found but bundle is installed! Full error. $ cap deploy * 2013-07-20 18:08:55 executing `deploy' * 2013-07-20 18:08:55 ...
1
vote
1answer
797 views

Execute gitlab sidekiq (rake task) with upstart

I'm trying start the gitlab sidekiq daemon through upstart. But unfortunately it seems that the sidekiq worker is respawned since sidekiq start deamonizes itself: Jul 12 17:26:42 git kernel: ...
-1
votes
2answers
34 views

Bundler won't install

I'm in a strange situation, I install bundler in my RVM gemset, it sais it installed correctly, but when I try to run it asks me to to install bundler again: here is a transcript of my terminal ...
1
vote
1answer
316 views

Bundler (or Ruby) mangling require paths

About 50% of the time, when I run bundle (or bundle exec foo) I get an error like the following: > bundle ...
0
votes
1answer
101 views

rails-boilerplate (0.1.9) gem mirror

Using paperclip (3.2.0) Using polyamorous (0.5.0) Using pr_geohash (1.0.0) Using slop (3.3.3) Using pry (0.9.10) Using pry-rails (0.2.2) Gem::RemoteFetcher::FetchError: too many ...
0
votes
1answer
900 views

Error installing new rails version. Failed to build gem native extension

I am trying to build my first ruby on rails app using the following guide (http://ruby.railstutorial.org/chapters/a-demo-app#code-demo_gemfile_sqlite_version_redux) and have run into a few obstacles. ...
0
votes
2answers
608 views

Using RVM in Puppet manifests

I'm currently digging deeper into Puppet and with several manifests I encounter problems regarding the installed ruby version or rubygems. I would guess that others probably also run in such problems. ...
1
vote
1answer
1k views

Setting up Thin, Bundler and Ubuntu

I have a very simple Ruby application which uses Thin and Bundler that I need to stick on an Ubuntu box. I've got as far as getting Ruby, bundler etc installed on the server, but am having trouble ...
1
vote
1answer
527 views

How to install bundler gem on Hetzner server?

I am trying to install bundler using the following command: gem install bundler but recieve this error: ERROR: could not find gem bundler locally or in a repository Running command gem list ...
3
votes
3answers
4k views

How to start a rake task using upstart

I'm trying to setup a Resque worker as an Upstart init script to be used by Monit in a Rails app. I'm not a sysop and I've tried to write this using examples from other init script we have on our ...
2
votes
1answer
1k views

How do I get Apache's www-data to recognize RVm?

Problem: Apache/Passenger don't recognize RVM I have a multi-user install of RVM, per the canonical instructions: http://beginrescueend.com/rvm/install/ I then edited /etc/profile.d/rvm.sh to ...
1
vote
1answer
743 views

Passenger is preventing Bundler from seeing my git gems

I'm attempting to deploy a Rails 3.1 application to an Ubuntu 11.04 server running nginx-1.0.0 and passenger-3.0.7 I have a system-level RVM install at /usr/local/rvm/gems/ruby-1.9.2-p180 My ...