0
votes
1answer
689 views

Cannot set postgres user password

Trying to install PostgreSQL with Ruby on Rails with Nginx on CentOS 6.5 using the following guide: ...
0
votes
1answer
216 views

Trouble setting up Ruby with Nginx on CentOS 6.5

Following the instructions here: https://www.digitalocean.com/community/articles/how-to-deploy-rails-apps-using-passenger-with-nginx-on-centos-6-5 I get to the point of "Use vim /etc/init.d/nginx to ...
0
votes
0answers
22 views

Gem generating different output on different machines with same configuration

I'm using the premailer gem to generate inline CSS for a project I work. That project is also cloned on a CI server. The wierd stuff that is happening is that from some time now, it started failing ...
2
votes
3answers
3k views

Ruby Install on CentOS

I’m trying to install Ruby on Centos-6.4 64-bit as following: mkdir /tmp/ruby && cd /tmp/ruby curl --progress ftp://ftp.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p247.tar.gz | tar xz cd ...
1
vote
1answer
467 views

Yum install libyaml has depsolving problems

Trying to get ruby up and running on a centos 5 box. yum install libyaml-devel Loaded plugins: fastestmirror Repository base is listed more than once in the configuration Repository updates is listed ...
0
votes
1answer
133 views

RVM Not Finding Library

I am running CentOS 5.9 and installed RVM on it. However, whenever I run rvm requirements or rvm install 1.9.3, I get: --> Processing Dependency: libyaml-0.so.1()(64bit) for package: libyaml-devel ...
0
votes
1answer
219 views

RubyGem installation can't find header files

I'm running Ruby 1.9.3 on CentOS 5.3. I installed it by compiling Ruby 1.9.3 from source, along with libyaml. I'm also using rbenv to manage versions, so I placed the compiled installation in ...
1
vote
0answers
372 views

Mongrel failing to start after an OS update

So there's this installation on a virtual server, administered by Plesk, running CentOS. The OS has been automatically updated recently - this broke a custom ruby installation. I haven't set up the ...
0
votes
1answer
276 views

Redmine (RoR rack app) on uWSGI forgets sessions when ran with more than one process

When I log into redmine it forgets that I was logged after first click on any link or immediately after the login redirect. After I refresh the page a few times, I am still logged in in some of this ...
0
votes
1answer
178 views

Gitorious - ActionController::UnknownHttpMethod when logging in?

I'm going to install Gitorious as a slave server for failover purpose follow this blog post. gitorious.conf NameVirtualHost *:81 <VirtualHost *:81> ServerName gitorious.domain.com ...
0
votes
1answer
321 views

Trouble installing Redmine on CentOS 6.2 - undefined method db for main:object

I am trying to install RedMine on CentOS 6.2 but I am running into difficulties when I try to access the site. Using this guide, I have configured the following in environment.rb: # Load the rails ...
1
vote
1answer
347 views

Puppet - Call custom function (which contains case/when) from manifest

I am working on puppetizing my httpd and nginx vhost confs. Right now I have 5 servers which each have their own port and are run on server1, while nginx is running on server2. Obviously I need to ...
-1
votes
2answers
252 views

rvm doesn't install in centos without root privileges [closed]

I trying to install RVM using deployer user that doesn't had root privileges ant I getting this error: bash: line 439: ./scripts/install: Permission denied Any help? Thank you!
4
votes
5answers
10k views

How to fix “ruby installation is missing psych (for YAML output).” on CentOS?

After rvm installation on CentOS 5.8: [rails@localhost ~]$ rvm -v rvm 1.16.17 [rails@localhost ~]$ which ruby ~/.rvm/rubies/ruby-1.9.3-p286/bin/ruby [rails@localhost ~]$ ruby -v ruby 1.9.3p286 ...
2
votes
1answer
978 views

Why does my namespace and class name conflict?

I have a puppet module installed that is called ntp. A node do I define by node testip { include myconfig::ntpp } and in /etc/puppet/modules/myconfig/manifests/init.pp have I class myconfig::ntpp ...
2
votes
1answer
446 views

Why isn't the variable available?

Background I would like to apply this idea of having a common class that includes all the specific info about my setup. So I have created /etc/puppet/modules/common/manifests/init.pp with class ...
-2
votes
1answer
66 views

looking for answer of Ruby coding in linux [closed]

puts ((11.to_s * 2).to_i/2), does anyone know answer of this coding? I am not aware of ruby!
1
vote
2answers
2k views

How to upgrade ruby on CentOS 5.3?

I have a CentOS 5.3 machine which I want to run SASS. To do this, I need to update the version of Ruby on the system. I've tried multiple methods of doing this, but none have worked so far (including: ...
0
votes
1answer
1k views

puppet dashboard fails to start

So here's the situation. I'm running Puppet on CentOS 5.7 64-bit, and on the puppet master I also have puppet-dashboard, however when I try to start it, I see the following: [root@puptest-master ...
1
vote
2answers
466 views

CentOS - Ruby - Executable host ruby is required

I am trying to compile ruby (v1.9.2) on a CentOS 5.6 system (kernel v2.6.18-238.12.1.el5), but keep getting a "executable host ruby is required" error message during make. Here are the steps: ...
1
vote
1answer
1k views

Can't compile CentOS 5, Ruby 1.9.2 and OpenSSL 1.0.0c [closed]

I'm trying to install Ruby 1.9.2 on CentOS 5.5. I get through most of the make process, but when it tries to compile OpenSSL I get an error. Below is the errror outputted: compiling openssl make[1]: ...
5
votes
2answers
13k views

How to setup Ruby and RubyGems on CentOS?

I have a CentOS 5.5 (64-bit server) I'd like to install Ruby 1.8.7 (current patch level) and RubyGems What's the best way to go about this? disclaimer: I'm a CentOS noob
0
votes
1answer
221 views

Change version of ruby does not work on CentOS

I'm trying to change version of the running ruby on a CentOs machine. -# rvm use ruby-1.9.1-p378 -# ruby -v -# ruby 1.8.6 (2007-09-24 patchlevel 111) [i686-linux] It is installed (by rvm) and I ...
0
votes
1answer
232 views

ruby on rails on CentOS?

I'm trying to install RedMine (www.redmine.org) which is an awesome project management tool. I have access to a CentOS machine which is supposed to host it. I found some guide specifying how to ...
0
votes
3answers
788 views

Start ruby script at boot as particular user

wondering how I can have a ruby script started at boot, as a particular user. This is on centos, so I imagine i need to create a service. ?
0
votes
3answers
3k views

What steps can you take to ensure sane build environments when compiling software?

I'm having a horrible time getting a piece of software to compile on a CentOS box, and the problem I've listed below is specific, but I'm hoping the correct approach that comes out of this is one that ...
1
vote
3answers
4k views

centos ruby 1.8.7 repository

I can't find a repository that contains ruby 1.8.7. All repos only contain 1.8.5 or 1.8.6 versions. Does anyone know of any repos with ruby-1.8.7?
2
votes
1answer
4k views

OpenSSL support for Ruby: “Cipher is not a module (TypeError)”

The Problem Our systems admin needed to upgrade the packages on our CentOS 5.4 dev server to match the packages on our production server. The upgrade affected ruby and/or openssl. We run a Ruby on ...
2
votes
4answers
7k views

How do I cleanly remove ruby 1.8.7 from CentOS 5?

How can I cleanly remove my ruby version 1.8.7 from CentOS 5? I installed it by downloading the source code and performed a make.
4
votes
8answers
2k views

How can I get alerts when my site is down?

My blog is a custom ruby/rack application, and has been crashing randomly every couple of weeks. I sometimes don't notice for days, and I'd like to be notified immediately if it happens. What's the ...
1
vote
3answers
2k views

cron not running on centos 5.2

Sorry if this is a dupe - after I merged my Stackoverflow and serverfault accounts, my question seemingly was erased... Using CentOS 5.2 and this cron is not running at all (/var/log/cron is not ...
1
vote
5answers
5k views

Installing Mysql Ruby gem on 64-bit CentOS

I have a problem installing mysql ruby gem on 64bit CentOS machine. [jacekb@vitaidealn ~]$ uname -a Linux vitaidealn.local 2.6.18-92.el5 #1 SMP Tue Jun 10 18:51:06 EDT 2008 x86_64 x86_64 x86_64 ...