0
votes
1answer
37 views

CentOS 5.5 php-posix with dependency error php53-common

I'm having problems installing php-posix. The problem I have, is that I used epel.repo and now I can't work out how to get past this. I'm not great with Redhat & yum. [root@badelivery ~]# yum ...
0
votes
2answers
478 views

CentOS 5 - yum update dependency error

I'm trying to run an update on my CentOS VPS. Ultimately what I am try to do is upgrade php53 to php55. However I appear to run in to some dependency issues. Please find below commands and outputs. I ...
0
votes
2answers
194 views

MariaDB Permission denied when using socket

Here is the gist of my problem: I have a web application that won't connect when the database has the host is set as localhost, however it will if I use the address 127.0.0.1. The error that PHP ...
0
votes
1answer
68 views

PHP debugging under Apache on CentOS 5.9

After upgrading a vBulletin installation, accessing any page tells me that files are missing--even though they exist in the filesystem. Based on other questions I found here, I have tried changing ...
0
votes
0answers
141 views

PHP Upgrade 5.1 to 5.4

I've upgraded PHP on my CentOS 5.10 box. I added the epel 5 repo and used yum to upgrade to PHP 5.4.21. PHP was working fine before this, but since the upgrade it just spits on the code, it shows a ...
0
votes
0answers
33 views

Upgrading PHP to 5.2.3

I have cacti running on centos running PHP 5.1.6. I need to upgrade to 5.2.3 so I can install media wiki. Whats the best way to achieve this so it doesnt effect my cacti install ? Thanks,
1
vote
0answers
99 views

Running PHP 5.2 FastCGI + Apache on CentOS 5 issue [closed]

I am trying to setup 2 versions of PHP on Centos 5.9 using this tutorial: http://linuxplayer.org/2011/05/intall-multiple-version-of-php-on-one-server. I have followed I have installed default 5.4.19, ...
1
vote
0answers
64 views

Long running Apache processes after Php execution completed

Apache/2.2.3 PHP 5.2.5 CentOS 5 Trace Trace details image start php run script run kill (registered Php shutdown function) apache still runs for long time, unknown why This does NOT happen ...
0
votes
2answers
333 views

Cannot install php-intl on CentOS

When I run: yum install php-intl I get this error: Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirror.as29550.net * epel: ftp.nluug.nl * extras: ...
0
votes
1answer
214 views

PHP curl showing wrong version

Hi I have been trying to get Curl with SSL support on CentOS 5.9 server . I have in the process updated php to 5.4.11 using the remi repo. The system is running plesk and when I do I look at phpinfo() ...
0
votes
1answer
4k views

How enable pdo_mysql

I am trying to install SpaceBukkit. I was wondering how I enable pdo_mysql. When trying to setup the MySQL part I get this error: The "pdo_mysql" extension is NOT loaded in your `php.ini`! Make sure ...
0
votes
0answers
100 views

How to get uncaught PHP errors from fcgi server

My web hosting company recently replaced suPHP with fcgi on my dedicated server because I needed opcode functionality. Since then I see loads of 500 errors in apache error and php error log is empty. ...
-1
votes
2answers
54 views

How to configure apache2 from source with php from repo?

I'm asking this question out of my curiosity. Is there anyway around to configure apache2 with the php that had been install through yum? Or vice versa? Because based on my self experiences and ...
2
votes
1answer
191 views

PHP 5.2.10 lost json and mcrypt - Parallels Small Business Panel v10.2.0_build102100709.06 os_CentOS 5

I updated my PHP from 5.1 to 5.2 a few months ago. Since then I noticed I don't have mcrypt. I tried everything I could too install it. Yum install...added to /etc/php.d/mcrypt.so etc. but nothing ...
1
vote
0answers
290 views

pgsql troubles on centOS 5 with directadmin

I'm having trouble configuring pgsql for PHP 5.2 on the server I administer. It's a DirectAdmin enabled server, and the contents of ap2/configure.php5 are: #!/bin/sh ./configure \ --with-apxs2 \ ...
0
votes
2answers
3k views

PHP 5.4 on CentOS 5 - GD Not Working

I installed PHP 5.4: rpm -qa | grep php php-common-5.4.6-1.el5.remi php-5.4.6-1.el5.remi php-cli-5.4.6-1.el5.remi Here's my php-m output: php -m PHP Warning: PHP Startup: curl: Unable to ...
2
votes
1answer
6k views

Trying to install phpmyadmin on centos - mysqli missing

Here is the error I get when trying to open my phpmyadmin directory: phpMyAdmin - Error The mysqli extension is missing. Please check your PHP configuration. I have done the steps in the following ...
0
votes
1answer
304 views

How do I troubleshoot a session saving issue on my Media Temple CentOS VPS?

My website won't save PHP sessions properly, I originally posted on it in SO, but it's increasingly looking like a server issue. So, I figured I would re-phrase the question here. Why would this PHP ...
4
votes
1answer
11k views

How to upgrade to latest PHP, MySQL, and phpmyadmin on CentOS 5.8 (32bit)?

I have searched around on the internet and cannot find a reliable source for installing the latest versions of PHP, MySQL, and phpmyadmin on CentOS 5.8 32bit with apache. I have tried a couple times, ...
0
votes
1answer
2k views

How to enabled pdo mysql in Centos 5.8

I have a VPS with Centos 5.8 In phpinfo displays: './configure' '--disable-fileinfo' '--disable-pdo' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-libxml' '--enable-magic-quotes' ...
0
votes
2answers
501 views

Receiving segmentation fault on various commands Centos 5.8

I have a server running CentOs 5.8. I installed New Relic yesterday. From 9am this morning the following commands give me Segmentation Fault: wget yum rpm I can still access Midnight Commander, ...
3
votes
2answers
2k views

Unusually high memory usage on a CentOS VPS with 512 guaranteed RAM

I'm working on a medium-sized web application written in PHP that's running on a VPS with 512mb ram. The webapp hasn't been officially launched yet, so there isn't too much traffic going on, just me ...
-1
votes
1answer
2k views

CentOs 5.8 php installation

I have recently downloaded and compiled the latest version of PHP on to my server. However, realized I did all of this as root. PHP shows as successfully installed, however php pages do not render, ...
0
votes
2answers
510 views

php 5.3 and libxml2 nightmare

My CentOS 5.7 ships with libxml2 2.6.26 that is very outdated and also causes many problems with my current PHP 5.3.3. I need to update libxml2 to 2.7.8 version or at least 2.7.3+ i've readed many ...
1
vote
1answer
432 views

Updated PHP from 5.1 to 5.3.9 and accidentally uninstalled Plesk (Linux)

I was updating PHP and when attempting to install 5.3.9, I got conflicts with 5.1 so I (rather stupidly) ran yum remove php php-* and I think that this removed the plesk plugin and I am able to access ...
4
votes
1answer
149 views

making sure daemons are safe

So I was wondering, what steps should we take to make sure PHP daemons are safe? One of the things that I read about was assigning the daemon to run as a user with limited priveleges? But how can we ...
0
votes
1answer
173 views

Error 500 message - but only for certain pages/ operations

I'm a bit confused and bewildered by a problem I seem to be having with Apache/ PHP. Whenever I try to open certain pages, I'm confronted by an error 500 message. For example, if I try to edit a View ...
1
vote
2answers
5k views

mod_rewrite is not being enabled?

I have php 5.3.8, apache 2.2.21, all is good, except mod_rewrite by default LoadModule rewrite_module modules/mod_rewrite.so is enabled (not commented out) ClearModuleList does not exist AddModule ...
0
votes
1answer
271 views

ffmpeg-php installation error on centos

I've installed ffmpeg and and ffmpeg-php so many before and it worked, today i'm having an error when i run make or make install, i get this error make: *** [ffmpeg_frame.lo] Error 1 i tried these ...
0
votes
2answers
409 views

CentOS/yum - Upgrading php 5.1 -> 5.3 without upgrading mysql 5.0 -> 5.1

I'm attempting to upgrade php from the centos default of 5.1.6 to 5.3.8 out of the Atomic repo, but when doing so, yum wants mysql to upgrade from 5.0 to 5.1, saying that php-mysql-5.3.8-1.el5 is ...
0
votes
1answer
321 views

why “php -i|grep php.ini” is not finding the correct path to php.ini?

I know that my php.ini is located at /etc/php.ini but when i run php -i|grep php.ini I get this output Configuration File (php.ini) Path => /usr/local/lib there's nothing in that directory and i ...
0
votes
1answer
1k views

how to install phpshield loaders on centos 5 64 bit, (i have php 5.3.8)

I have followed this tutorial and this one, I have downloaded the proper version and still cannot get phpmotion to detect it. Before i contact the support team for help, I just want to know if there's ...
0
votes
0answers
1k views

PHP cannot execute shell commands (CentOS 5.6, PHP 5.3.3)

Title says it all; I cannot run shell commands properly from PHP (CGI). Most commands (pwd and my own program) end with an exit code of 1 (permission denied). The command ls ends with an exit code of ...
0
votes
1answer
1k views

Setting Up Zend Framework on CentOS - Unsure where to place Zend folder

I have a CentOS server and am attempting to setup Zend Framework on it. The command which php outputs /usr/bin/php and php -i | grep include_path outputs include_path => ...
1
vote
2answers
343 views

Upgrade PHP on CentOs5

This morning I used yum upgrade to upgrade from php 5.1.6 to 5.3+ I then went to one of my sites and found that it had crashed, error establishing database connection. I found through this question ...
1
vote
1answer
3k views

Loading JSON in PHP53: ZVAL_DELREF in Unknown on line 0

I'm trying to loading JSON into the new-installed PHP5.3.1 on a CentOS server. Previously there was a PHP5.1 or near and due to the latest version of WordPress I had to upgrade the PHP. I tried to ...
1
vote
1answer
214 views

cron jobs for php executing differently

I have setup dkim on my server using opendkim(centos). when php executes mail command(on website eg forgot.php). it sends an email signed with DKIM. but i also setup a cron job to run mailcron.php ...
0
votes
1answer
38 views

Getting PHP5 To install

It seems I am stuck with a 4yo build of PHP (PHP4.3.9 Built: 2007) and I am trying to upgrade. Right now, it's like a traffic puzzle, or a vicious cycle, whatever you want to call it. I try to upgrade ...
3
votes
2answers
2k views

PHP Woes - 500 Internal Server Error (brand new server)

Anyone ever seen these errors, or something like it? /usr/bin/php: error while loading shared libraries: libcom_err.so.2: failed to map segment from shared object: Cannot allocate memory [warn] UID ...
1
vote
2answers
1k views

Enable zip on PHP 5.1.6 without recompile

I've got a CentOS / Red Hat 5.5 box running the current PHP 5.1.6 package. A user is getting the following error: Fatal error: Class 'ZipArchive' not found in /var/www/html/<filename.php> on ...
1
vote
1answer
384 views

Centos 5.5 install PearDB

Disclaimer: I use Linux for some jobs but I am not a Linux admin. I have a Centos 5.4 machine which performs some server duties and doubles as a web site development machine. PHP 5.3.3 was installed ...
2
votes
2answers
2k views

Installed php-mcrypt but it doesn't show up in phpinfo()

I'm trying to install php-mcrypt on a CentOS 5.4 but while the extensions appears to be installed, there's nothing about it when I do a phpinfo(). For example, you can see below that php-mcrypt ...
1
vote
1answer
634 views

CentOS package not available

I installed a CentOS 5.5 and the default php package is 5.1.6. I want to install 5.2.9, so I added /etc/yum.repo.d/CentOS-Testing.repo [c5-testing] name=CentOS-5 Testing ...
3
votes
1answer
1k views

Cent OS upgrade PHP

I'm in the midst of resolving a bunch of security issues on a clients server to get them compliant with credit card laws and such. The first order of business is getting php from 5.2.14 to 5.2.16. ...
0
votes
2answers
2k views

Upgrade PHP to 5.3 on CentOS 5 and Plesk 9.0.1

I have a VPS that currently runs CentOS 5 and Plesk 9.0.1. Right now the server runs PHP 5.1 but I really need to start running PHP 5.3. Is there a repository out there that would allow me to upgrade ...
15
votes
4answers
11k views

Failed to instal APC via pecl install APC

Hy when i try to install APC via pecl install APC-3.1.5 or even pecl install APC I get following error when the package comes to the make command: running: make /bin/sh ...
0
votes
3answers
4k views

How do I activate SQLite3 on PHP 5.3.3 Centos 5?

I have reviewed the previous questions on this and they don't seem to cover what exactly I'm looking for, before I start, I'm no server admin. I'm trying to help get this server up and active and I ...
2
votes
2answers
2k views

PHP-CGI Not working on CentOS 5?

While trying to configure php-cgi on a CentOS 5 server running nginx, I run into this: [root@~~~~~~~ run]# /etc/init.d/php_cgi start Starting php-cgi: spawn-fcgi: child exited with: 255 ...
0
votes
4answers
3k views

Installing phpMyAdmin on Cent OS 5.5

This is installed on CentOs 5.5 Please bare in mind that this is on a local network at work and access from the outside world is not possible due to the strict restrictions on the local network. I ...
0
votes
1answer
3k views

PHP mail() not sending emails Centos Cloud Server

I am new to this. Have got a cloudserver running centos 5.4, Installed php, mysql and apache to run magento however emails are not going out.. Do I need to configure something more?