0
votes
1answer
82 views

Verify PHP 5.3.27 has been patched for CVE-2013-4248

Server setup: CentOS release 5.10 (Final) WHM 11.40.0 (26) EasyApache 3.22.24 rev9999 compiled apache 2.2.26 and PHP 5.3.27 w/ SuHosin 0.9.33 I already had PHP 5.3.27 installed (since before most ...
0
votes
1answer
50 views

Warning messages while building Apache server

I am building Apache server 2.4.6 from source and am not sure about a few warning messages I received during the rpm build process. The build completes OK and everything seems fine..BTW, this is on ...
2
votes
2answers
697 views

Httpd restart “Address already in use” error

I have an .rpm, which I created. In its %post part, I do some stuff, and in the end of this script, i call service httpd restart. It gives the following error: + service httpd restart Stopping httpd: ...
1
vote
2answers
190 views

Install gettext-0.17-1.el5.i386.rpm on CentOS 5.8 i386 gives “/usr/bin/python is needed” error

I've removed yum by mistake. So, now I'm installing all the dependencies needed by yum manually. One of those is gettext-0.17-1.el5.i386.rpm and when I try to install it gives the following error, ...
3
votes
1answer
66 views

Re-packaging commercial software into RPM packages

The situation is this - I have a small CentOS 5 "cluster" (currently 7 machines, but potential for more) which run a commercially available software package that's distributed essentially in tarball ...
0
votes
1answer
806 views

Client is not able to use Yum Server configured on Server under /home/RPMS file path

I have configured Yum Server on Server 10.0.0.1(Redhat 5.3) All RPMS are here /home/RPMS/Server. Now on another machine i have Centos 5.3 (10.0.0.30).I want to use yum Server of 10.0.0.1 on 10.0.0.3 ...
1
vote
1answer
333 views

Obtain newer version of NetSNMP for CentOS 5

I'm using CentOS 5. I have a need to use net-snmp version "net-snmp-utils-5.5-37.el6_2.1.x86_64" which is currently available in CentOS 6 but not in CentOS 5. The reason I need this version (or ...
0
votes
1answer
216 views

Handling yum upgrade from pkg-x.y.rpm which requires mod_python to pkg-x.(y+z).rpm with conflicts mod_python

With yum/rpm on RHEL 5 can a yum upgrade be made to remove another, conflicting package - similar to the behaviour of apt-get dist-upgrade on Debian? I am updating the .spec for our product's rpm. ...
5
votes
3answers
2k views

CentOS6 installation from CentOS5 box?

I am trying to build a new CentOS 6 VM from my CentOS 5 host, but it appears that something fundamental has changed between these versions: $ rpm -ivh --nodeps --nodigest --ignorearch --ignoreos ...
0
votes
1answer
692 views

RPM ERRORs on a cloud CentOS 5.5 server

I am attempting to add an rpm repo in order to Yum install a Munin node, however i keep getting the following error: rpm -Uvh ...
2
votes
3answers
6k views

How to create RPM for 32-bit arch from a 64-bit arch server?

Our production server is running CentOS5 64-bit arch. Because there are no RPM available currently for SQLite latest version (v3.7.3), I created RPM using rpmbuild the very first time by following ...
1
vote
2answers
139 views

Is it OK to install a RPM built for lower OS version onto a higher OS version?

Our production server is running sqlite-3.3.6-2 on CentOS release 5.2 (Final). We're planning to upgrade SQLite to the latest v3.7.3 (atleast v3.5+). But there is no RPM available in SQLite website ...
10
votes
3answers
15k views

How to list RPM dependencies?

Our production server is running CentOS release 5.2 (Final). How do I see/get/list all the dependencies of an already installed RPM package? For example: SQLite v3.3.6 is already installed in the ...
1
vote
2answers
195 views

How do you update a driver after a fresh CentOS installation?

I've been a long time Debian user but now I'm working with Red Hat and I'm a bit lost. I just installed a fresh install of CentOS 5.5 on a new Dell server. Dell provides a current Red Hat 5.5 driver ...
1
vote
1answer
3k views

Failed depencies: libmysqlclient.so.16 is needed

I'm trying to install something on my server that requires mysqlclient, but looking at my RPM package list I have it ("MySQL-client-5.0.91-0.glibc23"). Doing a locate on libmysqlclient gives me this: ...
1
vote
1answer
84 views

Centos 5 RPMs on RHEL 5

I know this isn't ideal, but typically how compatible are Centos5 rpms with RHEL5? Is the only real difference the enterprise package management, or are the two OS as divergent as Fedora and RHEL?