CPAN is the Comprehensive Perl Archive Network, a large collection of Perl software and documentation. It is the de facto location for finding reusable Perl modules.

learn more… | top users | synonyms

0
votes
1answer
700 views

GnuPG::Interface fails to install on CentOS 7

I'm trying to install a CentOS 7 server to run Request Tracker. By running make testdeps I can see all missing packages and make fixdeps is supposed to install this packages. There is one package that ...
0
votes
1answer
289 views

Not able to install Statistics::Basic on RHEL5

I am trying to install the perl module Statistics::Basic::Mode on a RHEL 5 system and am having issues. I have tried MCPAN and RPM. Here is the result of running sudo perl -MCPAN -e shell > ...
0
votes
1answer
253 views

cpan configuration wrong - how to change?

I seem to have misconfigured spam and am now trying to change it. I read elsewhere to remove /root/.cpam, which I did but that did not help to get me the initiation dialog. When I type into the ...
0
votes
1answer
178 views

Help Installing Perl Module XML::Parser using CPAN

I'm trying to install the XML::Parser perl module using CPAN and can't get it to work. Below is the output that is being displayed by CPAN which appears to indicate that Expat is the issue. I've ...
0
votes
1answer
559 views

Troubleshoot Perl module installation on Mac OS X

I'm trying to install the Perl module Set::IntervalTree on Mac OS X. I recently installed it today on an Ubuntu box with no problem. I simply started cpan, entered install Set:IntervalTree, and it all ...
1
vote
0answers
745 views

Getting errors from local CPAN configuration on server with no internet

I've been wrestling with getting a local CPAN installed and configured on a CentOS server with no internet access. What I've done so far is this: 1) Made a full rsync of a CPAN directory onto an ...
1
vote
0answers
422 views

File::Temp version 0.18 required--this is only version 16

I ran YUM on a server running BestPractical's RT. Now Apache won't start. Looking at the error log I get this error: File::Temp version 0.18 required--this is only version 0.16 at ...