0
votes
3answers
703 views

Debian 5 Lenny how to upgrade Python to 2.7 version to run Django app?

I'm configuring Debian 5 to run my Django app. The required application is required incompatible with Python 2.5 packages. I installed Python 2.7 and created the symlink python -> ...
3
votes
2answers
1k views

Debian Lenny, Python 2.7 and mod_wsgi

I am running a Debian Lenny box, which comes with Python 2.5.2. I would like to run Python 2.7 for my WSGI apps only, keeping 2.5 as default for the system, but I cannot get it to work. First, I ...
0
votes
1answer
193 views

How to install python 2.6 on lenny

I would like the easiest way possible to install 2.6 on Lenny. I get really frustrated with compiling from source cause i can never get it right. any help will be great! Thanks
1
vote
1answer
1k views

When installing setuptools on Debian Lenny, why do I get zlib error?

I'm seeing this error when I run python2.6 setup.py build on Debian Lenny from the setuptools-0.6c11 source: Compression requires the (missing) zlib module
4
votes
3answers
17k views

How do I install Python 2.6 on Debian 5.0 (lenny) using apt-get?

After some digging and experimentation, I figured out how to install Python 2.6 on Debian 5.0 using apt-get. So I thought it best to post on SF as a question and answer. I know this can be manually ...