1
vote
1answer
181 views

Backup broken PostgreSQL 8.4 without pg_dump

So. I have a problem. PostgreSQL 8.4 won't start or restart without any output given. But it worked for 3 monthes until hosting provider doesn't rebooted server. Now it is completly broken. It wan't ...
0
votes
1answer
424 views

How to get rid of “Could not connect to database” with Linux and libnss-pgsql2?

I use libnss-pgsql2 in order to have virtual system users stored in a PostgreSQL database. The virtual users in the database work just fine. They can log in. I can see their uid, gid, groups via the ...
0
votes
1answer
446 views

PostgreSQL fails on boot, but works fine after logging in

I'm not sure if my problem started after update. I'm running Debian Squeeze and postgresql-8.4(8.4.12-0squeeze1). On startup or after reboot, I noticed that my PostgreSQL database service fails. ...
10
votes
1answer
3k views

How to use a custom status command for a service in puppet?

I am using debian squeeze with PostgreSQL 9.1 from backports. Puppet has version 2.7.14. Unfortunatly the init script returns the wrong exit code for status. Therefore I wrote a custom status command ...
0
votes
2answers
641 views

Installing Postgresql 8.3.7 in Debian Squeeze

I am tring to install postgresql-8.3.7 into Debian Squeeze OS. It is throws me following error. unmet dependency libkrb53, libpq5 . Whether postgresql-8.3.7 is compatible with Debian Squeeze ...
3
votes
2answers
2k views

Complete solution to upgrade PostgreSQL on debian production server

I'm using Debian 6 (Squeeze) in production for a couple of websites. I decided to use postgresql backports so that I could use PostgreSQL 9.0 features. I thought that it would remain 9.0 and receive ...
0
votes
1answer
1k views

Postgres connection establishment slow

If I wan to connect to postgres 9.1.1 db on debian lenny with PgAdmin, it takes >15 seconds until the connection is established. There is nothing to see in the logs why it takes so long. Any ideas ...
2
votes
1answer
1k views

Using PostgreSQL 9.0 and PostGIS 1.5 on Debian Squeeze

I have installed PostgreSQL 9.0 (postgresql) and PostGIS 1.5 (postgis) from Debian Backports on my freshly installed Squeeze (stable). However, when trying to create a PostGIS-enabled database, I ...