0
votes
1answer
433 views

Running dist-upgrade fails on installation of 'startpar'

I'm trying to run dist-upgrade on Debian 6 but it fails on installation of startpar with: dpkg: considering deconfiguration of sysvinit-utils, which would be broken by installation of startpar ... ...
1
vote
1answer
93 views

Difference between package updates and release upgrades on Debian

I've been trying to decide on a new OS for my production machine, and I was wondering what the difference is between straight up upgrading packages and upgrading to a new release. If I install Debian ...
1
vote
1answer
511 views

Ubuntu upgrade multiple versions at once

I need an Ubuntu 11.10 server, but for reasons beyond my understanding, our host only preinstalls Ubuntu 10.04 LTS. So I decided to get a 10.04 server and use Ubuntu's do-release-upgrade to get to ...
1
vote
2answers
657 views

Can't install PHP after apt-get dist-upgrade

I had a server with perfectly running for months classical LAMP installation on Ubuntu 8.04: Linux localhost 2.6.24-23-generic #1 SMP Wed Apr 1 21:47:28 UTC 2009 i686 GNU/Linux DISTRIB_ID=Ubuntu ...
2
votes
2answers
537 views

How to run Postgresql 8.2 on Debian lenny?

We are running a legacy application which requires PostgreSQL 8.2 on Debian Etch. Since Debian dropped support for etch, we're seriously considering to upgrade to Debian Lenny. However, we are stuck ...
2
votes
2answers
1k views

dist-upgrade to squeeze wants to remove apt

why does dist-upgrade to squeeze want to remove apt and how can I fix it? $ sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done ...
22
votes
2answers
10k views

Can someone clarify Ubuntu (Debian) dist-upgrade for me?

I've got an Ubuntu 8.04 LTS server. There are several packages which are "kept back" ("the following updates have been kept back:") when I do an apt-get upgrade. It's my understanding that I can do ...