0
votes
3answers
2k views

Ubuntu: Cannot apt-get upgrade server, dpkg permission denied even when root?

I've ran a general audit of the system and found that a few packages were aging, such as OpenSSH and related so I went to apt-get update then upgrade. Unfortunately it seems to get the packages ...
19
votes
1answer
13k views

How to update a package using puppet and a .deb file

I am trying to figure out the proper way to update/upgrade a deb package using puppet from a local source deb file. My current config looks like this... class adobe-air-2-0-4 { file { ...