1
vote
2answers
2k views

PHP5 is installed, but Apache is displaying PHP as uninterpreted text. How can I get it to process it as PHP?

In a Drupal installation, it's displaying the root PHP file as plain text below. a2enmod says that php5 is enabled, aptitude says libapache2-mod-php5 is installed, mods-enabled/ has php5.conf and ...
1
vote
1answer
2k views

Zend Optimizer not compatible with PHP+APC+Drupal. Can I disable it for Drupal-run domains?

I use the following set up: PHP Version 5.2.17 Apache/2 Zend Optimizer v3.3.3 Drupal 7.8 As far as I read other articles and questions, Zend Optimizer doesn't do any good neither for PHP5 ...
1
vote
1answer
143 views

Ideal technology stack for Drupal 6 in Windows Server 2008R2

My background is predominantly Linux-based servers, with which I can configure anything however I want. However, I'm building a Drupal6 site for a client, who (despite my warnings) wishes to self-host ...
1
vote
2answers
2k views

Using Puppet to Install PHP 5.2 on Ubuntu 10.04

I'm working on installing PHP 5.2 on Ubuntu using Puppet (with the goal of using Puppet and Drush to install Drupal), but the packages it installs are all PHP 5.3. I found instructions to install PHP ...