0
votes
3answers
165 views

CentOS Network Interface Priorization

I have a CentOS server with 2 network interfaces with configurations: eth0: DEVICE=eth0 BOOTPROTO=none BROADCAST=10.0.0.255 HWADDR=xx: IPADDR=10.0.0.2 NETMASK=255.255.255.0 NETWORK=10.0.0.0 ...
1
vote
1answer
38 views

Use or not to use multiple ips on the same network card?

I got a Dell r620 that cames with 4 network interfaces. If I have for example 4 ips, and want to assigne them to the server. What would be better, in terms of performance. Add all the 4 ips to the ...
3
votes
2answers
284 views

How can I make a secondary NIC port “eth0”?

I am using CentOS 5.9. One of my servers recently had a malfunctioning NIC port. The software running on the server was hard-coded to use eth0. The other physical NIC ports were fine and unused. The ...
-3
votes
1answer
502 views

Changing the default gateway address in Centos

I have a a Centos PC with 2 IP addresses. One of them is because of a back to back connection with another PC, so both run on different subnets. The eth0 has the 192.xx.xx.xxx address and eth2 has ...
0
votes
1answer
121 views

Linux network adapter keeps changing settings

I'm running CentOS 5 and noticed for the past week that eth0 settings keep changing and I have to reset them. Any ideas what it might be or where I need to start?
0
votes
1answer
584 views

SIOCSIFFLAGS: Resource or Device Busy

Have a Dell PowerEdge 2350 with dual nics built into the motherboard. eth0 works fine. Setting up an IP under eth1 results in the error: "SIOCSIFFLAGS: Resource or Device Busy". I have two ...
2
votes
1answer
2k views

Ethernet link dropping out consistantly (CentOS 5.5 / Dell 2950)

A few days ago the internal interface on one of my backup servers went down, and I've not been able to get it to work correctly since. In dmesg, I'm seeing: ADDRCONF(NETDEV_UP): eth0: link is not ...
0
votes
2answers
535 views

Unusual behaivior of ethernet cards on CentOS

So I am experiencing some weirdness on one of my servers. It has two on board gigabit ethernet ports on it's motherboard both of which seem to have been detected correctly (Broadcom NetXtreme II ...
1
vote
3answers
2k views

Linux NIC Bonding Issue (CentOS 4 / RHEL 3)

I am having an issue with bonding NICs on CentOS 4. It appears the bonding driver does work, but it is stuck in round-robin mode and I am trying to get to active-backup. The current config is: ...
0
votes
1answer
105 views

Restore eth2 interface?

i have centos 5, i have used "ifconfig eth2 down" and the server gets unaccesible, i can access to the files only at the moment, so i cant use "ifconfig eth2 up" to restore it, wich files have i to ...