The tag has no wiki summary.

learn more… | top users | synonyms

-2
votes
0answers
7 views

Not able to install modules p5-Expect, P5-IO-Tty, p5-IO-Stty, p5-Digest-MD5, p5-YAML in FreeBSD 10 [migrated]

I have installed OS FreeBSD 10.1 and installed perl 5.16 from my folder /usr/ports/lang/perl5.16. then i did: # portsnap fetch # portsnap extract then I am trying to make install clean port ...
2
votes
4answers
2k views

What's the best way to auto clean distfiles after using make/portupgrade in FreeBSD?

I'm playing with a FreeBSD installation inside a Virtualbox vm, and I want to keep the size of the image relatively small. How can I configure FreeBSD to clean distfiles after installing a port (using ...
8
votes
2answers
867 views

FreeBSD ports: remove build dependencies after installing port

Is there any way to remove build dependencies of the port after installing it? Many ports use exotic tools for building and these tools are not used anymore when port is builded and installed.
5
votes
1answer
187 views

Check ChangeLog of FreeBSD port before upgrading

Is there an easy way to check a ChangeLog of a FreeBSD port before you upgrade? For instance, I'd like to check what upgrades are mandatory before I do portmaster -ad. It would be nice to have ...
5
votes
4answers
5k views

FreeBSD Ports: How can I see all dependencies for a port, and all subdependencies for those dependencies?

I'm trying to build a port which depends on apache-ant. I thought I could run make build-depends-list to see all dependencies required by this port: # make build-depends-list ...
3
votes
3answers
727 views

Use default options when compiling ports

I am compiling a few ports on FreeBSD, however during the compiling process I am often greeted with options for the dependencies of the port. This causes the compiling process to pause until I select ...
3
votes
1answer
132 views

GCCVERSION not found error when installing a FreeBSD port

I am trying to install a program using port on FreeBSD 4.7. I get this error: Couldn't find your current GCCVERSION (OSVERSION=470000) How would you fix an error like this?