The tag has no wiki summary.

learn more… | top users | synonyms

6
votes
2answers
12k views

Install libxml2 2.7.X on CentOS 5.X

CentOS ships with libxml2-2.6.26. I have to install at least 2.7.X version. I downloaded RPMs for libxml2, libxml2-devel and libxml2-python (2.7.8) from XMLSOFT (http://xmlsoft.org/sources/). I am ...
5
votes
2answers
352 views

Linux: Block IPv6 for certain applications / hostnames

Problem and aim We don't get IPv6 from our ISP thus I have an IPv6 tunnel which works fine but is, of course, not very fast. And not really reliable. I like to have IPv6 available "just in case" but ...
4
votes
1answer
843 views

GLIBC 2.6 on Centos 5.8

There are many discussions about glibc on CentOS on serverfault but I couldn't find one directly related to these: I have CentOS 5.8 server and I would like to install G-WAN. It requires GLIBC 2.6, I ...
3
votes
2answers
7k views

glibc 2.7 on CentOS 5.5?

I'm trying to run a program that requires glibc 2.7, but I'm running it on CentOS 5.5. Is there any way to do this? I can't upgrade to CentOS 6.
3
votes
2answers
634 views

What can go wrong with a GLIBC upgrade?

I recently installed a piece of software that my group needs for a research project starting next September. Turns out the software has a known crash bug when used with glibc 2.12.1. My boss asked ...
3
votes
2answers
786 views

Problem upgrading kernel on debian 3.1

I have a quite old box in a remote server farm. So I have no direct access. Only remote SSH (and via SSH to a serial console). I haven't updated this box in ages. Now, whenever I want to install a new ...
3
votes
2answers
1k views

upgrade glibc on RHEL4 without breaking anything

I have a static version of wkhtmltopdf which requires glibc-2.4 wkhtmltopdf: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by wkhtmltopdf) I have apt installed with the DAG repos. ...
2
votes
1answer
269 views

Can I update libc.so.6 with no risk of breaking the server?

I have a server which for different reasons I cannot upgrade. It's running SUSE 11.4. I need to run a package that requires GLIBC_2.14, and I have GLIB_2.11 The error I'm getting is: ...
2
votes
1answer
2k views

5 second resolving delay

Using wget (curl, httplib2) I always get a 5 second resolving timeout. This issue doesn't arrive when I do wget -4 or wget -6. Resolving also works using dig or host. Delay can be lowered using ...
2
votes
1answer
109 views

All commands stopped working in centos 6.5

I have made a big mistake while removing some duplicate packages as it appears to be broken. yum 1036 rpm -e --nodeps glibc-2.12-1.132.el6_5.2.x86_64 1037 rpm -e --nodeps ...
2
votes
1answer
27 views

Squeeze/Lenny compilation : Library Link error [closed]

I've got a problem here : I have a C++ Library ("DataTsBroad") and a C++ Test app ("DataTsBroadTest"), to test it. Actually, the Lib and the Test app are both compiled an a Debian Lenny. Now, i ...
1
vote
1answer
1k views

Accidentally deleted symlink libc.so.6 in CentOS 6.4. How to get sudo privilege to re-create it?

I accidentally deleted the symbol link /lib64/libc.so.6 -> /lib64/libc-2.12.so with $ sudo rm libc.so.6 Then I can not use anything including ls command. The error appears for any command I type ...
1
vote
1answer
4k views

What does glibc detected …httpd: double free or corruption mean?

I have an EC2 server running that I use to process image uploads. i have a flash swf that handles uploading to the server from my local disk - while uploading about 130 images (a total of about 650MB) ...
1
vote
1answer
1k views

`GLIBC_2.7' not found

I have fpcalc installed on Linux and when I execute the following command: ./fpcalc I get an error saying: ./fpcalc: /lib/libc.so.6: version `GLIBC_2.7' not found (required by ./fpcalc) I ...
1
vote
2answers
2k views

What's wrong with this installation of Net::SSH2 Perl module?

I am trying to install Net:SSH2 Perl module, but I run in this error: [root@script-server fmzbih_cms_weather_updater]# cpanm Net::SSH2 --> Working on Net::SSH2 Fetching ...
1
vote
1answer
292 views

Built local glibc, broke system, how do I ssh without parsing the .bashrc?

The cluster I am on had really old build tools and I needed to use CUDA5. I'm a pretty clever dude and I planned on building the necissary tools. So, I built a local copy of gcc, bintools, and ...
1
vote
1answer
2k views

Newer GLIBC for RHEL/CentOS 5.x

I have a situation where a group of developers is attempting to deploy a binary application to a series of RHEL 5.5 and CentOS 5.5 servers. Unfortunately, the application was developed on another ...
1
vote
1answer
2k views

glibc.i686 conflicts with libc6?

I have a 64-bit Redhat Enterprise Linux server (version 6.3) that doesn't want to let me install the glibc.i686 module for 32-bit compatibility. When I try yum install glibc.i686 as root, it gives me ...
1
vote
1answer
600 views

yum update glibc dependency error on SL 6.1

On SL6.1 I am trying to yum update glibc and it's failing I think with a conflict of sources, but I'm not too sure. I don't really know how to parse the yum error, but here it is: # yum update glibc ...
1
vote
1answer
724 views

PhantomJS on CentOS 5.5 (glibc and libstdc++ versions)

I'm trying to run PhantomJS on CentOS, but I get the following: ./phantomjs: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./phantomjs) ./phantomjs: ...
0
votes
2answers
633 views

Yum Update Failing mod_ssl and glibc_devel

Any ideas on how to get this to not fail? # yum update Freeing read locks for locker 0x82: 4189/140342084876032 Freeing read locks for locker 0x84: 4189/140342084876032 Freeing read locks for locker ...
0
votes
1answer
45 views

RPM command hangs

in CentOs 5 rpm command stucks in my linux machine... [root@manage glib]# rpm -i libgcc-4.1.1-52.el5.i386.rpm [root@manage glib]# ps -efww | grep libgcc root 2020 32168 0 13:50 pts/0 ...
0
votes
1answer
562 views

Cannot install PEAR on Centos 6.5 and PHP 5.5

This is driving me nuts already and there's no information about this whatsoever in Google, only 2006 posts, but they don't really help me. I have CentOS 6.5 freshly updated, PHP 5.5, MySQL, Apache, ...
0
votes
1answer
445 views

Install Glibc2 using Yum

I'm trying to install glibc2 version 2.11 that's needed for openoffice 3.4 https://issues.apache.org/ooo/show_bug.cgi?id=119393 but i can't seem to find the dependency with yum. I already have the ...
0
votes
1answer
526 views

What depends on glibc.i686 — yum

yum is skipping certain packages because of glibc.i686. What I want to know is what is using glibc.i686 ( which I guess is the source of the failure ) ? sudo yum -y update --skip-broken [sudo] ...
0
votes
1answer
962 views

glibc detected *** /usr/sbin/httpd: free(): invalid pointer

One of my websites gives a lot of internal server errors. When I restart httpd they are gone for a while. But after some time they come back. And once or twice they have frozen the whole server/VPS. ...
0
votes
0answers
210 views

Apache2 PHP5 reports glibc detected corrupted double-linked list

recently I began to notice the following error message in the apache error log. I'm running Apache 2.2.22 with PHP 5.4.4 on Debian 7.4. All installed from stable packages. The error occurs randomly, ...
0
votes
0answers
56 views

btsync throws file not found. missing libraries?

I tried this guide here http://nickology.com/2013/05/06/bitorrent/ when I get to the end of step two, where it says to run ./btsync, this is what I get. btsync-backup@server523:~$ ./btsync -bash: ...
0
votes
1answer
73 views

glibc conundrum - how to undo partial upgrade?

My coworker was doing what should've been a straight-forward install of memcached this weekend on our Ubuntu 10.04.04 LTS server, but something went awry. I'm still trying to figure out the details, ...
0
votes
0answers
270 views

Install libxml2.8 on RHEL 6

I want to install the software TinyOWS on a RHEL 6 server. I followed the instructions: $ wget http://download.osgeo.org/mapserver/tinyows-1.1.0.tar.bz2 $ tar xvjf tinyows-1.1.0.tar.bz2 $ cd ...
0
votes
1answer
64 views

installing Abbyy ocr server on Amazon — incompatible GLIBC

I'm trying to run ABBYY server (version 10) in Amazon EC2 instance. At home, I realized that Abbyy requires a different (lower) GLIBC version than the one that comes with Ubuntu 12.04. It installed ...
0
votes
1answer
272 views

Segmentation fault while running Java with old GLIBC

I am trying to run Java 1.7.0_21-b11 with GLIBC 2.3.6. Java 7 requires at least GLIBC 2.4. I've tried this solution, so using ldd, I've found the following dependencies: ld-2.7.so ld-linux.so.2 ...
0
votes
1answer
547 views

can not install glibc-devel 'Requires: libnss_files.so.2' error

I'm using Linux 6.1 I need to install glibc-devel but it fails with this error. [root@server1 Packages]# yum install glibc-devel-2.12-1.25.el6.i686.rpm Loaded plugins: refresh-packagekit Setting up ...
0
votes
1answer
286 views

Glibc importance of error

I am following LFS 6.7, and I reached the point where I compile glibc-2.12.1 . I mounted the LFS partition with the atime option: here is a confirm on that I think: /dev/sdb1 on /mnt /lfs type ext4 ...
0
votes
1answer
378 views

How do I upgrade ubuntu eglibc from 2.11 to 2.12?

I m currently on Ubuntu 10.04 $ uname -a Linux dpn2 2.6.32-27-server #49-Ubuntu SMP Thu Dec 2 02:05:21 UTC 2010 x86_64 GNU/Linux $ ldd --version $ lsb_release -a No LSB modules are available. ...
0
votes
1answer
288 views

easiest way to upgrade to glib-2.14+ on rhel5?

my Yum repository doesn't have anything newer than glib-2.0. But glib is a fairly core animation library, is my understanding. Is there an easy way to upgrade that won't brick my system?
-1
votes
1answer
191 views

Apache errors - *** glibc detected *** Backtrace - perl

I have been getting these errors in my apache logs on my server - it only happened once a day or every two days. Any idea what could be causing this? I dont even have an idea of where to start? *** ...
-1
votes
1answer
235 views

Linux/glibc queries localhost for DNS even if no resolver is configured

Basically, with an empty resolv.conf (and no weird stuff configured like resolvconf, nscd...nothing at all, just a plain squeeze install), I see DNS queries to 127.0.0.1 port 53 when trying to resolve ...
-1
votes
1answer
288 views

Centos 5.9 glibc > 2.10 [duplicate]

so I have a little problem. I have a piece of software that requires glibc (libstdc++.i686 is that needs glibc) (32 bit version) that is >= 2.10.90-7. The problem is, CentOS 5.9 only has glibc 2.5 or ...
-1
votes
3answers
406 views

yum won't update my glibc packages

Is there any way to fix corrupted "yum"? This is what I got myself into by accidentally pressing ctrl+c while doing sudo yum update on an amazon linux EC2 instance $ sudo yum update Loaded plugins: ...
-1
votes
3answers
3k views

needs updated glibc package version 3.4.15 or later for RHEL6

I want to upgrade my current running applications to latest version. But due to some package issue i am unable to install them. I get common error in that: /usr/lib64/libstdc++.so.6: version ...