The tag has no usage guidance.

learn more… | top users | synonyms

0
votes
0answers
44 views

Apache / GnuTLS error connecting from Apache-Host

We got an Apache webserver which is configured to use SNI with GnuTLS. Everything works and the server delivers the correct cert to clients. Except for when connecting directly from the Apache-host. ...
5
votes
3answers
315 views

Configure exim4 to use Microsoft Exchange as smarthost

My company has set recently set up an Active Directory driven Microsoft Exchange environment to consolidate outgoing mails. We do have a set of staging servers which should now use our MSEXCHG as ...
-2
votes
1answer
148 views

Apache fails to start, ssl issue

For some reason Apache does not start. I tried rebooting the server but to no avail. It's about 2am and my brain is fried. Here is the apache log. I did not touch any configs, certs, or keys to cause ...
1
vote
1answer
123 views

exim4 gnu_tls cipher configuration for incoming connections to gmail

On the Debian 7 / exim4 / gnutls mailserver I'm running, since about 1-2 weeks, mails from gmail don't arrive any more with the following typical error message in the log file: 2015-02-14 17:32:07 ...
1
vote
1answer
85 views

gnutls-cli hangs when testing an ssl connection

I'm running the command gnutls-cli -s facebook.com -p 443 --x509cafile /etc/ssl/certs/ca-certificates.crt -d 999 and the output is |<2>| p11: loaded provider 'p11-kit-trust' |<2>| p11: ...
1
vote
1answer
347 views

Is it possible to configure ECDHE-ECDSA with mod_gnutls and Apache 2?

I'm trying to configure my Debian box with mod_gnutls implementation (for sake of SNI), to achieve best possible results in TLSv1.0/1.1/1.2 (disregarding both SSL2 and SSL3) However it seems to me, ...
0
votes
1answer
147 views

Exim says “The request is invalid” during gnutls_handshake

I have Debian wheezy and setup Exim to listen to port 587, where users can authenticate using TLS. I'm testing it with Thunderbird 31.1.2. When I try to send a message, Thunderbird displays this: ...
0
votes
3answers
1k views

Exim after Thunderbird update: “Could not negotiate a supported cipher suite” [closed]

Recently, after I installed updates on my Kubuntu 14.04. system and a new version of thunderbird was installed, I could not send emails any more. It prompts: Sending of message failed. The message ...
0
votes
1answer
2k views

Apache/GnuTLS: can't get multiple TLS-enabled virtual hosts to work

A while ago, I set up an SSL certificate authority for our intranet, generated a bunch of certificates and ran a number of sites with them, all on the same physical host with one single Apache2 ...
1
vote
0answers
127 views

apache/mod_gnutls ssl certificate based authentication

I'm using apache with gnutls. I've configured both to request authentication from the client. When providing the certificate it works. But it works also if I provide another that the correct ...
-2
votes
1answer
984 views

Why openssl s_client and gnutls-cli deliver different certificates (own server)

on my server i have multiple virtual hosts with apache2. Some with domain *.example-one.org and some whith *.example-two.org. Each domain has it's own wildcard certificate. When I fetch the ...
1
vote
2answers
1k views

How do I force my Debian system to update GnuTLS?

After the news broke that GnuTLS is broken hacker news | arstechnica I would like to know how to find out if my system(s) Debian 7.1 Stable & Debian 7.1 Testing are safe and more specifically ...
3
votes
1answer
465 views

GNUTLSClientVerify does not block unrecognized CAs

I have installed Apache on Ubuntu, installed GNUTLS module and everything worked fine: root@ilnwad15:~# apache2 -v Server version: Apache/2.2.22 (Ubuntu) Server built: Jul 12 2013 13:37:15 Now, I ...
3
votes
2answers
2k views

exim4 is showing a TLS error on connection… (gnutls_handshake)

My exim server is showing the following error: TLS error on connection from xxxx.xxxx.xxxx. ([127.0.0.1]) [xxx.xxx.xxx.xxx] (gnutls_handshake): A TLS fatal alert has been received. I'm using the ...
0
votes
1answer
1k views

gnutls vs openssl with openldap, debian and centos

I have a Debian 6.0.5 server running openldap. It appears to be compiled against gnutls. I used gnutls' certtool to generate a self-signed certificate and I have used it on a few debian client ...
2
votes
2answers
563 views

FTPS using Vsftp woes

I have some problems with Vstpd, and I don't know whether they are related or not. One problem is that FireFTP can't get past the directory listing phase - it just stucks there forever, no error ...
1
vote
2answers
927 views

Windows client can't connect to vsftpd server

I've a problem about vsftpd server. I've created an vsftpd server with implicit ssl. It works perfectly with filezilla client on ubuntu 10.04, but when I run with filezilla client on windows, it got ...
0
votes
1answer
372 views

Can't find gnutls ibrary when executing rpmbuild under non-root

I am trying to build ntgs from the latest source, using the .spec from rpmforge - as non-root via rpmbuild. During the compile, it fails at this step: checking for GNUTLS... no configure: error: ...
4
votes
4answers
7k views

How to change libcurl SSL backend from gnutls to openssl on Ubuntu server

I am getting gnutls specific errors in my Tornado webserver while processing Google OpenID SSL responses. One of the suggestions I got from Tornado mailing list is to try OpenSSL backend instead of ...
1
vote
1answer
186 views

FTPS failing on LIST command with error;

The machine in question is running CentOS 5.7 and vsftpd-2.0.5-21.el5.x86_64. My client can connect to the server and interact with it normally over standard FTP. It can also connect via FTPS and ...
0
votes
1answer
710 views

Ubuntu server 10.10 OpenLDAP 2.4.23 gnutls 2.8.6 keep getting “TLS init def ctx failed: -1”

So I've read about the Debian/Ubuntu distros migrated to gnutls implementation for TLS/SSL. Fine with me, but I've spent the last week trying to configure OpanLDAP with TLS/SSL without success, keep ...
1
vote
1answer
2k views

How to configure Apache with gnutls [closed]

I'm wanting SNI on my CentOS 5.5 dev server and since it looks like I'm out of luck with the current repo versions of openssl and apache, before I go compiling custom RPMs I thought I'd see if I could ...