2
votes
2answers
305 views

Installing PHP Imagick with libmagickcore4

I have ImageMagick (version 6.6.9-7) on Ubuntu 12.04, which has libmagickcore4. When I tried to install PHP imagick, I received the following error: The following packages have unmet dependencies: ...
1
vote
1answer
102 views

Maxed out directories in public folder for rails. What can I do?

We have a rails app that dynamically generates thumbnails on request and saves the result locally to make it faster to serve up the same one again. We use the following url structure: ...
1
vote
1answer
908 views

Cannot require 'rmagick' despite normal installation on Ubuntu (LoadError: no such file to load — rmagick)

I have installed all the dev files (sudo apt-get install libmagick++-dev libmagickcore-dev libmagickwand-dev) as well as the gem itself (gem install rmagick), and everything installed just fine, no ...
0
votes
1answer
2k views

Unable to open display “:0” on ubuntu 11.04 (with unity)

I'm connecting to a ubuntu 11.04 through ssh, and I'm trying to run this command(is a Image Magick command): *This command saves any visible window on an X server and outputs it as an image file. ...
3
votes
1answer
3k views

Install imagemagick with jpeg support from ubuntu packages

I installed libjpeg62 and imagemagick on my ubuntu 10.04 (lucid). Running identify command with a gif works but running it with a jpeg produces this error: identify: no decode delegate for this ...
2
votes
1answer
997 views

Install ImageMagick with liquid-rescale support

I have installed ImageMagick 6.5.8 from source on Ubuntu 8.10 followed by the instructions listed here > tar xvfz ImageMagick.tar.gz > cd ImageMagick-6.5.8 > ./configure > make > sudo ...
1
vote
1answer
2k views

Imagemagick fails to compile with --disable-openmp

I am trying to install the imagick extension for PHP, but PHP is unable to load it. I believe the reason is due to a bug in gcc 4.2 as described here. It looks like you can get round this bug by ...
8
votes
2answers
11k views

Installing imagick PHP extension on Ubuntu

I'm trying to install the imagick pecl extension on my Ubuntu server and am getting the below error. I've installed the ImageMagick rpm using aptitude already and the pecl extension is version 2.3.0. ...