0
votes
1answer
227 views

Configuring OpenLDAP init script on CentOS 6.4

If I just run slapd with no arguments (as root) it starts and works fine. When I try to start it using /etc/init.d/slapd start however, it dies immediately. I see from looking at the init script that ...
1
vote
1answer
243 views

Thin processes not starting after reboot on Ubuntu 12.04

Well, I'm running Ubuntu 12.04.2 and I have Thin installed by gem install thin sudo thin install sudo /usr/sbin/update-rc.d -f thin defaults and I have my configs at /etc/thin. But after system ...
2
votes
1answer
267 views

Starting a service only after another one is completely started (on CentOS)

I have installed on my CentOS server postgresql service and another one called netnfork. The 'netnfork' service starts only after postgresql starts. netnfork init script: #!/bin/sh # # netnfork init ...
1
vote
0answers
122 views

Thin configuration doesn't start on boot, but they do on manual start [closed]

I have some thin config files (generated with sudo thin install) which are slightly modified (only paths where they're located). I can start them just fine with /etc/init.d/thin start, but if the ...
0
votes
2answers
517 views

Chroot on startup

I have a script that runs on startup, but it wont launch a application in chroot. #!/bin/sh /usr/sbin/chroot /root/chrootdir/ /bin/sh -c "lighttpd -f /etc/lighttpd.conf -m /lib" echo "script ...
-2
votes
3answers
786 views

Can't create a working init.d for Apache 2.4.2 on CentOS

I built apache 2.4.2 on CentOS from source and now am trying to create an init.d script to go along with it. A friend gave me one script but it never outputted a success or fail and I disliked it. I ...