The tag has no usage guidance.

learn more… | top users | synonyms

-1
votes
3answers
7k views

iostat shows 100% utilization - what can be done to improve performance?

I have dedicated web server with CentOS. Recently, I get very high server load, probably caused due to IO bottleneck. iostat -mx 3 shows: avg-cpu: %user %nice %system %iowait %steal %idle ...
0
votes
1answer
929 views

Get I/O TPS for NFS on Solaris machines

I'm attempting to get IOPS for my Solaris servers. Typically I use tps for this calculation, however: iostat gives TPS but only for local disks. iostat -x gives everything but TPS for ALL disks. sar -...
0
votes
1answer
541 views

High cancelled_write_bytes, high IO load, concurrent memory-mapping

I have a software for persisting/retrieving data from files (a bit like database, but it's not exactly a database engine). It's not open source and the documentation is sparse, therefore I don't have ...
0
votes
1answer
113 views

how can I tell if there is a cpu trashing on my linux machine

I want to write a script that will kill my processes when my machine is doing "too much" swapping of process memory from disk to memory. What is the best way to determine that? I saw top has %wa and ...
0
votes
1answer
806 views

SNMP monitoring of iostat on a Solaris 10 server?

I'm looking at the System Management Agent resources which gives guidance to the Solaris SNMP tools however after extensive googling I can't find any OID reference list or details on what can be ...
1
vote
0answers
124 views

Why are /proc/diskstats figures suddenly unbelievably low?

I have a Debian jessie server with two Intel DC S3610 SSDs in it, in RAID-10. It's reasonably busy for IO and for the last several weeks I've been graphing the IOPS: As you can see, most of the ...
1
vote
0answers
470 views

MySql/RedHat, High I/O Wait … for a few hours… then disappears

I've got a RH server as a VMWare instance logging GPS fixes 24x7. The transaction volume hasn't changed over the months (in fact I am pruning the transaction table more aggressively now) with only ...
0
votes
0answers
16 views

No Partition statistics with iostat on NVMe devices with Linux

I have Linux servers with Kernel 3.16.0-73-generic #95~14.04.1-Ubuntu SMP x86_64 on a Dell Server with Ubuntu. Those servers have multiple SAS disks (with and without RAID on the PERC controller) as ...
0
votes
0answers
14 views

No w/s in iostat output even though wMB/s is high

I am trying to format a 2 TB SAN based block device (/dev/mapper/mpathb). Even though, mke2fs has been running since over one hour without completing, iostat -z -x -m 10 output in a separate terminal ...
0
votes
0answers
40 views

iostat -En command keep showing a removed disk

I have replaced a disk on a Solaris server (probably wrongly), which have an j4400 array connected. I unplug the disk and put a new one without unconfiguring, disconnecting etc the old one. The ...
0
votes
0answers
70 views

Strange load average behaviour

We have a daemon which collects system data and writes it into database. Sometimes the load average goes very high without apparent reason. Here is sample output. | id | server_id | datetime ...