0
votes
0answers
13 views

Adding nic to virtual machine via kvm not showing up inside machine

I'm trying to add a new nic (eth1) to a virtual machine that I have set up using virt-manager. I can use Virt-manager to add the hardware but when the machine is booted no new cards show up. What have ...
0
votes
0answers
21 views

KVM virtual IP address not working on HOST, works on GUEST

I have a setup composed of the following: -> A HOST running KVM with the following network configs: # The loopback network interface auto lo iface lo inet loopback # The primary network interface ...
0
votes
1answer
35 views

Restarting the networking on the HOST makes GUEST lose connection

I am probably missing something but have a KVM virtualized HOST/GUEST setup. The GUEST is using a bridge (br0) on the HOST for internet connectivity. When I make a "/etc/init.d/networking stop ; ...
1
vote
2answers
87 views

How to setup IPTables on KVM host - iptables-persistent is being ignored

I'm trying to setup some specific IPTables rules on an ubuntu 14.04.1 host that runs some KVM guests. The box has multiple NICs with multiple IP addresses and the guests use different addresses based ...
2
votes
1answer
236 views

Poor network performance with KVM (virtio drivers) - Update: with vhost_net

I've set up several KVM based networks before, and never encountered this issue, can't for the life of me think what I'd have set up differently previously. Setup Basically, Ive got and entirely ...
0
votes
0answers
105 views

CentOS Host KVM Virtual Machine running a Windows VM - No internet access

I've installed a KVM virtual machine on a CentOS host using libvirt. I've also set up a bridged connection from the interface en0:4 running on IP x.x.x.15 to br0. (The IP is a public one). Running ...
1
vote
0answers
499 views

Ubuntu 14.04 KVM Host - Only network device pcnet working

I've installed a KVM host on Ubuntu 14.04. I've added a networking bridge as br0 and also added the p4p1 network adapter to it. My problem is now that only the "pcnet" networking guest driver is ...
3
votes
2answers
103 views

same subnet,different VLAN in Virtual machine

I have 2 VLAN,VLAN 100 and 101 but only one subnet i am trying to make this work with virtual machine so that VM will have two IP address in same subnet but will actually be in two VLAN. steps ...
0
votes
0answers
32 views

KVM Networking guest issue due a provider networking limit

I have a KVM setup on Centos 6.4 64 Bits. My server provider assign us a Main IP to the Host with a gateway and netmask. Also our provider assign us additionals IP ( not in the same block as the Main ...
0
votes
1answer
53 views

openvswitch with multiple vlans

I'm having an issue wrapping my head around a setup. We currently use vmware+vsphere and switching to kvm. So we want the similar type setup using openvswitch. So our setup will be like kvm host ...
0
votes
0answers
71 views

KVM : domain names are resolved, but cannot ping

I've found that in KVM, my networking is acting funny. Oddly (1) I can resolve external internet locations using nslookup or ping , but I cannot actually receive a ping back. (2) I cannot ping ...
0
votes
1answer
49 views

KVM Dynamic Rate Limiting

How can I dynamically rate limit the network speed on individual KVM instances? For example, I want to set a rule where if a user uses over 100mbps inbound or outbound bandwidth for over 30 minutes, ...
0
votes
0answers
191 views

CentOS 6 KVM Host cannot connect to Internet while VMs can

I've configured a CentOS 6.4 server as a KVM host running multiple VMs. VMs running on this KVM host are fine. The problem is: the host itself cannot connect to the Internet. External addresses ...
0
votes
0answers
39 views

kvm guest cannot initialize network

I'm running a kvm ubuntu guest inside ubuntu both 12.04. Using KVM manager for this. Initially everything was fine, could connect from the guest to the internet, the host all right. But all of a ...
1
vote
1answer
101 views

Bridging is breaking the server: KVM configuration

I'm pretty new to networking and just can't get my head around this. I'm trying to setup KVM-Qemu so I can run some virtual machines. The instructions I'm following are telling me to use eth0 and ...
1
vote
2answers
218 views

How do I configure bridged networking for VMs

I'm setting up a KVM virtualization server in CentOS 6. How do I configure bridged networking? (I think I need network interface eth0 to be accessible to VMs) I have tried to follow this guide: How ...
1
vote
1answer
68 views

Linux kvm: Public bridge without the physical nic

I have a VM host on the internet with my own subnet. I intended to use bridged networking and simply add my one physical NIC to the bridge and be done. But that had several downsides, not the least of ...
1
vote
2answers
412 views

KVM: All network traffic to one guest (firewall)

I am currently using a VMWare ESXi 5.5 server for my virtualisation. The network setup is like this: PFSense firewall is the center of it all and connected to: LAN Network (physical NIC 1 assigned by ...
0
votes
0answers
137 views

Access KVM guest via hostname on private virtual network

KVM on CentOS 6.5. Setup one bridge connected to internet. And one virtual network on subnet 192.168.100.0/24 DHCP start: 192.168.100.128 DHCP end: 192.168.100.254 How to ...
2
votes
1answer
350 views

Ubuntu/KVM Bridge Interface IP Assignment

I have a Ubuntu 12.04 LTS machine running KVM/libvirt. It has two physical ethernet interfaces. I have dedicated eth0 as the primary interface and configured bridging on eth1 for my VMs. The KVM host ...
3
votes
1answer
224 views

Private network between two KVM VMs

I'm trying to connect two KVM hosts together with a transparent ethernet link. I'm using Proxmox VE as the host and have configured 2 KVM VEs with ethernet interfaces and joined them to a single ...
0
votes
2answers
118 views

KVM Network configuration + VLAN trunck

I am trying to set up a KVM Based solution, I am having trouble configuring the NICs for the VMs from a bridge based on a VLAN interface. My config below : ETH0 : KVM Host Management : ...
0
votes
1answer
116 views

Networking issues KVM

I have a server that is running Debian 7.2. I recently set up KVM on it, and created two VMs. Both VMs are unable to connect to the Internet. I was following a tutorial, and I'm certain I followed the ...
0
votes
2answers
45 views

My KVM machine can't get the network

I'm setting up a virtualization server for my company based on Fedora 19 and KVM. Our goal is to being able to convert and run a bunch of VirtualBox VMs. So I setup my F19 server, and created a br0 ...
1
vote
1answer
846 views

Assign ipv6 address to KVM guests on bridge mode

System: CentOS 6.5 Network: Bridge on br0 IPv6: ISP Native /64 block. IPv4: ISP address (not internal LAN) Purpose: To assign IPv6 only to guests (manually), I don't want ipv4 address to be ...
0
votes
1answer
606 views

how to connect multiple kvm/qemu VM guests in to a subnet [closed]

I want to setup a simple subnetwork of KVM/QEMU guest VMs living on a single host (Fedora 19) for testing purposes. The subnet would contain 3 servers: 1 Debian 6.x eth0 ip: 10.0.0.7 eth1 ...
1
vote
1answer
186 views

Access web server on VM from a machine in a different subnet

I cannot access to a web application running on a virtual machine hosted by KVM from a machine in a different subnet. So, I would like to access from the machine 192.168.1.2 (top right in green ...
1
vote
1answer
193 views

kvm guest can not connect to outside of host, vice versa

I have a vmware vm running ubuntu 12.04 server(name=vmhost), with network bridged and full access to the internet. This vmhost is using the kvm hypervisor and is running a vm(centOS 6.4),network ...
0
votes
0answers
111 views

Problems using wondershaper on KVM guest

I am trying to limit bandwidth on one of my KVM guest using Wondershaper. Doing something like this works fine: wondershaper br23 9000 9000 Doing a wget with the setting above gives a download ...
0
votes
1answer
97 views

Unbridged tap device

Good UTC evening! I've created a tap0 device on my host, it looks like: tap0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500 inet 10.0.0.1 netmask 255.255.255.0 broadcast 10.0.0.255 ...
0
votes
0answers
166 views

KVM - 2 external IPs - NAT - forwarding multiple ports to multiple VMs

I have a server with one network device and two external IP addresses. This server is running Debian 7. On this server I want to run two or three virtual machines using kvm/qemu. I want to use both ...
0
votes
1answer
956 views

Configure DHCPD with assigned IP address and gateway on different subnets for KVM [closed]

I have a dedi with an IP range of 123.123.123.1/24, the problem is the gateway address: 111.111.111.254 and it's on completely different subnet. I have already setup a bridge and KVM virtualization. ...
1
vote
1answer
279 views

KVM bridge network initial setup - 2 public IPs

I have actually two problems with my server. The setup is like this: server in a data center connected directly to the internet one network card / two public IPs (one IP the server gets over DHCP, ...
0
votes
0answers
124 views

KVM guest network breaks under load

We've been experiencing network problems in our KVM guests for a long time now, and I can't figure out what the problem is. We have multiple servers hosted at Hetzner in germany, these machines are ...
0
votes
1answer
95 views

Ubuntu 12.04: KVM and assigning public IPs to VMs

I'm setting up an environment where I have a VM host running behind a NAT firewall and plan to install VMs with public IPs so that they can be directly accessed over the internet like in the following ...
4
votes
1answer
354 views

New KVM guests cannot access outside LAN

I have a KVM host (at 192.168.0.10) that currently has one working KVM guest (at 192.168.0.12). On attempting to install a new KVM guest today, I reached a problem where the network on the new guest ...
0
votes
0answers
46 views

Trying to communicate between virtual servers on the same host through ipv6

I am running KVM on a host with 2 virtual servers. Each virtual server has a own bridge interface on the host VPS1 has br1 VPS2 has br2 Each virtual server has a own ipv4 and a ipv6. The virtual ...
0
votes
2answers
367 views

Why VM cannot get the public IP I have from provider?

I have a KVM-Host (on Debian) with root@kvm-host:/# cat /etc/network/interfaces auto eth0 iface eth0 inet manual auto vmbr0 iface vmbr0 inet static address 176.x.y.133 netmask 255.255.255.224 ...
2
votes
1answer
680 views

Why are eth0 and vmbr0 (bridge) having the same MAC addresses?

I configured my Debian (with KVM on board) as following: /etc/network/interfaces: auto lo iface lo inet loopback auto eth0 iface eth0 inet manual auto vmbr0 iface vmbr0 inet static address ...
0
votes
1answer
318 views

How to configure a network on KVM using only public IPs?

I have a KVM server and two VMs. I have one main IP and two additional "single" IPs (not a subnet). I don't want have a local network with private addresses on my KVM, but I want to assign my public ...
0
votes
1answer
125 views

What is th tap100i0 device on my debian with KVM?

I want configure a network for virtual machines on KVM. I created a bridge. But I found a new tap100i0 devise was created. Should I take it into account to get the virtual network running?
0
votes
1answer
213 views

What are the differences in the configuration of the network on Proxmox (KVM)?

I have a dedicated server, one main public IP from /27 and two single public IPs also from the same /27 (I think the provider manages single IPs using the VLAN tags). I want to have a KVM running on ...
0
votes
1answer
125 views

Slow network interaction between 2 kvm host machines

We have 2 physical machines, Host1 is a CentOS 6.4 kvm host and hosts ~7 kvm VMs all running Ubuntu 12.04 - all of this runs perfectly. Recently we've added a 2nd host system, host2, again a CentOS ...
0
votes
1answer
126 views

KVM firewall to disallow internet access for group of guests

I've got a KVM server inside a local network (192.168.10.0/24). This server has three interfaces, which are all publicly bridged [1]. Atm I'm only using two of the three interfaces, so the virtual ...
0
votes
0answers
233 views

kvm guest having temporary network drops

I have a Scientific Linux 6.3 KVM host running 2 nearly identical Ubuntu 11.04 guests. I built 1 base image and then cloned. Each vm has mysql and different RoR app installed on apache, using nginx as ...
1
vote
1answer
566 views

Kvm Guest Network Unreachable

I have a kvm setup with several guest vms running ubuntu. For some reason I cannot get traffic through port 80 from the guests to the outside anylonger. The other way round works just fine, the ...
1
vote
2answers
98 views

KVM guest has wrong outgoing IP address

I'm having the same problem that's described in the following question here, however no clear answer was given. KVM guest has a wrong outgoing ip address My KVM host has an IP address of ...
0
votes
1answer
227 views

UBuntu 13.04 Server with a Windows 2008 VM

I have a ubuntu 13.04 server. On it I have a virtual machine (kvm), with Windows 2008 on it. I have configured /etc/network/interfaces to have a bridged connection to the machine, so I am able to ...
0
votes
1answer
52 views

Pings are dropped when pinging a specific KVM guest

I had a seriously latency when using SSH to Server1 and noticed when I ping Server1 that a lot of packets are dropped. When I go to Server1 and enter ifconfig I do not see any errors or dropped ...
0
votes
1answer
165 views

Debian Squeeze KVM - No Matter How I Setup Bridge, No Connectivity on Guest

I'm attempting to setup libvirt KVM guests on my server, and I've been messing around for two days now trying to get the guest networking working. So far, I haven't gotten anywhere. My network is ...