KVM (for Kernel-based Virtual Machine) is a full virtualization solution for Linux on x86 hardware containing virtualization extensions (Intel VT or AMD-V). It consists of a loadable kernel module, kvm.ko, that provides the core virtualization infrastructure and a processor specific module, ...

learn more… | top users | synonyms (3)

0
votes
0answers
112 views

Use host's VGA output from virtual machine

Is there a way to stop a host OS from using its VGA port (on the motherboard) and allow a VM to use it instead with KVM-QEMU? I have read about VGA pass-through, but all the discussion I've found on ...
0
votes
0answers
69 views

enable ssh over virtual machines running on kvm

I am trying to connect to a virtual machine running on KVM hypervisor from a host machine (Ubuntu 14.04) through ssh, but it is giving me the following error: ssh: connect to host 10.117.82.2 port ...
0
votes
0answers
103 views

kvm network bridge on centos 6

I have a Centos 6 KVM host. I installed the KVM following this manual: https://wiki.centos.org/HowTos/KVM Its network has been configured as a bridge: [root@server ~]# ifconfig br0 Link ...
0
votes
0answers
11 views

KVM Error While Deploying Existing Image

I have KVM running with 2 VM's. I tried backing up one of the images by copying it and then deploying using virtual machine manager using that existing image, that fired up fine. Now the second backup ...
0
votes
0answers
264 views

How to use vhost-scsi with Intel P3700 NVME SSD in KVM

I am using proxmox beta 4 in my HP DL 380 server with KVM. I configured Intel P3700 NVME - nvme0n1 as Virtio and on windows server 2008 r2 with virtio-scsi driver. I am getting 100 K random IOPS ...
0
votes
0answers
155 views

Host cpu association with numa node not reflected in guest

In host NUMA node 0 has cpus 0-7 and 16-23 NUMA node 1 has cpus 8-15 and 24-31 But in guest NUMA node 0 has cpus 0-7 and 16-31 NUMA node 1 has cpus 8-15 only My Question is why NUMA node cpu ...
0
votes
0answers
360 views

virsh shutdown not working on linux guest

Solution to this issue is usually installing acpi on the guest vm and making sure the vm has the following: <features> <acpi/> <apic/> <pae/> </features> I have that, ...
0
votes
0answers
28 views

No package transfer from host to guest on KVM

I want to assign external static IPs to my KVM guests. I do not prefer a NAT solution. What should be the configuration of network and routing tables? I manually assing a static IP to guest. I can ...
0
votes
0answers
241 views

Is it possible to passthrough a USB-hub and its devices to a libvirt guest?

Since I am having multiple devices in a libvirt/qemu Windows 8.1 guest I need to plug in and out rather often, I am wondering if it is possible to make life a bit easier. Is it possible to pass ...
0
votes
0answers
32 views

KVM Virtual Machines and Public IPs

I currently have some Virtual Machines on my business dedicated server using the KVM layer as apposed to Xen or other virtualization methods. I was wondering if I could get a "best practice" on ...
0
votes
0answers
147 views

Two NICs for one KVM guest

I deleted an old KVM guest and now have a spare IP address. I now assigned this (previously working!) IP address to another KVM guest, like so: virsh # attach-interface my-guest bridge br0 vnet1 ...
0
votes
0answers
39 views

How to prevent virt-viewer from asking a password

I am aware of what file I need to create, in order to prevent virt-manager from prompting me for a password. However, I'd like to create a shortcut on my desktop that opens directly the virtual image ...
0
votes
0answers
80 views

Monitoring / logging bandwidth usage per KVM on SmartOS?

Usually on a KVM node with CentOS, iptables support is enabled on the bridge (bridge-nf-call-iptables) iptables rules can be used to log the data, 2 chain rules one for incoming and one for outgoing ...
0
votes
0answers
47 views

OpenNebula host CPUs count altering

I am playing around with the latest OpenNebula sandbox for VirtualBox. In the "cloud" view, where users can create and delete their virtual machines, the CPU cores dedicated to each machine are ...
0
votes
0answers
250 views

Putty SSH connection timed out but OVH KVM ok

I dont know why today SSH give me an error but i can ping server and connect to SSH via OVH panel with KVM I reboot my server, load new config in putty, change try alive option to 200, change user ...
0
votes
0answers
24 views

Configuring additional static IP for Guest Machine

I am trying to bind my Guest machine to respond on my second public IP address. Sometimes it works automatically by DHCP just by configuring my MAC address, sometimes it doesn't work at all. All I ...
0
votes
0answers
101 views

Stucking qemu-kvm process

What i have: CentOS 7.1 as KVM host - Xeon E3-1200 v2, 32GB RAM, with and without dedicated raid controller (i tried both options) 3x Ubuntu 14.04.2 as quest VM (3 CPU, 512MB RAM on each VM) host ...
0
votes
0answers
70 views

Openstack Icehouse - Hypervisor (KVM) cpu_mode config

I have installed Openstack Icehouse, using the guide located here, and I am trying to find out what 'cpu' is exposed through the hypervisor to a VM. I have found this guide in order to configure the ...
0
votes
0answers
146 views

mdadm and LVM high load and IOwait

I've got a new CentOS 6.6 server with 2 HDD with mdadm & LVM. As I've used the CentOS install CD I assume everything should be aligned properly. I've just written a KVM image to a LVM LV using dd ...
0
votes
0answers
103 views

virsh console is “eating” keyboard input

A system upgrade messed up the sshd options in my virtual server (no matching cipher found), and while trying to get a serial console over virsh console, it seems to be "eating" or ignoring some key ...
0
votes
0answers
126 views

How use namespaces and fabric

I am using python and fabric, I have a hypervisor (KVM) defined as follows: env.hypervisor_address = 'hypervisor' # 192.168.0.250 From one VM (in the hypervisor) I want to SSH to other VMs with ...
0
votes
0answers
62 views

Linux router showing packet loss

I have two linux boxes that are using a third box as a router. Packets flow normally. BoxA(10.0.0.10) -> (10.0.0.20) RouterBox (172.16.50.20) -> BoxB(172.16.50.30) When I run mtr from BoxA to BoxB the ...
0
votes
0answers
452 views

can't create volume on disk-based libvirt storage pool

I followed Red Hat's doc (to the letter) on adding a disk-based storage pool for my libvirt/kvm server. Here's what I see: [root@kvm ~]# virsh pool-info guest_image_disk Name: ...
0
votes
0answers
146 views

KVM port-forwarding from ppp0 to VM's bridged NIC not working, but to VM's NAT NIC works?

I've spent a lot of time on this freaky problem, I've created a simple host and VM configuration to try isolate the problem. Terminology in this question Host: The bare metal server VM: The KVM ...
0
votes
0answers
858 views

Have GPU Passthrough working both Windows and Linux guests but libGL SDL error linux couldn't find matching glx visual NX x2go freenx

I have GPU Pass-through working with KVM qemu with both Windows 7 and CentOS guest but with Windows I can easily RDP with Remote Desktop mstsc and even run 3D accelerated apps that will make use of ...
0
votes
0answers
39 views

CentOS wrong outgoing IP address on forward

I have a rather strange behaviour for me in here. I am trying to forward traffic between two interfaces (one being a bridge) but will not work as intended. Here is the setup: Kvm host has br0 ...
0
votes
0answers
153 views

CSR1000v image in Openstack as a VM

I have an esxi host. Under that I have created a Ubuntu 14.04 machine running Openstack(devstack single node)Juno release. I am trying to spin CSR1000v image as a VM inside Openstack. I followed the ...
0
votes
0answers
742 views

Backup KVM running machine safely

I read some solutions to make backups of running VMs, but all take offline snapshots that seems difficult that will work if the VM has high I/O load. I have tested but i have doubts about the process ...
0
votes
0answers
125 views

netcat not listening on desired port

When I want to listen on desired port on one server, I use netcat ie: nc -l 8888 Then I can verify the server is actually listening on that port: netstat -tlnp | grep 8888 tcp 0 0 ...
0
votes
0answers
147 views

How do I configure KVM guest to have Internet access?

I am trying to get KVM working on my Debian server and I am having a slight problem with networking with my guest OS (also Debian). The virtual machine is using the "default" network (without a ...
0
votes
0answers
185 views

Packet loss between windows guest and Ubuntu 14.04 host

We are seeing packet loss between one of our Ubuntu 14.04 hosts and a KVM guest running Windows 2008 R2. The loss only shows up at high loads. Similarly loaded machines running 12.04 do not exhibit ...
0
votes
0answers
308 views

OpenStack Live-Migration VNC server error

Following these steps to do a live migration results in: 2014-12-08 00:42:38.772 17808 ERROR nova.virt.libvirt.driver [-] [instance: db9d53ac-4a75-4009-a67e-f45abf9d4d32] Live Migration failure: ...
0
votes
0answers
691 views

KVM does not boot with .iso disk images. Device or resource busy?

I've been trying to set up a windows VM on my Ubuntu box by following the linked blog post http://www.pugetsystems.com/labs/articles/Multiheaded-NVIDIA-Gaming-using-Ubuntu-14-04-KVM-585/ So I have ...
0
votes
0answers
81 views

simulate slow hdd in kvm

Can i simulate a slow hdd in a KVM guest? I need to test what happens with an app when it runs o a slow server (actually a server with the filesystem mounted over nfs). Related to this, I've found ...
0
votes
0answers
347 views

Convert KVM VM with multiple drives to Hyper-V (or somehow clone into a single drive system?)

I know this is going to sound weird. I have a VM running under KVM on Centos 6 that ran out of disk space, so 2 qcow2 drives were added, with one of them extending the vg_svn-lv_root LVM VG, and the ...
0
votes
0answers
966 views

Virtualization-(Cluster) with KVM/libvirt on top of a FC SAN

I'd like to set up a 2-node HA-Cluster based on Ubuntu and KVM running about 30 VM's. Both nodes are connected to a HP MSA(5TB) via Fibre Channel. Multipathing's already working and the nodes are able ...
0
votes
0answers
489 views

Adding nic to virtual machine via kvm not showing up inside machine

I'm trying to add a new nic (eth1) to a virtual machine that I have set up using virt-manager. I can use Virt-manager to add the hardware but when the machine is booted no new cards show up. What have ...
0
votes
0answers
146 views

Ubuntu KVM Guests going Read Only

I have three servers, all running KVM with 4-5 Ubuntu Server guests: generic PC, single SATA HDD, Ubuntu 14.04 PowerEdge 2950 8GB RAM, 2x SAS 10k in RAID1, Ubuntu 12.04 PowerEdge 2950 8GB RAM, 2x ...
0
votes
0answers
128 views

KVM virtual IP address not working on HOST, works on GUEST

I have a setup composed of the following: -> A HOST running KVM with the following network configs: # The loopback network interface auto lo iface lo inet loopback # The primary network interface ...
0
votes
0answers
56 views

KVM Image consumes more space on disk than what du shows

I have a kvm image which by looking at it with du -sh consumes 13GB (12980888) but in reality it consumes 42GB. Found that out the hard way when I scped it and after 18GB it was still copying ...
0
votes
0answers
585 views

KVM - Graphics card passthrough

I am trying to passthrough a graphics card to a KVM guest but have been unsuccessful. The graphics cards has been attached and it does appear that the guest is aware of the card, I can see the kernel ...
0
votes
0answers
371 views

Libvirt/KVM vm - No network connectivity

I have installed devstack (OpenStacks development platform) on a physical ubuntu 14.04 host and I have been trying to follow the tutorials for manually creating an image. I have tried for Ubuntu and ...
0
votes
0answers
319 views

CentOS Host KVM Virtual Machine running a Windows VM - No internet access

I've installed a KVM virtual machine on a CentOS host using libvirt. I've also set up a bridged connection from the interface en0:4 running on IP x.x.x.15 to br0. (The IP is a public one). Running ...
0
votes
0answers
3k views

Gnome Boxes on CentOS 7 with Windows 7 as a guest

I just installed CentOS 7 and tried to use Gnome Boxes to create some virtual machines. As long as I stick to other Linux distributions everything is fine. But I really do have trouble installing ...
0
votes
0answers
737 views

Open vSwitch double VLAN tagging is ignored

I'm trying to add a flow to a KVM machine using Open vSwitch 1.10.2 for it's networking, which double tag all traffic comming from one of the virtual machine's ports. I'm using the following command ...
0
votes
0answers
228 views

KVM : domain names are resolved, but cannot ping

I've found that in KVM, my networking is acting funny. Oddly (1) I can resolve external internet locations using nslookup or ping , but I cannot actually receive a ping back. (2) I cannot ping ...
0
votes
0answers
813 views

CentOS 6 KVM Host cannot connect to Internet while VMs can

I've configured a CentOS 6.4 server as a KVM host running multiple VMs. VMs running on this KVM host are fine. The problem is: the host itself cannot connect to the Internet. External addresses ...
0
votes
0answers
1k views

Apache bench failing with error “No route to host”

Got a new dedicated box. Installed CentOS 6.5 Installed KVM Installed a CentOS 6.5 guest rsync'd websites/database/settings etc over from existing VPS. Set up "dedi.mydomain.com" in DNS to test it ...
0
votes
0answers
3k views

“Network error: connection refused” when trying to SSH to guest VM

CentOS 6.5 host, CentOS 6.5 guest. Using kvm. VM gets a local IP from the virbr0 interface. I've set up some port forwarding in iptables. port 80 forward works, but my SSH forward does not. ...
0
votes
0answers
52 views

kvm guest cannot initialize network

I'm running a kvm ubuntu guest inside ubuntu both 12.04. Using KVM manager for this. Initially everything was fine, could connect from the guest to the internet, the host all right. But all of a ...