Acronym for a development stack originally made up of Linux, Apache, MySQL and Perl/PHP/Python

learn more… | top users | synonyms

0
votes
0answers
22 views

WordPress (or Apache) point to wrong IP (?)

I set up Apache and WordPress on Debian (LAMP stack) and everything was working fine (including /wp-admin/), but it could only be accessed from localhost or from within my own network. I fixed it (my ...
0
votes
1answer
41 views

What user should I use to create websites?

I setup a LAMP stack on a dedicated server. There is a root user and a user named user1 with sudo privileges. I usually put all my websites inside the /home/sites dir, and I don't know if it's better ...
0
votes
3answers
36 views

How to add IP to EC2 firewall

We run a number of different servers that are hosted in a local data centre however our Dev server is hosted on AWS and I'm having trouble accessing it. The EC2 server is running a LAMP stack, I can ...
1
vote
2answers
33 views

Windows firewall blocking inbound port 9000 (xdebug), even though inbound rule created

I have been trying to allow computer A (LAMP with xdebug configured) connect to computer B (Eclipse IDE with xdebug) via port 9000. Both are on running on my local network. I created an inbound rule ...
2
votes
1answer
588 views

Do I need to have port 80 configured in LAMP for an HTTPS website?

I have a LAMP webserver, and on it there is https://sslhosting.cz/ domain. First I attach a general Let's Encrypt config file, which I changed to my needs: /etc/letsencrypt/options-ssl-apache.conf ...
-1
votes
1answer
13 views

Connection reset when trying to access / with a FallbackResource rule

I am having an issue where my site is working as intended for all urls except the base url of example.com/. When I try to access that in particular I get a connection reset. I have reduced my site to ...
1
vote
1answer
20 views

OCSP Stapling on LAMP with Let's Encrypt

How do I verify if OCSP Stapling works correctly? Setup: LAMP with Let's Encrypt, test domain https://pavelstriz.cz/ High-Tech Bridge result says OCSP is enabled Is this enough for me to believe ...
-1
votes
1answer
97 views

Step by step configuration of Ubuntu server for LAMP with remote FTP/SSH and GIT access [closed]

This is the first time I had to configure an Unix Server as a remote server for a website based on LAMP. It also need to offer SFTP and GIT support. I read a lot of guides and I wrote down all the ...
0
votes
1answer
17 views

OpenVPN with LAMP on same VPS instance

I have a VPS where I configured LAMP to host a couple of websites. Would it be problematic to set an OpenVPN Access Server on this same server, alongside LAMP? If this is a good idea at all? What ...
2
votes
2answers
24 views

Need Help Upgrading LAMP (Centos) Server

I just took over the server admin duties for a CENTOS box (6.5-FINAL), and I need some direction, as I don't come from the LAMP side. The box is running: L: CentOS 6.5 FINAL A: 2.2.15 (Centos) M: ...
1
vote
0answers
68 views

Unable to login to MySQL on ownCloud using PHP - SQLSTATE[28000] [1045] Access Denied

I get a SQLSTATE[28000] [1045] Access Denied error every time I try to connect my ownCloud instance to my MySQL database as <user>@localhost. This is on a clean, newly installed copy of Ubuntu ...
0
votes
0answers
25 views

sar -r %commit very high but only utilizing 3GB of 8GB Ram

This is probably lack of understanding on my part, and maybe too general of a question (if I can clarify further please let me know) but I am wondering what this could mean. I have the following ...
1
vote
1answer
42 views

VPS Admin Panel

I got a simple question. I have this VPS hosted on Linode.com and I am currently using webmin and virtualmin. I have one domain, do not plan to have to multiple domains, I want subdomain and my dns ...
0
votes
3answers
45 views

Log File Directory LAMP

I'm a developer working for a company and, for better or worse, their IT Dept. handles the server that my current web application exists on. It's a LAMP server and, right now, the access log file sits ...
0
votes
1answer
60 views

Varnish 4.1: Is this the proper VCL code to use default localhost unless it's unhealthy, then fallback to director?

I just wanted to make sure this is the most ideal way to accomplish this. Here's the setup: Basically we have 3 servers "balanced" by DNS Round Robin. Varnish is configured on each server with a ...
0
votes
0answers
50 views

Enable Firebird Interbase for PHP on Ubuntu LAMPP

I installed Firebird on Windows along with XAMPP and all went OK. On Ubuntu, after installing Firebird Server following the instructions here. I uncommented the "interbase.so" line in php.ini, but I ...
1
vote
1answer
15 views

Is it possible to send the same domain to a different vhost on Apache?

I need to send my local users on my LAN who visit mydomain.com to virtual host A. Then external visitors from the web who visit mydomain.com are redirected to virtual host B. The reason being; I would ...
0
votes
0answers
8 views

Is it possible to send the same domain on an Apache server to a different vhost?

I am wondering if it is possible to send a domain to a different virtual host on running Apache based on the users location. For example users on my LAN who visit my domain.com get directed to ...
1
vote
1answer
24 views

How to prevent compression of images served via HTTP

I have an already optimized JPEG image in my server 32.07 kB (and in my local computer), 800px * 534px, if I request it via browser, it keeps the same width * height, but its size gets smaller 17,97 ...
0
votes
1answer
46 views

Single Thread CPU Performance with PHP

I have a lamp web server running a website that is getting very feature bloated. I have a few pages that are taking 2-3 seconds of CPU time to render the PHP. Most other pages a processed in about .2 ...
0
votes
2answers
29 views

Create and save mail to inbox locally with Postfix

Apparently it's as simple as just sending an e-mail to a local account, and configuring Postfix to receive mail for the local account. Not too shabby! Original Question This hypothetic server would ...
0
votes
0answers
15 views

Apache Setting up multiple domains with http & https

I've been trying to add a second domain to my apache ubuntu server. I'm not getting any errors, but when I go to "test.ca" it still redirects to "example.com". What am I missing?? I want both domains ...
4
votes
1answer
51 views

TKLBAM backup stalling causing MySQL issues

I'm having a strange issue that I've never encountered before. I'm running a Turnkey Linux LAMP server (Debian) and it seems that my MySQL server becomes inaccessible at least once a day. I'm not sure ...
0
votes
0answers
13 views

Website slowed down all of a sudden? [duplicate]

My site example page is very slow, this is the server status page of apache My guess is that the iptables are slowing it down, as there is no reason from the hardware side, there are enough free ...
3
votes
2answers
87 views

Apache Suddenly Slow

Apache on my webserver is suddenly very slow. I have a 8 GB Ram, 4 CPU server at digitalocean with LAMP installed. What can I do to fix this? This is the top output: top - 10:37:15 up 93 days, ...
0
votes
0answers
11 views

Staging Server file permisssion

I have a staging server that I use primarily for wordpress sites but there is also couple of non wordpress sites. I need to be able to update and install new plugins to these sites and also change ...
-2
votes
1answer
23 views

How to config apache for a local network app?

Hey guys I'm really new to this please forgive me if I butcher all the terminology. I've managed to get a lamp-server running for my small business and have created a small webapp that runs on the ...
-4
votes
2answers
26 views

php file permission 600 gives me a blank page in localhost

When I set the file permission to 644 for php files, it works. But if I give them 600 then they give me blank pages. And it happens only in localhost, in remote host 600 file permission for php files ...
0
votes
2answers
43 views

I think I've got .htaccess issue

I run Ubuntu 14.04 and a LAMP stack. I'm having strange issues with my Joomla site and I suspect that maybe it's because of my errors in running a web server. Since it's not a Joomla forum, I won't ...
0
votes
2answers
28 views

Directory/file permissions for web pages on Ubuntu web server

I'm setting up a web server at work, with Ubuntu 14.04 and apache. It hosts 3 webpages (can be more in the future), managed by different developers. I have concerns on how to setup the public web ...
-2
votes
1answer
69 views

Sendmail works fine but PHP is unable to use that

I have a problem sending mail with PHP on a LAMP (redhat 7 server). I have configured sendmail, with which I am able to send email using the following: $ sendmail toemail@something.com <press ...
0
votes
1answer
78 views

LAMP server with remote MySQL on CentOS 6.4 [duplicate]

I am pretty new to linux and LAMP setup. I want to setup a LAMP environment with AP on one linux server and M on a different linux server. I have a hard time finding a relevant document with such a ...
-1
votes
1answer
148 views

LAMP stack with apache and php on one linux server and mysql on a different linux server [closed]

I am pretty new to linux and LAMP setup. I want to setup a LAMP environment with AP on one linux server and M on a different linux server. I have a hard time finding a relevant document with such a ...
0
votes
2answers
157 views

Unable to authenticate MediaWiki (on LAMP/Ubuntu) users using AD (on Windows Server 2012 R2) via LDAP

I am working in an AD domain with a single DC running Windows Server 2012 R2. On the domain's network (though not formally domain-joined) is a LAMP web server running Ubuntu Server 14.04.3 LTS. All ...
0
votes
1answer
17 views

apache2 is showing my webpage directory and folders after installing ssl self-signed certificate.

after configuring apache2 on my lamp, all content on my local webpage shows just directory and folders. It was working fine when I had it on http. I have been trying to figure when went wrong for ...
0
votes
0answers
14 views

webpage issue after enabling ssl, all i see is files and folders on my webpage

I installed Teampass on my lamp server and it was all good on http. now that i have enabled ssl for https all i see are the files on the webpage. not more graphics etc. I need help please.
1
vote
0answers
76 views

Creating subdomain in google cloud LAMP stack

I have installed the LAMP stack, and mapped my domain name "example.com" to my external IP in google app engine. Now I need to create a subdomain and map it to some folder in the same instance. So , ...
0
votes
1answer
84 views

Install lamp-server on EC2 at start-up

I passed some scripts to EC2 userdata to install at starup. One of those is sudo tasksel install lamp-server When this process runs, it prompts for mysql password,twice, to bypass this, I use sudo ...
0
votes
0answers
24 views

Someone has put phishing files on my server [duplicate]

Recently i found some phishing files (PHP/HTML) on my server which were previously not present. I deleted them but later another set of files reappeared. This is happening for all the sites hosted on ...
0
votes
0answers
49 views

How to get a useful error about failed .htaccess redirects?

I am trying to set up a test server on localhost for a LAMP app that's already live, in order to allow my team to write and test some new features. On a vanilla installation of Fedora 22, I have ...
0
votes
0answers
9 views

installing lampp or installing separately for those components [duplicate]

Should I install lamp package or Should I install separately like apache2,mysql and php packages? What installing method is better for VPS server optimization, fast and safe to run website? ...
0
votes
0answers
67 views

Using docker for a LAMP multi tenant app

I'm developing a CRM application that provides a unique subdomain to users who sign up for the service. I use the same code base but multiple databases with identical schema. My initial plan was to ...
1
vote
1answer
108 views

Ubuntu LAMP server busy at peak hours

I'm running a Ubuntu 14 server with LAMP on virtual cloud hosting (CityCloud). The server is usually doing very well with response time<0.5s. However, the problems start at peak hours, mainly ...
0
votes
0answers
31 views

How to get “Runtime Settings” on Web UI in APC 4.0.7?

I have two LAMP servers, server1 and server2, with server2 being the newer of the two: server1 [root@server1 ~]# cat /etc/redhat-release CentOS release 6.5 (Final) [root@server1 ~]# httpd -v Server ...
0
votes
2answers
55 views

Performance testing LAMP-Cluster - How to find bottle neck?

I have set up a cluster of 3 nodes running a LAMP-Application with HAProxy doing the load balancing. Now I would like to optimize and load test the system. Therefore I am unsing jmeter-ec2 which ...
0
votes
0answers
46 views

IIS 7.5 Reverse Proxy and ARR Multiple Sites to Seperate Subdirectories

I am running a Windows Server 2008 R2 SP1 web server (IIS 7.5) with the rewrite module and ARR installed. I have a few LAMP servers which do a few WordPress sites which are to be accessed via the ...
0
votes
1answer
104 views

Unable to locate where PHP requires extension? [closed]

After php -v I get some warnings about broken PHP extensions. PHP Warning: PHP Startup: Unable to load dynamic library ...
2
votes
0answers
180 views

How to solve intermittent server hangs? Write to (and read from) a disk stops completely

We have a LAMP server for about 6 months. CentOS 7.0 It ran non stop without a restart for the first 3 months then it hang. Then it run for the next 2 months (also non stop without a restart) then ...
1
vote
0answers
370 views

Apache2 could not be installed

When I run apt-get install apache2 I get some error: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may ...
2
votes
1answer
157 views

Website sometimes takes long time to load

I am running a LAMP system with Ubuntu 14.04. I have 4 cores and 8GB Ram on my server The problem is that when I connect to my website after idle period( 2-3 hours or more) the it takes lot of time ...