2
votes
0answers
27 views

LibVirt (QEMU) Shutting down from inside guest

I am currently running LibVirt with Qemu on Debian Wheezy: Versions: libvirtd (libvirt) 1.2.4 qemu-x86_64 version 2.0.0 (Debian 2.0.0+dfsg-4~bpo70+1), Copyright (c) 2003-2008 Fabrice Bellard It's ...
0
votes
0answers
64 views

Cannot add any virtio discs in virt-manager, how to fix?

I’ve just freshly installed virt-manager and libvirt-bin (and related packages) on a Debian sid system, and have a strange problem I’ve not yet seen on another similar installation: When creating a ...
1
vote
1answer
275 views

Why can't I shutdown running kvm instance?

I have running kvm instance: =# virsh list --all Id Name State ---------------------------------------------------- 2 debian-test running When ...
1
vote
1answer
185 views

virt-install ignoring vnc port/listen?

I'm trying to create kvm machine on remote host. The host is running debian testing. Did use this command: virt-install --name debian-test \ --os-type=linux \ --os-variant=debianwheezy \ ...
0
votes
1answer
232 views

OpenNebula can't start vm after reboot

I installed a fresh install of Debian-7-opennebula-4.4.0-1.tar.gz on a fresh Debian and got a VM to start via sunstone. The output of libvirt was: 2013-12-26 12:48:12.919+0000: starting up LC_ALL=C ...
1
vote
1answer
858 views

Libvirt: ERROR No domains available for virt type 'hvm', arch 'x86_64', domain type 'kvm'

Installed virt-man like this $ apt-get install virt-manager $ modprobe kvm $ modprobe vhost-net Launching libvirt guest $ virt-install --virt-type kvm \ --name centos-6.5 --ram 1024 \ ...
1
vote
0answers
234 views

nwfilter: Generated firewall rules don't make any sense

I'm trying to configure nwfilter for KVM, but so far I haven't managed to figure out a working configuration. Network setup: The dom0 (Debian 7.1, kernel 3.2.46-1, libvirt 0.9.12) is connected via ...
0
votes
1answer
153 views

Debian Squeeze KVM - No Matter How I Setup Bridge, No Connectivity on Guest

I'm attempting to setup libvirt KVM guests on my server, and I've been messing around for two days now trying to get the guest networking working. So far, I haven't gotten anywhere. My network is ...
8
votes
3answers
324 views

Technology for short-lived private VMs

I'm trying to build a system that will run short-lived (CI and test builds) of software components, it's mandatory according to my requirements that each live on a private host. I'm taking that ...
2
votes
0answers
403 views

Debian Squeeze Preseed Installation “The current kernel doesn't support the Logical Volume Manager. You may need to load the lvm-mod module.”

I'm attempting to install Debian Squeeze via an instalinux.com image pre-seeded with more or less default settings. (Only notable addition is the openssh server, which is a clickable option in the ...
3
votes
1answer
199 views

2xAMD Opteron 6128 with libvirt, Physical CPU 13 doesn't exist

I need help with libvirt(?) problem. Server specs: ProLiant DL165 G7 2x AMD Opteron(tm) Processor 6128 System: Debian GNU/Linux testing (wheezy) 3.2.0-3-amd64 libvirt 0.9.12-5 kvm ...
1
vote
4answers
3k views

KVM slow guest i/o

Host: Debian 6.0 (squeeze) with qemu-kvm and libvirt from squeeze-backports ii qemu-kvm 1.0+dfsg-8~bpo60+1 ii libvirt-bin 0.9.8-2~bpo60+2 Has ...
1
vote
1answer
3k views

Libvirt: Cannot access CA certificate '/etc/pki/CA/cacert.pem': No such file or directory

Debian 6, all libvirt packages are installed. The /etc/pki/ directory is missing. What package is responsible for it?
1
vote
1answer
233 views

freebsd iso install on KVM - timer freezes

Trying to boot freebsd iso on KVM/libvirt [debian host] Timer shows: 10 sometimes is 9 or even 7. and that's it, count down stops.. Found some information that it's a bug with newest qemu and my ...
1
vote
3answers
2k views

Can't connect to remote Xen libvirt with ssh, using virsh or virt-manager

I'm running Xen 4 on a Debian server running Squeeze (stable). I want to connect remotely over ssh using virt-manager or virsh, because I can do that on a Lenny server (oldstable). Xen is installed ...