Localhost is an address/term used for testing connection to the local host (current computer) used for some network troubleshooting

learn more… | top users | synonyms

0
votes
0answers
24 views

cannot resolve … Unknown host with Bind

I am using BIND on OS X. nslookup and dig work (I think) but ping and HTTP in browser do not seem to work. $ nslookup a.appname.local Server: 127.0.0.1 Address: 127.0.0.1#53 Name: ...
1
vote
0answers
47 views

ERR_ICANN_NAME_COLLISION when trying to use localhost .dev in Chrome [migrated]

Today I got this error when trying to access local domains specified in apache httpd-vhosts.conf. It happened for the 1st time with a .dev domain, so it seemed plausible that in light of recent news ...
0
votes
1answer
33 views

Postfix + php translating email addresses sent to local domains to something@localhost.localdomain [on hold]

My first question here, if I don't provide sufficient info straight away, please take it easy on me with the downvotes ;-) I'm running a VPS hosted by afterburst.com with OpenVZ I installed and ...
0
votes
1answer
78 views

IIS 8.5 - Site not reachable locally, but is reachable from any other machine [on hold]

I have a weird problem. I have a couple of sites hosted through IIS. One of them works fine all around. The other only works if I try to access it from another machine. I have bindings set for ...
0
votes
1answer
24 views

How to use non-deprecated tools like ss to get process id running on a port?

I am looking for a non-deprecated way of running a command like netstat -tulpn | grep 8000 to output information about an active port. Any suggestions on how to use a tool like ss to get the process ...
0
votes
2answers
55 views

Apache 2.2 won't start with an ipv6 address [closed]

I'm trying to only allow the localhost on a certain folder, it works perfect with ipv4 (Allow from 127.0.0.1) but as soon as I add ipv6 (Allow from [::1]) my Apache won't start anymore. I checked the ...
-1
votes
1answer
44 views

Too large 127.0.0.1 connections with nginx - apache2 [duplicate]

I use nginx as proxy-server apache2 and I have a problem with netstat output: $ netstat -ntu | awk '{print $5}' | cut -d: -f1 | sort | uniq -c | sort -n 5 109.195.36.169 6 109.195.33.205 8 ...
0
votes
3answers
283 views

VirtualDocumentRoot & localhost

Currently this is my httpd-vhosts.config file NameVirtualHost *:80 <VirtualHost *:80> VirtualDocumentRoot /Users/Gabri/Sites/%2/%1/build </VirtualHost> However I would like to have ...
-1
votes
0answers
7 views

Accessing JSON Server Hosted on a Virtual Machine [migrated]

I have set up a Linux Virtual Machine on my Mac (Kubuntu 14.04). On it I am running a JSON server using a Python script that is hosting it at localhost:8080. Is there a way I can access this from the ...
-3
votes
0answers
50 views

error 404 new installation of wordpres in localhost with nginx hhvm

I have problems with wordpress and nginx on localhost. The phpinfo test runs within the default folder nginx user,,,, When I try to install wordpres says, error 404 If I make a test page ...
1
vote
1answer
202 views

Can't access local apache virtualhost using Chrome [closed]

I have a few virtualhosts on my localhost apache, here's the config of one (the others just change the letters before .localhost) <VirtualHost *:80> ServerAdmin admin@dev.localhost ...
0
votes
1answer
17 views

Accessing Local Web server on my LAN error

I have looked at the other questions related to this on SO, Googled and looked in my Window Logs. I have a local web site on a PC that is DHCP assigned. It is a MVC web site using IIS Manager. On ...
-4
votes
2answers
11k views

Why does localhost not work on Windows Server 2008 R2? [closed]

Why does navigation to localhost not work on Windows Server 2008 R2? The expected result is the IIS application hosted on the machine in question to be returned. Navigation to localhost/mySite returns ...
0
votes
2answers
279 views

localhost as computer name

When you set up Windows it requires a computer name, something like Steven-PC. This is the equivalent to hostname on Linux. I noticed that Fedora Linux uses localhost as the default hostname. Would ...
0
votes
0answers
13 views

Pinging <anything>.google resolves to 127.0.0.53 [duplicate]

Ok, this is weird. I didn't know the Google Aprils joke URL (it's http://com.google FYI), so I put http://google.google into my Chrome browser, and got returned a default IIS landing page. Turns out ...
0
votes
1answer
35 views

Ubuntu server does not display any webpage in browser

Initially I was installing wordpress on ubuntu, it does not display wordpress install page, so then I took it off of var/www/html and realize that ubuntu does not display any webpage including the ...
0
votes
0answers
71 views

Simulate load balancing on localhost using IIS and Application Request Routing

I want to simulate website load balancing on my development machine using IIS and Application Request Routing. I was able to "load balance" between two external sites, but trying to do the same with ...
0
votes
2answers
1k views

Serving assets on two different ports

I have one PHP app running on localhost port 80 and another running on port 81. Pointing the browser to http://localhost runs the first app and all of its assets: js, css, imgs in the /assets folder. ...
0
votes
7answers
12k views

localhost went “It works!” - and nothing else

I'm working with Mac's built in Apache, and everything was just great UNTIL - something went wrong. I think it's the .hosts file. http://localhost results with "It works!" message, while any ...
1
vote
1answer
663 views

Showing outdated information when using WAMP as local server [duplicate]

I am running WAMP as a local server for the computers in the my network. The problem is that when I try to do any operations to the database from these computers, it seems as if they don't happen, ...
6
votes
1answer
2k views

Failed to connect to 127.0.0.1 port 80

I have running nginx server (doesn't matter which server): $ sudo netstat -tulpn | grep 80 tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4268/nginx tcp6 0 0 :::80 ...
0
votes
1answer
148 views

Intranet Ip - Access from Custom Domain

I have setup a local intranet in my office using IIS7 (Windows 7 Machine), currently it can be accessed through the PC's static IP, however I would like it so that internally it can just be accessed ...
0
votes
1answer
54 views

localhost != localhost for MySQL/PHP

System: Mac OS X Server 10.6.latest I just switched from the ancient MySQL (<5?) that came with Mac OS X Server to MariaDB 10.1, installed via MacPorts. (That was a whole 'nuther barrel of fun...) ...
-3
votes
1answer
84 views

Why is my apache server address ::1 but not 127.0.0.1 [closed]

I am using bitnami wamp on windows 7 running apache 2.4 and I am having a problem. The server address of the apache server shows ::1 instead of the expected 127.0.0 1 Is apache using ipv6 by default ...
0
votes
1answer
78 views

Port redirection with iptables to localhost / blocking the destination port

I like to forward all traffic coming to 80 to be redirected to 8000. I used iptables -tnat -A PREROUTING -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 8000 But then port 8000 is still open to ...
-1
votes
1answer
311 views

OS X 10.10 Localhost Environment using nginx, mysql, and php via Homebrew

I am running Mac OSX 10.10 Yosemite with homebrew. I was using a localhost environment using MAMP and I wanted something that was less of a resource hog and without all the bloated extras. I have ...
0
votes
2answers
385 views

Can View Website on Localhost and By IP on machine but nothing from other machines

I have a centos apache2 webserver which is running and I can view the localhost website from localhost or by http://192.168.0.167 (its IP) through a browser on the machine itself, but if I try to view ...
1
vote
1answer
88 views

Can't reach iis server via external ip

I am using aws from amazon and I have iis intalled on my server. I have created a test site but I can't reach it using external ip address. It is only reachable throught http://localhost- and ...
4
votes
1answer
99 views

psping to localhost - improve throughput

I'm using following psping command to measure the bandwith throughput for localhost on a physical server psping -4 -b -l 8k -n 20000 localhost:1234 The throughput is around 150MB/s wich isn't all ...
0
votes
0answers
83 views

Proxmox on localhost network + 32 bits host

I'm working in installing Proxmox on localhost network. Installing the PVE kernel works fine : root@localhost:~# uname -a Linux localhost 2.6.32-14-pve #1 SMP Sat Sep 22 08:55:13 EST 2012 i686 ...
1
vote
1answer
197 views

Windows server DNS resolves localhost for (some) foreign IPs

I have 2 Windows Server 2008 R2 DNS Servers which share the domain xyz.wan and reside in the 192.168.50.0/24 subnet of my network. Connected via IPSec VPN site-to-site are some other subnets ...
2
votes
3answers
2k views

Redhat doesn't set my desired hostname on reboot

I have a redhat (EL5) server that I need to change the hostname on. I'm trying to put it back into a known state to help with server provisioning activities. As part of changing the hostname, I'm ...
4
votes
7answers
33k views

FTP hangs on: 150 Opening ASCII mode data connection

I am setting up an FTP server on my Windows 2008 server (R2). Everything appears to be installed correctly but I am having trouble using an FTP Client to login to my FTP server. I can remote desktop ...
-1
votes
2answers
186 views

Why does mail always come from @localhost on my ubuntu server from exim4? [closed]

I have an up-to-date Ubuntu Server (14.04.01) and want to be able to send out status e-mails. I've also got 2 other computers running Debian Sid. I have exim4 installed on all 3. I've gone through ...
3
votes
3answers
12k views

Accessing localhost on IIS7 from another computer on the network

I recently upgraded computers to Windows 7 Professional and am running IIS7. When I'm on my computer I can easily access localhost through my web browser but when I try from another computer on my ...
1
vote
1answer
2k views

IIS refuses connection to localhost and 127.0.0.1

I am unable to connect to localhost and http:// 127.0.0.1 on one of my machines. However http://machinename works. This results in the Windows Token Application being not able to issue tokens, ...
3
votes
8answers
5k views

SQL Server 08 Express error when connecting to localhost - “Timeout expired”. Works with ::1 or 127.0.0.1

EDIT New info: Navigating to localhost:1434 in Chrome gives me an "ERR_EMPTY_RESPONSE", while other ports give me an "Oops! This link appears to be broken". So it seems to binding ok there? So ...
-1
votes
2answers
768 views

“Connection to host lost” on telnet to port 25 [closed]

i installed smtp4dev to test receive mails in my localserver(xampp) for the registration form here: https://github.com/panique/php-login note: localserver is on port: 8080 my php.ini file for SMTP ...
98
votes
2answers
40k views

Why does my hostname appear with the address 127.0.1.1 rather than 127.0.0.1 in /etc/hosts?

This may be a bit of a noobish question, but I was taking a look at /etc/hosts on my new Xubuntu install and saw this: 127.0.0.1 localhost 127.0.1.1 myhostname On most 'nixes I've used, the second ...
2
votes
4answers
1k views

Best way to run two different websites on localhost [closed]

I'd like to run two websites with XAMPP for Linux on my computer: One for my public website development One for my thesis (bibliography management, abstracts, ...) They are totally unrelated and I ...
82
votes
14answers
74k views

In my /etc/hosts/ file on Linux/OSX how do I do a wildcard subdomain?

I need to test sub-domains on my localhost. How can I effectively have this result of adding *.localhost.com to m /etc/hosts/ file? If it's not possible, how do I work around this problem? I need ...
0
votes
2answers
291 views

Bind9 DNS resolves full domain to localhost

I have set up a Bind9 DNS server on my development VM which is running Debian Wheezy. My addresses resolve from my host machine (Win7) to my dev VM, and I can ping from there. Internally on the VM, I ...
1
vote
0answers
148 views

Getting 503 when trying to run Classic ASP on Win7 and IIS7.5

I am being asked to resurrect a classic ASP application for temporary use. Wonderful. Well, the pay's the same, so I am now trying to get the thing to run on my localhost so I can test it and so on. ...
0
votes
1answer
286 views

Centos services cannot bind on localhost but find on * or specific ip address

I've got a VPS with Centos 6.4 installed. I used to have a VPS at Digital Ocean that when I start PostgreSQL or Monit that bind to localhost, they all work fine. But on the new VPS, when I have ...
1
vote
1answer
76 views

HTML served from localhost is being modified by ISP [closed]

I took my laptop to a local restaurant yesterday to do some work setting up a new web app. I get the server in place, and created a simple HTML page: <html> <body>Hello, ...
2
votes
4answers
21k views

Cannot get proxy.pac file to get browsers to go DIRECT for localhost

I am gonna throw this problem out into the wild. We have just started using a proxy to log users internet usage against login names. This is setup on ISA Server 2004 (which is on our Internet gateway ...
0
votes
3answers
2k views

Assigning Multiple IP Addresses to localhost OS X 10.6

I'm attempting to host multiple website locally with HTTPS enabled, but in order to do this I'd need to configure my local machine to use multiple IP address for localhost (I believe). Is there any ...
-3
votes
2answers
243 views

DNS Server VS DNS Record [closed]

This question is to clarify a fundamental concept so that I can properly understand an error message. My server threw a warning message that implored me to: add 127.0.0.1 to the list of DNS ...
1
vote
0answers
185 views

DNS does not route properly to WAN NIC when dnscrypt is used

I have a Windows 2003 server with AD integrated DNS. I'm trying to configure the server to make outgoing (forwarded) DNS requests through dnscrypt proxy instead of through the normal TCP/UDP 53. I ...
4
votes
6answers
8k views

Can't SSH into a Vagrant Virtual Machine

Local Vagrant machine installed at IP address 10.0.0.23 with hostname lamp-vm. Using vagrant ssh command, I can connect just fine and do everything I need. This creates an error $ ssh ...