2
votes
1answer
74 views

How to reject Mercurial user if userid not matched with Apache authentication?

Presently we are serving Mercurial Repository (hgweb) behind the Apache server, when user pushes changes to Apache it is authenticated by userid/password (pwauth). How to restrict the push to user ...
4
votes
3answers
639 views

Setup mercurial over HTTP

Can you give some pointers to setup Mercurial over HTTP/HTTPS? I am setting up a development server (Debian), where i want to create a mercurial repository and push the changes to the server. I need ...
2
votes
1answer
128 views

Replace Mercurial username with Apache authenticated one

I have an Debian 6 x64, python 2.6, Apache 2.2, Mercurial 1.8. Mercurial is accessed over HTTPS, python uses mod_wsgi, Apache performs "Authentication: Basic" with mod_authnz_external. What I need is ...
2
votes
1answer
1k views

Authenticating with Mercurial server without supplying credentials to prompts or in .hgrc file

I have a Windows 2008 R2 IIS7 server with Mercurial under HTTPS. I connect to the Mercurial Repositories using TortoiseHG and via the web interface. If I don't have my username and password in the ...
2
votes
2answers
598 views

How to configure mercurial access controls using apache and hgweb?

I have set up a mercurial repo to be served using apache+wsgi+hgweb on OS X. It is now completely open to anyone who stumbles upon my server on the correct port number.. How can I set it up so that ...
18
votes
2answers
7k views

Setting Mercurial with Active Directory authentication and authorisation

I am evaluating the possibilities of moving my organisation to Mercurial, however I am stumbling on two basic requirements which I can't find proper pointers to. How do I set up Mercurial's central ...
26
votes
6answers
67k views

How to configure basic authentication in Apache httpd virtual hosts?

I'm trying to configure mercurial access using Apache http. It requires authentication. My /etc/apache2/sites-enabled/mercurial looks like this: NameVirtualHost *:8080 <VirtualHost *:8080> ...