The tag has no wiki summary.

learn more… | top users | synonyms

2
votes
2answers
1k views

Mod_pagespeed, Varnish and Apache cache issues after new code pushes

I have a rather strange issue. In my environment we are running a load balanced cluster of 8 apache servers with a master-master MySQL backend. In front of apache we have Varnish in the cache layer. ...
0
votes
2answers
22 views

Mod-Pagespeed dropping headers

I'm using 1.6.29.7-3343 for css and images with Apache 2.2.15 (Unix) on RHEL 6. My pagespeed.conf config is here: https://gist.github.com/jhirbour/a66b0efe58c8d109b90e As part of our PCI our ...
0
votes
1answer
249 views

How to make varnish 4.0 work with nginx and pagespeed

I am trying to setup Varnish 4 + Nginx with mod_pagespeed. I am using the following config for Varnish 4 as per this document : ...
0
votes
1answer
94 views

Can I use the Nginx PageSpeed module together with SSI?

Is it possible to use the Nginx PageSpeed module together with SSI? I can't get SSI up and running when PageSpeed is enabled. But as soon as I disable PageSpeed, SSI works again: location ~ ...
0
votes
1answer
96 views

pagespeed cleanup performance issue

I configured pagespeed to cache js and css files to improve server performance. But sometimes server loads and performance lag is quite visible. So want to tune pagespeed. I increased pagespeed's ...
0
votes
1answer
198 views

mod_pagespeed own js and css render blocking

My mod_pagespeed gives a lower score because it's own js and css are render blocking. Given that the tool is designed to speed up, not slow down, I don't think this is desired behavior by design. Has ...
0
votes
1answer
1k views

Apache2 will not start on OpenSUSE after enabling mod_pagespeed

I have a linode VPS, running openSUSE 12.1 (A little outdated, but stable). I have installed the RPMS for mod_pagespeed. mod_pagespeed.conf has "ModPagespeed on". Restarting apache fails after ...
-1
votes
1answer
108 views

compiling nginx with page speed error

Hi all why do I get this error when compiling Nginx with page speed make[1]: Leaving directory `/home/myhomedir/ngx_pagespeed-release-1.6.29.5-beta/nginx-1.4.2' make -f objs/Makefile manpage make[1]: ...
2
votes
0answers
716 views

Mod_pagespeed with Zend Framework gives 404

I am expiering some problems with the Google's Apache mod_pagespeed module to combine css, js, etc. During the last months I developed a new version of our software based on Zend Framework. I just ...
1
vote
0answers
62 views

Django wsgi and mod_pagespeed not working

I installed mod_pagespeed on my server and it's working as far as the page header is concerned: X-Mod-Pagespeed:1.7.30.5-3847 The problem is that it's doing nothing else. No whitespace or comment ...
1
vote
0answers
82 views

Mod Pagespeed installed, sends headers, but does not filter or cache

Server: CentOS, Apache, WHM/Cpanel, Hostgator dedicated. I had mod_pagespeed installed and working. Someone at HG ran a script that killed mod-pagespeed and they had to re-install it. Now, it is ...
1
vote
0answers
303 views

How do I handle apache2 modsecurity2 warnings like Match of “rx ^OPTIONS$” against “REQUEST_METHOD” required?

After upgrade from squeeze to wheezy I get loads of these messages in my apache errorlog when I open a webpage on myserver, (changed to myserver.de here): [Sat Oct 19 01:06:21 2013] [error] [client ...
1
vote
0answers
671 views

Apache mod-pagespeed installation affects mod-spdy?

Recently my site (an https connection, running on an Amazon EC2 ubuntu apache2.2) has this issue where I need to load the page several times (3-4) before it will load normally without issue. It will ...
0
votes
0answers
11 views

Infinite 301 redirect loop on some images with apache mod pagespeed

I just installed mod-pagespeed on my Ubuntu server and I have some images which are not visible when I activate mod-pagespeed. When I looked at these images in the Chrome developper tool I see a 301 ...
0
votes
0answers
30 views

mod_pagespeed combine_javascript combines but serves individual as well

I have spent all day trying to get mod_pagespeed working. All is going pretty well and I have decreased my load times. The last piece I would like to get working is the combine javascript. BTW, I ...
0
votes
0answers
27 views

mod_pagespeed - not respecting vary header

It appears that the Apache httpd server(with mod_pagespeed) in front of my application is not honoring the “Vary: User-Agent” response header included by the applciation. It appears to be replacing it ...
0
votes
0answers
57 views

Google PageSpeed Mod (nginx) dns-prefetch not working

My VPS running Ubuntu 12.04, Nginx, pagespeed Mod, APC and wordpress. I added insert_dns_prefetc filter to main Nginx configuration file. But it's not adding <link rel="dns-prefetch"> tags to ...
0
votes
0answers
342 views

Apache Error - child process [xxx] still did not exit, sending a SIGTERM & ServerContext: 1 leaked_rewrite_drivers on destruction

I have many error log entries called ServerContext: 1 leaked_rewrite_drivers on destruction AND child process 10494 still did not exit, sending a SIGTERM does anyone has any idea on how to ...