Mono is an open source implementation of .NET that runs on many platforms, including Linux, Mac OS X, and Windows. This allows running .NET applications on platforms other than Windows with little to no modification.

learn more… | top users | synonyms

5
votes
2answers
3k views

Linux: Case-INSENSITIVE Filesystem

What methods are there to make the Linux filesystem case-INSENSITIVE ? I have asp.net applications developed on Windows, but there are always issues with capitalization/spelling on mono when putting ...
2
votes
1answer
984 views

Trying to run an ASP.NET MVC application using Mono on Apache with FastCGI

I have a hosting account with DreamHost and I would like to use the same account to run ASP.NET applications. I have an application deployed in a subdomain, a .htaccess with a handler like this: # ...
1
vote
3answers
758 views

ASP.NET via mono on linux? [closed]

Has anyone tried running an ASP.NET project via mono on a linux server? Can it be done? was the performance good?
3
votes
1answer
2k views

Install Mono ASP.NET on debian

I've been trying to install mono ASP.NET onto my debian VPS and I am unable to do so. I know I need mono which can support .NET 4.0 now. I am unsure if I need XSP and mod_mono, or just mod_mono. ...
0
votes
1answer
2k views

Automatically starting C# Mono application on Ubuntu server

I have a TCP server written in C# which I will run on my server. I've tested the application running on the server and client side and it all works great! I'm using mono on my Linux server to run the ...
8
votes
3answers
8k views

Setting up Mono/ASP.NET 4.0 on Apache2/Ubuntu: Virtual hosts?

I'm attempting to setup Mono/ASP.NET 4.0 on my Apache server (which is running on Ubuntu). Thus far, I've been following a few tutorials/scripts supplied here, and here. As of now: Apache 2.2 is ...
0
votes
0answers
98 views

CentOS 6, mod_mono configuration (pages not serving)

I've installed LAMP on CentOS 6, and that's all working fine - serves PHP without issue. I'm trying to install "mod_mono" to create an ASP.NET 4.5 site, but it's simply downloading the file (e.g. ...
0
votes
0answers
46 views

TypeLoadException with ASP.NET on Apache2+Mono

I developed some ASP.NET code on my Mac laptop. It works fine. Deployed it to Ubuntu running apache2+mono. Now, I am getting TypeLoadException claiming that my type cannot be loaded from an assembly: ...
2
votes
2answers
4k views

Haproxy not properly passing on X-Forwarded-For header

I have backend web servers that receive requests by way of haproxy->nginx->fastcgi. The web app used to see multiple ip's coming through in the X-Forwarded-For header, chained together with commas ...
0
votes
0answers
53 views

cannot open assembly certmgr.exe

I'm trying to run a basic console app that calls a web services hosted on an external https endpoint using Mono. I keep getting errors about decrypting the response. Some googling has led me to ...
1
vote
5answers
2k views

nginx more fastcgi-mono-server

I've been looking for post related to my problem, but I have not found. I´m hopeless, I follow the guide for install and config nginx with fastcgi-mono-server ( ...
0
votes
1answer
81 views

404 error for WebResource.axd with fastcgi-mono-server4

I have a simple ASP.NET WebForms app that I created in Windows and copied over to a Linux server (Ubuntu 14.04) that is running fastcgi-mono-server4 and nginx. The app runs fine on windows, but when ...
1
vote
1answer
125 views

Could not load file or assembly fastcgi-mono-server4

I am trying to host an ASP.NET Web Forms application using Mono. I have installed Mono 3.0.7 and XSP 2.10.2 from source into the /usr/bin directory. I then started the mono server with the following ...
0
votes
2answers
111 views

Why does google-site-verification go into fastcgi-pass ?

See the below nginx configuration file. Virtual name based hosting (example.com), passing requests for example.com and www.example com to the mono fastcgi-process on port 9000 (127.0.0.1:9000) I've ...
0
votes
1answer
268 views

No mod-mono.so or mod_mono.conf after Install

(I apologize in advance for "spam" I asked on "Ask Ubuntu" but no one answered in 5 days. I didn't think this would be hard as I'm sure many have installed Mono with Webmin on Ubuntu 12.04.) On ...
0
votes
3answers
1k views

ASP.NET MVC 3.0 on linux

I'll admit it... I'm a n00b in the linux world, but I'm curious to find out if it's possible to run my ASP.NET MVC 3.0 web applications on linux. Can anybody direct me to or write a guide for n00bs ...
0
votes
1answer
533 views

CentOS 6 Mono and Apache

EDIT: Added some extra logs at the end I'm trying to make Mono 3.0 work on CentOS 6 with Apache. I have compiled Mono, mod_mono and the XPS server from the source. But now I'm getting errors because ...
1
vote
1answer
349 views

fastcgi-mono-server with Nginx is much slower than xsp4

We started testing our MVC4 app on xsp4 server compiled with mono-3.0.3, speed was enough and we decided to set up production fastcgi-mono-server4 (version 2.11.0.0) with nginx (1.2.6-r1). Single ...
0
votes
1answer
167 views

ASP.NET app on Apache Mono Ubuntu compiler error as log4net is unable to be found

I'm trying to get a vulnerable practice ASP.NET web application (WebGoat.NET) installed on Apache Mono on Ubuntu. I've followed this guide and it all went smoothly; however, whenever I try to run the ...
0
votes
2answers
444 views

How do I add Mono Application to Ubuntu Start Up?

I am very new to Ubuntu & Linux. I have deployed an C# Console Application to an EC2 Instance running Ubuntu 12.10. Currently I am using mono foldername/appname.exe to start the app. How do I add ...
0
votes
0answers
380 views

Setting up mod_mono with Apache and ASP.net mvc 4

so I've recently installed mono, mod_mono and xsp4. So far I my site works perfectly with xsp4 but for some reason I cannot get it working with mod_mono and apache2. I get a resource cannot be found ...
2
votes
1answer
337 views

fastcgi-mono-server2 vs fastcgi-mono-server4

Not sure if this is a silly question or not. Basically I'm figuring out how to run Mono on Linux, and I'm a Linux no0b. I've got everything up and running, but confused about fastcgi-mono-server. ...
0
votes
0answers
223 views

Mono FastCGI takes forever to process requests with lighttpd

Alright, for some reason I've decided to try and get ASP.NET working on OpenBSD, because why not? I've settled on lighttpd as I really mucked up nginx bad and they don't ship mod_mono for Apache ...
2
votes
1answer
378 views

“mod_mono and xsp have different versions” error

I'm trying to start a test MVC4 application on Mono 2.10 $ xsp --version xsp2.exe 2.10.2.0 Copyright (C) 2002-2011 Novell, Inc. Minimalistic web server for testing System.Web $ mod-mono-server4 ...
0
votes
1answer
79 views

Is it secure to use apache mod_mono with more virtualhosts?

I am using apache2 with mod_php and mpm_itk_module to run every virtualhost under its user. Now I am looking at mono (mod_mono) and I am not sure, if it is secure to run mono as only one process, whom ...
2
votes
1answer
75 views

What is the best setup of mod_mono with more virtual hosts?

I have VPS on debian, where I want to host at least 20 virtual hosts running mono application. On PHP I was using mpm_itk to run each vhost under its own user (I thing it is good for security and ...
0
votes
1answer
2k views

nginx rewrite url to lowercase url

I have nginx setup, however I'm needing to fix an issue where someone types "/Home" to: rewrite it to the lowercase "/home" (do this to all files and directories, not just home) but locate the ...
1
vote
1answer
1k views

Apache2 doesn't load module mod_mono - CentOS 6

I have compiled and installed Mono 3.0.6, XSP and mod_mono on CentOS, following mostly these instructions. My VHOST is configured as such: <VirtualHost *:80> ServerAdmin ...
0
votes
1answer
448 views

Mono 3.0 not intercepting requests on Apache2/CentOS

I have Mono 3.0.6 up and running on a CentOS 6/Apache 2 setup. I have published an ASP.NET 4.5/MVC4 website on the server. However, when I try to reach the website I get a status code 503 (Service ...
0
votes
2answers
732 views

Running mono-based application on Centos Start

I am very new to Linux and I am currently switching my server from Windows to Centos 6.3. I have written a small UDP server. UDP server was written in C# and now I adopted it to work with Linux using ...
1
vote
0answers
1k views

How do I configure mod_mono to use ASP.NET 4?

I am running a VPS with Centos 6.3, with WHM 11.34.1 (build 11). I wish to use mod_mono to host an ASP.NET 4 application. (Background: I am rewriting a hobby PHP website in ASP.NET MVC 4, and want to ...
3
votes
1answer
319 views

share a domain name beween php and mono

I've got a problem : I've got a dedicated server where I use three different domain names and php. Now, I've got a new website that I developped with asp.net. I installed mono, mod_mono and transfered ...
1
vote
3answers
3k views

How to install Mono XSP as a daemon on Debian?

I want XSP to run on my virtual Debian 5 as a daemon. How can I do that? I tried next: $ sudo cp /etc/init.d/skeleton /etc/init.d/xsp updated the script properly: ...
1
vote
2answers
646 views

Does Mono need to be restarted after changing code files?

I have installed Mono under Apache and its working. My question is - Do I need to restart the mono service each time I make ANY change to any asp.net file under Apache, be this a .cs or even a ...
1
vote
1answer
245 views

mono 3.0.2 + xsp + lighttpd delivers empty page

I needed MVC 4 (and basic .NET 4.5) support so I downloaded mono 3.0.2 and deployed it on an lighttpd 1.4.28 installation, together with xsp-2.10.2 (was the latest I could find). After going through ...
1
vote
2answers
438 views

ASP.NET website as subfolder on PHP Nginx server

My requirements: My website -> example.com - Runs Magento ecommerce platform built in PHP running under Nginx server (currently Apache but very soon moving to Nginx) Another website -> ...
1
vote
1answer
903 views

how to install mono xsp4 and fastcgi-mono-server4

Quick question - I'm on Debian squeeze, running nginx fine and installed mono fine. Now I want to host a .net4 web application and as I understand it I'll need fastcgi-mono-server4 (and xsp4 when ...
0
votes
1answer
39 views

Disable scripting for a particular vhost

I want to disable every form of scripting (PHP, ASP.NET, CGI) for a specific vhost in my Apache2 setup. Only plain old HTML pages. Scripting must remain enabled for all other vhosts in the server. ...
3
votes
2answers
870 views

What's the best server to use with ASP.Net on Mono? [closed]

I am reconfiguring my website from scratch and basically I want it to run Mono(well, ASP.Net inside Mono) According to the Mono Project there appears to be two options, Apache or Nginx. Which one ...
1
vote
1answer
94 views

Best way of updating my (non-critical) website? [closed]

Somehow I couldn't find a related question that quite fit me. Anyway, I run a small blog. When I first started my blog it had next to no traffic, now it receives a couple hundred views per day ...
4
votes
1answer
3k views

Mono 2.11 on nginx using fastcgi-mono-server4 will not work

I have mono 2.11 set up with my nginx 1.0.15 webserver running on centos 6.2. I built it from source and xps2, xps4 and fastcgi-mono-server2 work as expected. The problem is when I try and run ...
1
vote
1answer
397 views

Troubleshooting debian 6 server restarts

A day ago I have installed Mono 2.10 ( for C# 4 support ). Since then server was randomly restarting whenever there is C# app running with no error messages or anything. uname -a Linux ...
-2
votes
1answer
1k views

Install Mono on CentOS 5.5 using Yum

I'm trying to install mono on a CentOS 5.5 machine. I assumed I will be using the OpenSUSE packages (i'm not sure thought, there are other options like Debian and Ubuntu). I created a mono.repo file ...
6
votes
8answers
22k views

Performance of IIS+ASP.NET vs (NGINX + FastCGI + Mono or XSP)?

How much requests each can handle? How many RAM needed? As I remember FastCGI are opened initialized processes, each can handle one request. What about multithreading?
1
vote
1answer
568 views

configuring apache with mod_mono for .net app

I'm having a huge problem getting mod_mono and apache configured to work correctly. I've had this working at one time, but I can't seem to figure out where i'm going wrong. I'm using mono-server4. ...
0
votes
1answer
403 views

mod mono consuming lots of memory and cpu in some situations. How to improve this?

I have set up a apache + mod_mono asp.net mvc3 website, and I'm facing some strange problems with it. Some times, for a reason I do not know, the website just stops responding. When this happens, I ...
3
votes
4answers
2k views

Upgrading my debian server to Wheezy just to install mono

I'm looking to use mod-mono-server4 so that I can run .NET 4.0 apps on mono. I'm currently running a debian server with squeeze with this mono version: $ mono --version Mono JIT compiler version ...
1
vote
0answers
174 views

Find counts of ulimit quotas

So, we may have some sort of zainy leak in our software. We're using Mono and spawning many processes over the course of weeks/months. Eventually, we can't spawn anymore on our clients machines. It ...
1
vote
1answer
3k views

Mono through FastCGI on nginx

I'm going through http://www.mono-project.com/FastCGI_Nginx and can't get it to work. The FastCGI server seems to be running. The following is from the error log: upstream sent unexpected FastCGI ...
1
vote
1answer
2k views

Mono undefined reference to `locale_charset'

I am trying to compile mono from source and am getting this error. ../src/.libs/libeglib.a(libeglib_la-gunicode.o): In function monoeg_g_get_charset': /opt/mono-2.10.1/eglib/src/gunicode.c:312: ...