Mono is an open source implementation of .NET that runs on many platforms, including Linux, Mac OS X, and Windows. This allows running .NET applications on platforms other than Windows with little to no modification.

learn more… | top users | synonyms

2
votes
1answer
918 views

Trying to run an ASP.NET MVC application using Mono on Apache with FastCGI

I have a hosting account with DreamHost and I would like to use the same account to run ASP.NET applications. I have an application deployed in a subdomain, a .htaccess with a handler like this: # ...
1
vote
2answers
2k views

Haproxy not properly passing on X-Forwarded-For header

I have backend web servers that receive requests by way of haproxy->nginx->fastcgi. The web app used to see multiple ip's coming through in the X-Forwarded-For header, chained together with commas ...
0
votes
1answer
429 views

Automatically starting C# Mono application on Ubuntu server

I have a TCP server written in C# which I will run on my server. I've tested the application running on the server and client side and it all works great! I'm using mono on my Linux server to run the ...
0
votes
1answer
41 views

No mod-mono.so or mod_mono.conf after Install

(I apologize in advance for "spam" I asked on "Ask Ubuntu" but no one answered in 5 days. I didn't think this would be hard as I'm sure many have installed Mono with Webmin on Ubuntu 12.04.) On ...
0
votes
3answers
1k views

ASP.NET MVC 3.0 on linux

I'll admit it... I'm a n00b in the linux world, but I'm curious to find out if it's possible to run my ASP.NET MVC 3.0 web applications on linux. Can anybody direct me to or write a guide for n00bs ...
1
vote
0answers
15 views

Why firstcgi mono server2 is not runing [closed]

firstcgi mono server is not running in windows. i am using this command fastcgi-mono-server2 /applications=localhost/ /socket=tcp:127.0.0.1:9000 where i am making mistake? Thanks
0
votes
1answer
357 views

CentOS 6 Mono and Apache

EDIT: Added some extra logs at the end I'm trying to make Mono 3.0 work on CentOS 6 with Apache. I have compiled Mono, mod_mono and the XPS server from the source. But now I'm getting errors because ...
1
vote
1answer
262 views

fastcgi-mono-server with Nginx is much slower than xsp4

We started testing our MVC4 app on xsp4 server compiled with mono-3.0.3, speed was enough and we decided to set up production fastcgi-mono-server4 (version 2.11.0.0) with nginx (1.2.6-r1). Single ...
0
votes
1answer
106 views

ASP.NET app on Apache Mono Ubuntu compiler error as log4net is unable to be found

I'm trying to get a vulnerable practice ASP.NET web application (WebGoat.NET) installed on Apache Mono on Ubuntu. I've followed this guide and it all went smoothly; however, whenever I try to run the ...
0
votes
2answers
297 views

How do I add Mono Application to Ubuntu Start Up?

I am very new to Ubuntu & Linux. I have deployed an C# Console Application to an EC2 Instance running Ubuntu 12.10. Currently I am using mono foldername/appname.exe to start the app. How do I add ...
0
votes
1answer
122 views

nginx reverse proxy server protocol violation

I have nginx which proxies database server REST API with following example configuration: server { listen 80; server_name sub.domain.com; location / { auth_basic "Restricted"; ...
8
votes
2answers
6k views

Setting up Mono/ASP.NET 4.0 on Apache2/Ubuntu: Virtual hosts?

I'm attempting to setup Mono/ASP.NET 4.0 on my Apache server (which is running on Ubuntu). Thus far, I've been following a few tutorials/scripts supplied here, and here. As of now: Apache 2.2 is ...
0
votes
0answers
197 views

Setting up mod_mono with Apache and ASP.net mvc 4

so I've recently installed mono, mod_mono and xsp4. So far I my site works perfectly with xsp4 but for some reason I cannot get it working with mod_mono and apache2. I get a resource cannot be found ...
2
votes
1answer
200 views

fastcgi-mono-server2 vs fastcgi-mono-server4

Not sure if this is a silly question or not. Basically I'm figuring out how to run Mono on Linux, and I'm a Linux no0b. I've got everything up and running, but confused about fastcgi-mono-server. ...
0
votes
0answers
179 views

Mono FastCGI takes forever to process requests with lighttpd

Alright, for some reason I've decided to try and get ASP.NET working on OpenBSD, because why not? I've settled on lighttpd as I really mucked up nginx bad and they don't ship mod_mono for Apache ...
1
vote
1answer
280 views

“mod_mono and xsp have different versions” error

I'm trying to start a test MVC4 application on Mono 2.10 $ xsp --version xsp2.exe 2.10.2.0 Copyright (C) 2002-2011 Novell, Inc. Minimalistic web server for testing System.Web $ mod-mono-server4 ...
0
votes
1answer
73 views

Is it secure to use apache mod_mono with more virtualhosts?

I am using apache2 with mod_php and mpm_itk_module to run every virtualhost under its user. Now I am looking at mono (mod_mono) and I am not sure, if it is secure to run mono as only one process, whom ...
2
votes
1answer
64 views

What is the best setup of mod_mono with more virtual hosts?

I have VPS on debian, where I want to host at least 20 virtual hosts running mono application. On PHP I was using mpm_itk to run each vhost under its own user (I thing it is good for security and ...
0
votes
1answer
1k views

nginx rewrite url to lowercase url

I have nginx setup, however I'm needing to fix an issue where someone types "/Home" to: rewrite it to the lowercase "/home" (do this to all files and directories, not just home) but locate the ...
0
votes
3answers
1k views

nginx more fastcgi-mono-server

I've been looking for post related to my problem, but I have not found. I´m hopeless, I follow the guide for install and config nginx with fastcgi-mono-server ( ...
1
vote
1answer
693 views

Apache2 doesn't load module mod_mono - CentOS 6

I have compiled and installed Mono 3.0.6, XSP and mod_mono on CentOS, following mostly these instructions. My VHOST is configured as such: <VirtualHost *:80> ServerAdmin ...
0
votes
1answer
307 views

Mono 3.0 not intercepting requests on Apache2/CentOS

I have Mono 3.0.6 up and running on a CentOS 6/Apache 2 setup. I have published an ASP.NET 4.5/MVC4 website on the server. However, when I try to reach the website I get a status code 503 (Service ...
0
votes
2answers
475 views

Running mono-based application on Centos Start

I am very new to Linux and I am currently switching my server from Windows to Centos 6.3. I have written a small UDP server. UDP server was written in C# and now I adopted it to work with Linux using ...
3
votes
1answer
251 views

share a domain name beween php and mono

I've got a problem : I've got a dedicated server where I use three different domain names and php. Now, I've got a new website that I developped with asp.net. I installed mono, mod_mono and transfered ...
1
vote
3answers
2k views

How to install Mono XSP as a daemon on Debian?

I want XSP to run on my virtual Debian 5 as a daemon. How can I do that? I tried next: $ sudo cp /etc/init.d/skeleton /etc/init.d/xsp updated the script properly: ...
1
vote
2answers
543 views

Does Mono need to be restarted after changing code files?

I have installed Mono under Apache and its working. My question is - Do I need to restart the mono service each time I make ANY change to any asp.net file under Apache, be this a .cs or even a ...
1
vote
1answer
211 views

mono 3.0.2 + xsp + lighttpd delivers empty page

I needed MVC 4 (and basic .NET 4.5) support so I downloaded mono 3.0.2 and deployed it on an lighttpd 1.4.28 installation, together with xsp-2.10.2 (was the latest I could find). After going through ...
1
vote
2answers
275 views

ASP.NET website as subfolder on PHP Nginx server

My requirements: My website -> example.com - Runs Magento ecommerce platform built in PHP running under Nginx server (currently Apache but very soon moving to Nginx) Another website -> ...
1
vote
1answer
744 views

how to install mono xsp4 and fastcgi-mono-server4

Quick question - I'm on Debian squeeze, running nginx fine and installed mono fine. Now I want to host a .net4 web application and as I understand it I'll need fastcgi-mono-server4 (and xsp4 when ...
3
votes
2answers
800 views

What's the best server to use with ASP.Net on Mono? [closed]

I am reconfiguring my website from scratch and basically I want it to run Mono(well, ASP.Net inside Mono) According to the Mono Project there appears to be two options, Apache or Nginx. Which one ...
1
vote
1answer
89 views

Best way of updating my (non-critical) website? [closed]

Somehow I couldn't find a related question that quite fit me. Anyway, I run a small blog. When I first started my blog it had next to no traffic, now it receives a couple hundred views per day ...
4
votes
1answer
3k views

Mono 2.11 on nginx using fastcgi-mono-server4 will not work

I have mono 2.11 set up with my nginx 1.0.15 webserver running on centos 6.2. I built it from source and xps2, xps4 and fastcgi-mono-server2 work as expected. The problem is when I try and run ...
1
vote
1answer
379 views

Troubleshooting debian 6 server restarts

A day ago I have installed Mono 2.10 ( for C# 4 support ). Since then server was randomly restarting whenever there is C# app running with no error messages or anything. uname -a Linux ...
-2
votes
1answer
926 views

Install Mono on CentOS 5.5 using Yum

I'm trying to install mono on a CentOS 5.5 machine. I assumed I will be using the OpenSUSE packages (i'm not sure thought, there are other options like Debian and Ubuntu). I created a mono.repo file ...
6
votes
8answers
20k views

Performance of IIS+ASP.NET vs (NGINX + FastCGI + Mono or XSP)?

How much requests each can handle? How many RAM needed? As I remember FastCGI are opened initialized processes, each can handle one request. What about multithreading?
0
votes
1answer
328 views

mod mono consuming lots of memory and cpu in some situations. How to improve this?

I have set up a apache + mod_mono asp.net mvc3 website, and I'm facing some strange problems with it. Some times, for a reason I do not know, the website just stops responding. When this happens, I ...
3
votes
4answers
1k views

Upgrading my debian server to Wheezy just to install mono

I'm looking to use mod-mono-server4 so that I can run .NET 4.0 apps on mono. I'm currently running a debian server with squeeze with this mono version: $ mono --version Mono JIT compiler version ...
1
vote
0answers
157 views

Find counts of ulimit quotas

So, we may have some sort of zainy leak in our software. We're using Mono and spawning many processes over the course of weeks/months. Eventually, we can't spawn anymore on our clients machines. It ...
1
vote
1answer
3k views

Mono through FastCGI on nginx

I'm going through http://www.mono-project.com/FastCGI_Nginx and can't get it to work. The FastCGI server seems to be running. The following is from the error log: upstream sent unexpected FastCGI ...
1
vote
1answer
1k views

Mono undefined reference to `locale_charset'

I am trying to compile mono from source and am getting this error. ../src/.libs/libeglib.a(libeglib_la-gunicode.o): In function monoeg_g_get_charset': /opt/mono-2.10.1/eglib/src/gunicode.c:312: ...
1
vote
2answers
448 views

Clients can make maximum only 15 connections to ubuntu custom server

I have a custom server in C# being run on Ubuntu 9 under mono. I can make up to 15 silverlight clients connect to the server. When I make the 16th, it just waits. And if I close one of the established ...
1
vote
2answers
831 views

Installing Mono on Amazon Linux AMI

I am trying to setup an Amazon EC2 AMI (details) with Mono 2.8.2 on it by following this guide. I've run into a couple of issues with it. Issue One I get a Permission Denied error When I try to do ...
13
votes
5answers
3k views

Where are you going for Mono hosting?

I'm ready to deploy and I want to get my ASP.net web service off of my home development server and out onto the internet. Who would you recommend for good, reliable Mono hosting? Doesn't have to be ...
5
votes
1answer
1k views

Installing mod_mono on Ubuntu: handler doesn't seem to get registered

I'm trying to install mod_mono on Apache 2 (Prefork MPM). I'm using Ubuntu Karmic, and just want an auto-hosting setup (so that any .aspx files are executed, similar to how PHP is normally setup). I ...
0
votes
1answer
479 views

MySql *completely random* Unable to connect

This one is killing me. We have an ASP.NET/Mono application on a MySQL database. For months we've been plagued by a completely random but consistent occurrence of "Unable to connect to any of the ...
0
votes
1answer
518 views

Mod Mono CentOS Install - Dependency: >= httpd 2.2

I've been trying to install Mono on CentOS 5.5 with Cpanel. It was all going fine until I needed to install the mod mono add-on. I get a missing dependency error, any help would be much appreciated ...
0
votes
2answers
619 views

Can mono/xsp with fastcgi handle more then one request?

Right now i am using nginx with mono/xsp through fastcgi. I haven't seen any clear answers but can xsp/fastcgi handle multiple request? I have one instance running all my sites. Would i get better ...
2
votes
1answer
907 views

How to add a new website to a fastcgi-mono-server4 process on nginx without having to restart existing websites?

I know this might be related but I have a script that loads fastcgi-mono-server for defined websites on a configuration file and I need to a new website to the pool without having to reload all ...
0
votes
2answers
862 views

ASP.NET/mono performance on Linux

Anybody knows how asp.net/mono performance is on Linux ? I mean, which server gives you the best performance/delivery time (Apache/Apache2, xsp2, lighthttp, nginx, other) ? Since all asp.net goes ...
0
votes
1answer
117 views

Mono fast cgi not working on nginx

I installed mono fast cgi for nginx following instructions on: http://www.mono-project.com/FastCGI_Nginx but when i try to load test aspx file i getting 502 error gateway,and following error in error ...