-1
votes
1answer
466 views

Ubuntu 14.04, OpenLDAP TLS problems

So i have set up an openldap server using this guide here. It worked fine. But as i want to use sssd i also need TLS to be working for ldap. So i looked into and followed the TLS part of the guide. ...
0
votes
0answers
58 views

Combining CA's into a single PEM

I have been wondering if it is possible to combine two CA certificates into a single .pem, then use that pem to allow clients with certs signed by either CA to create TLS connections with an LDAP ...
1
vote
3answers
6k views

CentOS openLDAP cert trust issues

# LDAPTLS_CACERTDIR=/etc/ssl/certs/ ldapwhoami -x -ZZ -H ldaps://ldap.domain.tld ldap_start_tls: Can't contact LDAP server (-1) additional info: TLS error -8172:Peer's certificate issuer has ...
0
votes
1answer
796 views

gnutls vs openssl with openldap, debian and centos

I have a Debian 6.0.5 server running openldap. It appears to be compiled against gnutls. I used gnutls' certtool to generate a self-signed certificate and I have used it on a few debian client ...
3
votes
1answer
2k views

Setting up a Linux client for OpenLDAP over SSL

I'm trying to set up SSL with a server running OpenLDAP (and using OpenSSL, not GnuTLS). The server seems to be working fine: I can authenticate using ldap:// and can also use ldaps:// from Apache ...
2
votes
1answer
2k views

Configuring OpenLDAP and SSL

I am having trouble trying to connect to a secure OpenLDAP server which I have set up. On running my LDAP client code java -Djavax.net.debug=ssl LDAPConnector I get the following exception trace ...
1
vote
2answers
1k views

Unable to verify SSL certificate issuer for LDAP server

I have just setup SSL on my LDAP server by following this guide - http://www.linux.com/archive/feature/114087 I have made a self signed certificate using openSSL and set it up. When something tries ...
2
votes
2answers
2k views

OpenLDAP SSL error

I did setup an OpenLDAP server with PAM authentication against it. In clear text, it works very well but when I try to add SSL it always faill. I'm following that guide to get it working : ...