0
votes
0answers
141 views

Upgrade OpenSSL to Latest Version

I'm build app ruby on rails but openssl on my server is old. I need upgrade openssl because openssl certificate verfication failed. OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008 Centos 5.8 I have tried ...
0
votes
1answer
495 views

Ruby/Passenger stops working after update to OpenSSL

Someone has run a yum update on the CentOS box (Linux 2.6.28.1-xxxx-std-ipv4-32 #2 SMP Fri Jan 30 09:55:02 UTC 2009 i686 i686 i386 GNU/Linux) that runs a Ruby on Rails app (Redmine) served with ...
1
vote
1answer
1k views

Can't compile CentOS 5, Ruby 1.9.2 and OpenSSL 1.0.0c [closed]

I'm trying to install Ruby 1.9.2 on CentOS 5.5. I get through most of the make process, but when it tries to compile OpenSSL I get an error. Below is the errror outputted: compiling openssl make[1]: ...
2
votes
1answer
4k views

OpenSSL support for Ruby: “Cipher is not a module (TypeError)”

The Problem Our systems admin needed to upgrade the packages on our CentOS 5.4 dev server to match the packages on our production server. The upgrade affected ruby and/or openssl. We run a Ruby on ...