The tag has no wiki summary.

learn more… | top users | synonyms

-1
votes
0answers
11 views

OpenSwan VPN pings but other traffic fails

I'm setting up a VPN server using OpenSwan, to establish site to site VPN. Site A has the OpenSwan server, sitting behind the SOHO router (ports 500 and 4500 forwarded and default route to subnet B ...
0
votes
1answer
776 views

L2TP over IPSec VPN with OpenSwan and XL2TPD can't connect, timeout on Centos 6

I'm setting up LT2p over IPSec on my Centos 6.3 fresh install. I have iptables flushed, permit all. Whenever I try to connect, i get a 'no reply from vpn' and nothi Here's my ipsec.conf file ...
0
votes
0answers
18 views

VPN and router pass-through

I have been having trouble with VPN on my router, so I thought that since it allowed VPN Pass-through, I would set up a VPN server on an Ubuntu box here, and pass through to that. I have set up PPTP, ...
0
votes
1answer
737 views

openswan and xl2tpd tunnel not working?

Since weeks i want to setup l2tp tunnel with xl2tpd and openswan in debian wheezy, the external interface is ppp0 with dynamic ip and the internal interface is eth0 with ip address 192.168.1.1. l2tp ...
1
vote
0answers
33 views

Openswan and sonicwall and encryption parameters

This error leads me to investigate my encryption parameters: 003 "sonicwall" #2: ignoring unknown Vendor ID payload [...] Can some expert please have a look at tell me what is wrong? Sonic wall ...
1
vote
1answer
1k views

Openswan + xl2tpd connections time out after a while

I have a non-NATed Openswan+xl2tpd server (Ubuntu 12.04), to which I connect with a Windows 8 behind NAT. The client loses its connection after a while of doing nothing (between 30 and 60 minutes, but ...
2
votes
1answer
688 views

IKE Phase 1 Aggressive Mode exchange does not complete

I've configured a 3G IP Gateway of mine to connect using IKE Phase 1 Aggressive Mode with PSK to my openswan installation running on Ubuntu server 12.04. I've configured openswan as follows: ...
9
votes
2answers
1k views

Setup VPN issue on Ubuntu Server 12.04

I have a problem with setup VPN server on my Ubuntu VPS, here is my server environments: Ubuntu Server 12.04 x86_64 xl2tpd 1.3.1+dfsg-1 pppd 2.4.5-5ubuntu1 openswan 1:2.6.38-1~precise1 After ...
0
votes
1answer
178 views

Openswan is not sending packets on new ip after DPD

I have configured tunnel with DDNS. After appliance get rebooted the other side is not sending packets on new ip-address (even i have set dpdaction=restart). I am using openswan 2.6.38. Here is my ...
2
votes
0answers
29 views

Openswan bad routing record after connect

I have a problem in openswan configuration. In the routing table create following lines on the client, after connect to server: Dest mask Gateway Conn Metric 0.0.0.0 ...
1
vote
2answers
483 views

xl2tpd[845]: parse_config: line 13: data 'ipsec sared=yes' occurs with no context

When I executed xl2tpd I amhaving following error. # xl2tpd -D xl2tpd[845]: parse_config: line 13: data 'ipsec sared=yes' occurs with no context xl2tpd[845]: init: Unable to load config file When I ...
1
vote
0answers
138 views

OpenSwan + AWS + Ubuntu 14.04 - Cannot reach server

i'm currently trying to set up a VPN in order to login into a private subnet hosted on AWS. The target host has Ubuntu 14.04 and installed OpenSwan. I've setup ipsec.conf, ipsec.secrets, xl2tpd.conf, ...
0
votes
1answer
37 views

xl2tpd doesn't connect and no logs with Openswan

I'm using Openswan and xl2tpd to set up a VPN connection for a Windows computer, everything looks perfectly configured and the IPSec connection is successful : STATE_QUICK_R2: IPsec SA established ...
1
vote
1answer
1k views

How do I configure routing for an IPSEC tunnel between Openswan and RouterOS

I am trying to create a site-to-site VPN between a Linux router that runs openswan and shorewall (host A, serving subnet 10.10.0.0/16) and a MikroTek RouterBoard running RouterOS 6.3 (host B, serving ...
0
votes
0answers
86 views

Openswan sessions hanging with multi user VPN configuration (ipsec/l2tpd)

I've got a linux box running openswan and xl2tpd. It's a simple configuration with multiple users connecting using a sharedKey, and then establishing an L2TP connection with PPPD providing the ...
1
vote
0answers
80 views

Is it possible to do IPSec Site to Site VPN without static & public IP on one end?

I am working on a project for my engineering degree that requires me to interface with some pre-existing equipment, so I am rather limited on my options. I'm rather new to VPN and ipsec for that ...
0
votes
0answers
34 views

Openswan is not restaring

I am configuring new ip-address in configuration file /etc/ipsec.conf & restarting Openswan. But, It struck & not started. Here is my logs: Apr 26 18:02:16 (none) authpriv.warn pluto[11631]: ...
1
vote
1answer
369 views

Openswan Cisco ASA 9.1 — cannot resopnd to IPsec SA request because no connection is known for

Ok, so I have a simple VPN IPSEC setup with a single Linux host that has a public IP address and a loopback interface of 172.16.255.1. On the right side I have a Cisco ASA 5505 9.1. the issue is the ...
0
votes
1answer
131 views

Strongswan with X.509 authentication and LDAP authorization

I would like to setup Strongswan/Libreswan with PKI authentication. Now I have searched and found only how to configure specific accepted client certificates like here: ...
0
votes
0answers
36 views

NO_PROPOSAL_CHOSEN error while connecting

crypto isakmp policy 1 encr 3des authentication pre-share group 2 ! crypto isakmp client configuration group vpn key cse123 pool SDM_POOL_1 acl 100 netmask 255.255.255.0 crypto isakmp ...
0
votes
1answer
8k views

OpenSwan IPSec phase #2 complications

Phase #1 (IKE) succeeds without any problems (verified at the target host). Phase #2 (IPSec), however, is erroneous at some point (apparently due to misconfiguration on localhost). This should be an ...
0
votes
0answers
181 views

OpenSwan VPN Connected but can't ping or connect to anything on right side

On my end is an Ubuntu AWS EC2 VM and on the other end is a Cisco ASA 5500 router. Phase 1 and Phase 2 come up but I cannot access anything on the other end. It would seem there's a routing problem, ...
0
votes
1answer
119 views

L2TP/IPSec Conectivity Problems

We ar traying to establish a VPN to our office. We sucesful configured a debian server using openswan and lx2tpd. We test the conection on the local network, and established a VPN conection with the ...
0
votes
1answer
100 views

L2TP VPN Connection on Debian Squeeze

I need to make an L2TP VPN connection from a Debian Squeeze server. What I have is: The server IP address Shared Key My username and password Just using these 3 parameteres I can establish the ...
0
votes
0answers
94 views

Debugging IPSEC log

A Fortigate unit and a Openswan based Linux server. Tunnel is up but no data goes through. This is the log from the Forti unit: Line 204: ike 0:Brazil_VPN:2803378:19809969: responder received first ...
0
votes
0answers
328 views

openswan multiple subnets routing issue

I am trying to setup an OpenSwan(2.6.32) on CentOS 6.5 (final) to connect the remote VPC gateway on Amazon cloud. I got the tunnel up. However, only the traffic from/to the last ip range defined in ...
1
vote
1answer
155 views

What is the simplest open source Linux VPN software/configuration with Windows Clients?

I used Strong Swan (server/client cert) server before with a Windows 8.1 client base and it was a nightmare to configure (that's an understatement). The documentation was poor. I read books on ...
0
votes
0answers
42 views

Iptables being changed without rebooting

I configured a tunnel between my network and a remote network with OpenSwan. On my tunnel endpoint, running on Ubuntu, I added iptables rules to disable source NAT (SNAT) when the destination was the ...
0
votes
0answers
285 views

iPhone fails to connect to Openswan IPSec

An iPhone client fails to connect to a IPSec VPN powered by Openswan on Debian with xl2tpd and ppp. The iPhone itself keeps telling after some time "Server not responding" and /var/log/auth.log says ...
0
votes
0answers
354 views

Route all traffic through IPSec VPN with ZyWALL USG 100 and OpenSwan

i want to route all traffic from our ZyWALL USG 100 through an IPSec tunnel. I was able to establish a connection from the ZyWALL, but now i have no idea how i can route the traffic through the ...
0
votes
0answers
287 views

l2tp vpn is disconnected after few minutes

I installed IPSec/L2TP on my vps server. I tried to connect from my mac to this VPN server. First time, connection is succeeded. But after a few minutes, connection was broken by itself. After ...
0
votes
0answers
241 views

ignoring informational payload, type INVALID_COOKIE msgid=00000000

I'm configuring a site-to-site vpn between openswan ipsec and cisco asa 5540. After the step, i started ipesc service but the error i'm seeing is: ignoring informational payload, type INVALID_COOKIE ...
1
vote
0answers
124 views

IPsec connection established but xl2tpd times out

This may or may not be related to my problem with passing ipsec verify. I have configured L2TP/IPsec VPN on Ubuntu 13.04 following Ubuntu's community documentation and while IPsec connection seems ...
-1
votes
1answer
34 views

Openswan stopped writing to /var/log/secure after log deletion

I deleted the log intentionally but it seems like Openswan is not creating a new one on it's own. I tried restarting the service or even creating an empty file. Nothing works. What can I do besides ...
1
vote
1answer
4k views

Can't get the L2TP IPSEC up and running

i have an Ubuntu 11.10 (oneiric) server running on a ReadyNAS. Im planning to use this to accept ipsec+l2tp connections through a router. However, the connection is failing somewhere half through. ...
0
votes
0answers
239 views

Cannot establish tunnel with OpenSwan/xl2tpd

I'm trying to set up L2TP/IPSec on Ubuntu as a client so that it can connect to a Check Point VPN appliance. That last point is key because the appliance does impose some restrictions on how ...
0
votes
1answer
2k views

Ipsec config with openswan

I try to configure Ipsec on server with openswan as client. But receive error - possible, it's auth error. What I wrote wrong in config ? Thank you for answers. #1: ...
2
votes
1answer
2k views

Configure ipsec vpn tunnel (network to network with IKE with preshared key) on Centos 6 with openswan

I have Cisco Linksys router configured as VPN gateway (network to network) : Now I wanna configure ipsec VPN similarly on Centos 6 with openswan. I was looking in internet but have no luck (there ...
0
votes
1answer
122 views

Translating IPTables rule to UFW

we are using an Ubuntu 12.04 x64 LTS VPS. Firewall being used is UFW. I have setup a Varnish + LEMP setup. along with other things, including an Openswan IPSEC VPN from our office to the VPS data ...
1
vote
1answer
2k views

FortiGate IPsec VPN: Configuring Multiple Phase 2 Connections (Multiple Subnets)

I am trying to make an IPsec connection to a FortiGate router using OpenSwan. The FortiGate sits on two distinct subnets and I need to access both of them. In the FortiGate I have defined one Phase 1 ...
0
votes
0answers
59 views

VPN Server Doesn't Allow Internet Access

I recently set up a VPN on my local network to test and confirm that I could do it before sending it to my production server on Amazon AWS. It worked perfectly well, and I was satisfied with the ...
2
votes
0answers
214 views

IPSec + L2TP + NAT-Traversal does not work for multiple clients behind same nat

I have recently configured a VPN server hosted in AWS EC2. Details: Centos 6.4, openswan, xl2tpd, NAT-traversal. The configuration works great for a scenario when only one user connects form a given ...
1
vote
2answers
2k views

Openswan tunnel up, but works only in one direction

I've successfully established an IPsec connection, but it works only partially. One side does not send out packets through the tunnel. It seems as if the network topology is unclear to this side. ...
0
votes
0answers
54 views

OpenSwan issuing same IP

So I have finally got the authentication to work, and it will now connect, but when I go to use the connection I can't actually use the network. looking at the connections it seems to be issuing the ...
1
vote
0answers
505 views

L2TP & IPSec (OpenSwan) on Centos time out when connecting

I'm having big trouble setting up a very simple VPN. Using Centos 6. My Server Address : 61.34.26.32 (fictive) Whenever I try to connect (from iPhone5 or MacOS X) i get a connection timeout. I ...
0
votes
1answer
251 views

Openswan does not connect when using sha256 (RHEL 6.2)

I am trying to connect openswan 2.6.16 on two RHEL 6.2 (kernel 2.6.32-220) virtual machines (gateway1 and gateway2) using IKEv2. It all works well and makes tunnel with ESP authentication algorithms ...
0
votes
0answers
1k views

IPSEC Tunnel with OpenSwan on Ubuntu <-> CISCO Router

I have setup a tunnel between a UBUNTU SERVER linux box and a CISCO ROUTER. This is what's the topology looks like: host 1 ------ UBUNTU SERVER IPSEC <---> CISCO ROUTER ------ host 2 | ...
1
vote
1answer
570 views

Openswan tunnel to remote public NAT'd host

Need help on this VPN set-up to work. Left-hand. EC2: eth0:10.0.0.100/EIP=1.1.1.1 (ie. NAT'd IP) eth1:10.0.0.200/EIP=2.2.2.2 Peer ip/leftid: 1.1.1.1 Right-hand. Cisco: Peer ip: 3.3.3.3 ...
2
votes
0answers
2k views

Can't get past “pending Phase 2” on OpenSWAN <-> ISA Server IPSec VPN

The issue I´m having quite a hard time configuring OpenSWAN on my Linux server (Ubuntu 12.04) to connect to an ISA Server 2004 IPSec VPN. There is apparently something wrong in the configuration that ...
3
votes
2answers
6k views

Simple L2TP/IPsec server not working (openswan, xl2tpd, Ubuntu, Windows)

I configured openswan and xl2tpd on an Ubuntu 12.04 server (on EC2) by following various tutorials/documentation which seem to largely say the same things, but most recently this one. However, my ...