DataStax OpsCenter makes it possible to manage Apache Cassandra and DataStax Enterprise clusters from a centralized web-based dashboard.

learn more… | top users | synonyms

-1
votes
0answers
20 views

Http Protocol bug in opscenter 5.0.0 dashboard for Google Chrome after activating HTTPS opscenter 5.0.0 [on hold]

There is http bug after activating ssl in opscenter 5.0.0. error: Mixed Content: The page at 'https':'/locahost:8443''opscenter/index.html' was loaded over HTTPS, but requested an insecure ...
0
votes
1answer
12 views

Change hostname in datastax-agent

I've noticed when working in Opscenter that all the nodes are displayed with the result of hostname and their IP address. For an ec2 host this is a little redundant since the hostnames look like ...
0
votes
1answer
17 views

Agent connected to Opscenter but no data available

I'm currently running Cassandra, the OpsCenter, and the OpsCenter agent all on my dev Windows box. The agent is successfully connected to OpsCenter and I can see it listed there along with the amount ...
0
votes
0answers
22 views

Datastax opscenter 5.0.1: can't create a new cluster

I can't create a new cluster using datastax opscenter 5.0.1 I can add the datastax agent to node on a existing cluster but can't create one (ports are opened, ssh connection OK, sudo works for the ...
0
votes
1answer
35 views

Can't get datastax-agent to run on a new node

I'm trying to install the datastax-agent on a new CentOS node (there are 3 other nodes currently up and running correctly). After installing the datastax-agent via the Opscenter UI it appears to ...
0
votes
1answer
24 views

Multiple data centers and DataStax OpsCenter

Multiple questions regarding DataStax OpsCenter. I am evaluating for our use OpsCenter 5.0.1 I am able to build a cassandra cluster using opscenter sucessfully. However, all nodes belong to one ...
1
vote
1answer
16 views

Datastax Opscenter 5.0: Getting “InvalidGroup.NotFound” when adding node via AWS

I am getting an "InvalidGroup.NotFound" when trying to add an additional node to my cluster through OpsCenter via AWS. The existing node running OpsCenter is in the VPC and is already using the ...
0
votes
1answer
38 views

OpsCenter seems to not read configuration file

I have just installed OpsCenter 5.0, using "DataStax All-in-One Installer" on Linux. I have tried to add authentication by setting the following in /etc/opscenter/opscenterd.conf: [authentication] ...
0
votes
1answer
125 views

Datastax community edition in windows - Error in creating the test cluster

I recently installed Datastax community edition for windows. As per the installation manual, after successful installation, the Ops Center is supposed to open and show the status of the Test Cluster. ...
0
votes
0answers
38 views

Opscenter 5 setup error on adding existing cluster

I've got an existing Cassandra cluster (Datastax Community v2.1, Linux). I've downloaded 2.0.10 on a separate box (Win) just to use Opscenter (v5). I add ('manage') the existing cluster by simply ...
1
vote
1answer
57 views

DataStax OpsCenter 5.0.0 API doesn't increase last_seen when nodes down if DataStax OpsCenter Agent is down, used to work with 3.2.2

I've been using the DataStax OpsCenter (Enterprise) 5.0.0 REST API with DSE 4.5.1 (Cassandra 2.0.9) to query the /$cluster_name/nodes endpoint and see the last_seen field for the number of seconds ...
0
votes
1answer
30 views

OpsCenter 5.0: Unable to get definition for cassandra-yaml for cluster settings

Adding a cluster in OpsCenter 5.0 without problems. As far as I can see, there are no errors in opscenterd.log. However, the web interface doesn't show any nodes. I can see that all XHR calls in the ...
0
votes
1answer
91 views

OpsCenter shows a datacenter as unknown even though the agents are connected

We added a datacenter to our cluster and it is shown as "Unknown DataCenter". The dashboard reports all the agents as connected, and neither the agents logs nor opscenter logs show any error. The ...
-2
votes
1answer
82 views

OpsCenter on AWS: No permission to create /mnt/cassandra/data directory [closed]

Followed the instructions here: http://www.datastax.com/documentation/cassandra/2.0/cassandra/install/installAMILaunch.html Installed OpsCenter on m3.large. When launching an instance, I get this ...
0
votes
1answer
25 views

How to copy perf graphs from one user to another in datastax OpsCenter?

I have lots of perf graphs in datastax OpsCenter under my "admin" user. I've created a new read-only user that i can let anyone in the company use, but how do i copy all the already configured perf ...
-2
votes
1answer
132 views

DataStax OpsCenter - can't connect with agents

I've installed DataStax OpsCenter (Apache Cassandra) and in OpsCenter, there is an error: "0 of 1 agents connected". When I click "fix", enter credentials and try to install nodes, i get error: ...
0
votes
1answer
22 views

Why do I see 3 node rings in the DSE OpsCenter

Simple Newby question. I've booted 3 instances up in EC2, a cassandra, solr and spark node. I thought they would appear as a single clustered ring in the OpsCenter, but they actually appear as 3 ...
0
votes
0answers
183 views

Opscenter is unable to install agents due permission denied to /tmp

O am not able to install agents on 10.0.0.29 IP through opscenter. It says below error. The user is pavan and this user is having sudo access. Opscenter is unable to install the agents and I'm not ...
0
votes
1answer
336 views

Setting-up OpsCenter gives: scp /tmp/.. Permission denied

I'm trying to setup OpsCenter by adding my localhost Cassandra node (for testing). The login credentials I used for SSH has sudo/root rights, nevertheless I get the error: scp: /tmp/tmpXInRfq: ...
0
votes
1answer
134 views

OpsCenter 5.0: No Data on Dashboard Graphs

I have an OpsCenter 5.0 instance running and 10 agents connected. The agents are in 2 regions in AWS, so everything is using external addresses to communication. All the necessary ports are open, ...
0
votes
1answer
38 views

Opscenter 5.0: User management query

I've installed the free tarball version of opscenter and am having problems with the user management aspect of it. I have authentication enabled via: [authentication] enabled = true ...and can ...
0
votes
1answer
274 views

Opscenter 5.0: error when adding cluster, cluster added anyway, no clusters shown

I have a new Opscenter installation. After adding my "existing cluster" to opscenter, I get the following error dialog boxes: Error creating cluster: Cannot read property 'datasource' of undefined ...
0
votes
1answer
50 views

Opscenter 4.1.4: Authentication failing

I'm getting authentication errors when starting the opscenter agents on each of my cassandra (v1.2.5) nodes: INFO [main] 2014-07-23 12:18:03,880 Starting Stomp INFO [main] 2014-07-23 12:18:03,881 SSL ...
0
votes
0answers
92 views

Installation stage failed: Permission denied

I have installed OpsCenter on an AWS instance that uses RHEL. After starting the OpsCenter, I am trying to access the GUI from a windows machine (http:// my.ip:port). This brings up the interface ...
0
votes
0answers
36 views

Replace existing DataStax OpsCenter Installation in EC2

I'm using DataStax OpsCenter v3.2 installed on an EC2 instance. AWS is going to retire the instance, so I set up a new instance, installed OpsCenter, and tried to connect to my cluster. I got the ...
0
votes
1answer
70 views

opscenter build cluster failing on EC2

I'm trying to build a new Cassandra cluster on Amazon EC2 using Opscenter for development use. I have installed Opscenter (v4.1.3) on an EC2 instance using the instructions on ...
0
votes
0answers
51 views

datatstax opscenter v 4.1.2 short-os collection failed

I've installed Datastax opscenter v4.1.2. It was bundled with Datastax Cassandra Community edition version 2.0.8. I'm running these on Windows Server 2008 R2 64-bit. When I open opscenter all ...
-1
votes
1answer
148 views

Opscenter repair service times out. ERROR: Requested range intersects a local range […]

My production cluster had the repair service enabled since april 16th with the default 9 days time to completion and repairs would complete properly. However, since may 22nd, it is being disabled ...
0
votes
2answers
194 views

CentOS: OpsCenter does not see other node's agent

I'm new with Apache Cassandra. I am trying to install a little sample cluster using two CentOS server. I followed the documentation (Tarball installation) and the nodes are up. However, when I go to ...
2
votes
1answer
159 views

Problems gettings datastax-agent (DSE 4.0.2) working with opscenter (4.1.2), IllegalArgumentException

I guess the question is: why isn't this working? I'm a bit stuck because there isn't much in the way of documentation on the agent itself, and the exception (seemingly from Clojure) isn't particularly ...
1
vote
0answers
60 views

DataStax OpsCenter ignoring proxy environment variable

we installed DataStax OpsCenter (v4.1.1) on a Debian 7.4 server. After starting the service, the following error is logged in /var/log/opscenter/opscenterd.log: ERROR: Trying to download ...
0
votes
1answer
17 views

Cassandra Opscenter historical view

I recently upgraded the underlying machines of my Cassandra cluster (In AWS, from "old" to "current" generation hardware). I thought I'd be able to see if this had a performance impact in Opscenter. ...
0
votes
0answers
19 views

OpsCenter API return all null values for os-cpu-* metrics

Invoking the metrics API (e.g., /cluster/metrics/node/os-cpu-idle?start=1397746020&function=average), I get all null values: { "192.168.4.101": { "AVERAGE": [ [ 1397746020, ...
0
votes
0answers
67 views

NullPointerException during datastax agent startup

I installed DSE 4.0 and started the datastax agent and set up a 12-node cluster. When I look in the opscenter console I see 0 nodes connected. I see this exception in the agent log: INFO ...
0
votes
0answers
144 views

In DataStax Community Edition 2.0.6, OpsCenter appears to require OpenSSL for Windows

Until yesterday, I was running the DataStax Cassandra Community Edition 2.0.5 just fine, both with Cassandra 2.0.5 and later with the Apache Cassandra 2.0.6 inserted underneath it. I had to ...
0
votes
0answers
183 views

OpsCenter doesn't display disk space

I've looked through multiple forum posts, I've turned on debug et al, and I still cannot for the life of me figure out why the disk space isn't working. ALL other information is filled--except for ...