DataStax OpsCenter makes it possible to manage Apache Cassandra and DataStax Enterprise clusters from a centralized web-based dashboard.

learn more… | top users | synonyms

1
vote
3answers
3k views

DataStax OpsCenter agent fails to start when Cassandra requires authentication

Problem I can not get OpsCenter get to connect to datastax-agent. It seems that datastax-agent starts and tries to connect to cassandra, fails because it does not know the correct credentials, but it ...
0
votes
1answer
1k views

OpsCenter 5.1 add existing cluster

I have recently removed the old opscenter and installed new opscenter Opscenter 5.1. When I am trying to add existing cluster to opscenter I keep getting error "Error creating cluster: Timeout while ...
0
votes
1answer
149 views

Multiple data centers and DataStax OpsCenter

Multiple questions regarding DataStax OpsCenter. I am evaluating for our use OpsCenter 5.0.1 I am able to build a cassandra cluster using opscenter sucessfully. However, all nodes belong to one ...
0
votes
0answers
16 views

Managing multiple clusters in Opscenter Datastax?

We have 3 clusters in three different environments. wanted to manage all the three clusters from a single opscenter server. 6Dev, 6 QA, 6 non prod clusters and every cluster has multi DC environment ...
0
votes
0answers
50 views

LDAP Cassandra OpsCenter Configuration With AD

I have an OpsCenter that I need to connect to AD. The relevant configuration below: [authentication] enabled = True authentication_method = LDAP audit_pattern = ldaplog [ldap] server_host = ldap....
0
votes
0answers
69 views

OpsCenter 5.1.3 tells agents wrong host IP

When adding new Cassandra nodes to the cluster we also start up the DataStax agent. After some time the agent is shown as not being connected anymore. Whenever we restart the agent the following error ...
0
votes
1answer
437 views

Can't get datastax-agent to run on a new node

I'm trying to install the datastax-agent on a new CentOS node (there are 3 other nodes currently up and running correctly). After installing the datastax-agent via the Opscenter UI it appears to ...
1
vote
0answers
307 views

datastax opscenter Unable to find a matching cluster for node with IP

I'm trying to configure a new OpsCenter 5.2.2 manually to a newly launched and running Cassandra Cluster 2.0.17, so I add a cluster conf file, start the OpsCenter, which then creates the CF OpsCenter, ...
1
vote
1answer
246 views

Change hostname in datastax-agent

I've noticed when working in Opscenter that all the nodes are displayed with the result of hostname and their IP address. For an ec2 host this is a little redundant since the hostnames look like ip-...
0
votes
2answers
369 views

Agent connected to Opscenter but no data available

I'm currently running Cassandra, the OpsCenter, and the OpsCenter agent all on my dev Windows box. The agent is successfully connected to OpsCenter and I can see it listed there along with the amount ...
0
votes
1answer
65 views

Why can't I create nodes on EC2 default network with OpsCenter 5.2.1?

I've had to update our DataStax OpsCenter service from 5.1.3 to 5.2.1 because when I tried to add a new node to our Cassandra Cluster (DSE 4.6.6 on Amazon EC2) it said that "No nodes were available to ...
1
vote
1answer
712 views

Opscenter can not connect to the nodes

Our opscenter can not connect to the nodes, in the logs the next error appears: 2015-08-17 08:56:37+0200 [SNPaware_Cluster] INFO: Nodes with agents that appear to be no longer running: 172.31.7.245, ...
0
votes
1answer
120 views

Datastax Agent 5.1.3 Short os-stats collector failed

after starting datastax agent 5.1.3 on our new servers we are getting following error in the agent.log. ERROR [os-metrics-6] 2015-08-05 13:49:41,565 Short os-stats collector failed java.lang....
1
vote
1answer
130 views

datatstax opscenter v 4.1.2 short-os collection failed

I've installed Datastax opscenter v4.1.2. It was bundled with Datastax Cassandra Community edition version 2.0.8. I'm running these on Windows Server 2008 R2 64-bit. When I open opscenter all ...
1
vote
1answer
751 views

OpsCenter 5.2 cannot connect to multi-dc cluster

We have two data centers (192.X.X.X and 10.X.X.X) between which gossip (port 7001) is possible but not thrift or the native protocol. OpsCenter runs on a node in the first data center (192.X.X.X). ...
0
votes
0answers
99 views

OpsCenter 5.2 still views a keyspace after DROP via cqlsh

After dropping a keyspace via cqlsh we can still see it on OpsCenter. The following error was seen in the log: Error deleting keyspace: ErrorMessage code=2300 [Query invalid because of ...
0
votes
1answer
117 views

Opscenter 5.2 missing data for 1day and 1week graph scale

I recently update Opscenter from 5.1 to 5.2, and yesterday just discovered that if I select different 1day or 1week graph scales no data will be shown in the graph. I checked the logs and the chrome ...
0
votes
0answers
111 views

OpsCenter 5.2.0 - Event log view error: “Undefined name target_node in selection clause”

I've got an upgraded instance from OpsCenter 5.1 to 5.2. When I try to look at the event log, I receive this error in the UI: Error loading events: code=2200 [Invalid query] message="Undefined name ...
0
votes
1answer
123 views

Opscenter not showing disk info

I'm using opscenter 5.1.3 with cassandra 2.1.7 in Ubuntu 14.04 with lvm disks. Opscenter shows all information except disk utilization and storage capacity and keeps saying that it has trouble ...
1
vote
0answers
799 views

OpsCenter - DSE Cassandra - Cannot achieve consistency level LOCAL_ONE

I am running into this error on a OpsCenter node with DSE Cassandra installed locally. It is in it's own DC and part of a cluster with three other nodes in another DC. Authentication is enabled on ...
1
vote
1answer
467 views

Cannot add an existing Cassandra cluster to OpsCenter ('ascii' codec can't encode character)

While trying to add an existing Cassandra cluster to OpsCenter I encountered the following error: Error creating cluster: 'ascii' codec can't encode character u'\u03a7' in position 0: ordinal not ...
3
votes
0answers
50 views

Adding cluster to Opscenter fails intermittently due to Enterprise functionality: False

I am working with a OpsCenter 5.1.1 installation, while trying to add an existing DSE 4.6.5 cluster containing 5 nodes via the API. The options passed set the storage_cassandra variables for storing ...
0
votes
1answer
269 views

OpsCenter 5.1.2 fails to start with SSL enabled on CentOS 5

This applies to OpsCenter 5.1.0 and 5.1.1 as well. I got the following error when trying to run OpsCenter 5.1.2 on a CentOS 5 server: Unhandled Error Traceback (most recent call last): File "/usr/...
1
vote
0answers
76 views

Trouble configuring Opscenter (5.1.1) Email alerts

I was wondering if anyone could assist me in figuring out why my opscenter email alerts aren't working. My environment is docker running in native network mode with opscenter in a container. ...
3
votes
2answers
137 views

opscenter REST API when authentication is enabled

I enabled authentication on my opscenter node as per this . I've a python script that periodically invokes opscenter actions through the Opscenter REST APIs. From the REST API documentation, it looked ...
2
votes
1answer
4k views

datastax-agent Cannot connect Error

Seeing an issue with the Opscenter Agents. Opscenter reports the agents are not connected and in the agent.log on each node, they all report the following: com.datastax.driver.core.exceptions....
-1
votes
1answer
64 views

Cassandra versions supported in OpsCenter 5.1.0

We are planning to use Cassandra 2.0.11 but the latest OpsCenter 5.1.0 doesn't support creating a new cluster with Cassandra 2.0.11 package. It shows only 2.0.9. How do we proceed?
1
vote
1answer
604 views

Opscenter is unable to install agents due permission denied to /tmp

O am not able to install agents on 10.0.0.29 IP through opscenter. It says below error. The user is pavan and this user is having sudo access. Opscenter is unable to install the agents and I'm not ...
1
vote
1answer
1k views

Setting-up OpsCenter gives: scp /tmp/.. Permission denied

I'm trying to setup OpsCenter by adding my localhost Cassandra node (for testing). The login credentials I used for SSH has sudo/root rights, nevertheless I get the error: scp: /tmp/tmpXInRfq: ...
1
vote
1answer
254 views

Datastax OpsCenter 5.1 fails to backup 'All Keyspaces'

We recently upgraded our company servers (Datastax Enterprise 4.5.3) to DSE 4.6.0. The only problem we face with that is the new Backup Service, in which we are unable to create a backup for "All ...
0
votes
1answer
417 views

Datastax opscenter 5.0.1: can't create a new cluster

I can't create a new cluster using datastax opscenter 5.0.1 I can add the datastax agent to node on a existing cluster but can't create one (ports are opened, ssh connection OK, sudo works for the ...
0
votes
1answer
149 views

OpsCenter 5.0.1 - xhrstream HTTP Get request cancelled - 0 of 0 agents connected

Connecting to OpsCenter 5.0.1 on OSX Yosemite on the latest Google Chrome 39.0.2171.99 (64-bit) results in these tcp xhrstreams requests being cancelled and i get a message stating 0 of 0 agents ...
1
vote
0answers
463 views

Repairing OpsCenter rollups60 Results in Snapshot Errors

I am running a 6 node cluster using Apache Cassandra 2.1.2 with DataStax OpsCenter 5.0.2 from the AWS EC2 AMI "DataStax Auto-Clustering AMI 2.5.1-hvm" (DataStax Community AMI). When I try to run a ...
0
votes
0answers
233 views

DataStax OpsCenter Agent Service doesn't report on CentOS, binary works fine

I have OpsCenter 5.0.2 running on a node, and Cassandra 2.1.2 and the Agent 5.0.2 running on another node. I installed both OpsCenter and the Agent using yum/rpm on CentOS 7. I have no problem using ...
0
votes
0answers
1k views

Opscenter is connected to datastax agents but no data available

We installed opscenter and datastax agents on a cluster with private network through datastax community packages. Configurations seems to be ok and we don't have connectivity issues on jmx or stomp. ...
1
vote
1answer
238 views

DataStax OpsCenter ignoring proxy environment variable

we installed DataStax OpsCenter (v4.1.1) on a Debian 7.4 server. After starting the service, the following error is logged in /var/log/opscenter/opscenterd.log: ERROR: Trying to download https://...
0
votes
1answer
1k views

OpsCenter seems to not read configuration file

I have just installed OpsCenter 5.0, using "DataStax All-in-One Installer" on Linux. I have tried to add authentication by setting the following in /etc/opscenter/opscenterd.conf: [authentication] ...
1
vote
1answer
76 views

Datastax Opscenter 5.0: Getting “InvalidGroup.NotFound” when adding node via AWS

I am getting an "InvalidGroup.NotFound" when trying to add an additional node to my cluster through OpsCenter via AWS. The existing node running OpsCenter is in the VPC and is already using the ...
2
votes
1answer
923 views

Datastax community edition in windows - Error in creating the test cluster

I recently installed Datastax community edition for windows. As per the installation manual, after successful installation, the Ops Center is supposed to open and show the status of the Test Cluster. ...
0
votes
0answers
211 views

Opscenter 5 setup error on adding existing cluster

I've got an existing Cassandra cluster (Datastax Community v2.1, Linux). I've downloaded 2.0.10 on a separate box (Win) just to use Opscenter (v5). I add ('manage') the existing cluster by simply ...
1
vote
1answer
176 views

DataStax OpsCenter 5.0.0 API doesn't increase last_seen when nodes down if DataStax OpsCenter Agent is down, used to work with 3.2.2

I've been using the DataStax OpsCenter (Enterprise) 5.0.0 REST API with DSE 4.5.1 (Cassandra 2.0.9) to query the /$cluster_name/nodes endpoint and see the last_seen field for the number of seconds ...
0
votes
1answer
69 views

OpsCenter 5.0: Unable to get definition for cassandra-yaml for cluster settings

Adding a cluster in OpsCenter 5.0 without problems. As far as I can see, there are no errors in opscenterd.log. However, the web interface doesn't show any nodes. I can see that all XHR calls in the ...
-2
votes
1answer
350 views

OpsCenter on AWS: No permission to create /mnt/cassandra/data directory [closed]

Followed the instructions here: http://www.datastax.com/documentation/cassandra/2.0/cassandra/install/installAMILaunch.html Installed OpsCenter on m3.large. When launching an instance, I get this ...
0
votes
1answer
604 views

OpsCenter shows a datacenter as unknown even though the agents are connected

We added a datacenter to our cluster and it is shown as "Unknown DataCenter". The dashboard reports all the agents as connected, and neither the agents logs nor opscenter logs show any error. The ...
0
votes
1answer
44 views

How to copy perf graphs from one user to another in datastax OpsCenter?

I have lots of perf graphs in datastax OpsCenter under my "admin" user. I've created a new read-only user that i can let anyone in the company use, but how do i copy all the already configured perf ...
0
votes
2answers
621 views

CentOS: OpsCenter does not see other node's agent

I'm new with Apache Cassandra. I am trying to install a little sample cluster using two CentOS server. I followed the documentation (Tarball installation) and the nodes are up. However, when I go to ...
-2
votes
1answer
650 views

DataStax OpsCenter - can't connect with agents

I've installed DataStax OpsCenter (Apache Cassandra) and in OpsCenter, there is an error: "0 of 1 agents connected". When I click "fix", enter credentials and try to install nodes, i get error: ...
0
votes
1answer
46 views

Why do I see 3 node rings in the DSE OpsCenter

Simple Newby question. I've booted 3 instances up in EC2, a cassandra, solr and spark node. I thought they would appear as a single clustered ring in the OpsCenter, but they actually appear as 3 ...
0
votes
1answer
1k views

OpsCenter 5.0: No Data on Dashboard Graphs

I have an OpsCenter 5.0 instance running and 10 agents connected. The agents are in 2 regions in AWS, so everything is using external addresses to communication. All the necessary ports are open, ...
1
vote
1answer
735 views

Opscenter 5.0: error when adding cluster, cluster added anyway, no clusters shown

I have a new Opscenter installation. After adding my "existing cluster" to opscenter, I get the following error dialog boxes: Error creating cluster: Cannot read property 'datasource' of undefined ...