DataStax OpsCenter makes it possible to manage Apache Cassandra and DataStax Enterprise clusters from a centralized web-based dashboard.

learn more… | top users | synonyms

2
votes
1answer
173 views

Problems gettings datastax-agent (DSE 4.0.2) working with opscenter (4.1.2), IllegalArgumentException

I guess the question is: why isn't this working? I'm a bit stuck because there isn't much in the way of documentation on the agent itself, and the exception (seemingly from Clojure) isn't particularly ...
1
vote
1answer
177 views

Datastax community edition in windows - Error in creating the test cluster

I recently installed Datastax community edition for windows. As per the installation manual, after successful installation, the Ops Center is supposed to open and show the status of the Test Cluster. ...
1
vote
1answer
69 views

DataStax OpsCenter 5.0.0 API doesn't increase last_seen when nodes down if DataStax OpsCenter Agent is down, used to work with 3.2.2

I've been using the DataStax OpsCenter (Enterprise) 5.0.0 REST API with DSE 4.5.1 (Cassandra 2.0.9) to query the /$cluster_name/nodes endpoint and see the last_seen field for the number of seconds ...
1
vote
1answer
71 views

DataStax OpsCenter ignoring proxy environment variable

we installed DataStax OpsCenter (v4.1.1) on a Debian 7.4 server. After starting the service, the following error is logged in /var/log/opscenter/opscenterd.log: ERROR: Trying to download ...
0
votes
1answer
21 views

Change hostname in datastax-agent

I've noticed when working in Opscenter that all the nodes are displayed with the result of hostname and their IP address. For an ec2 host this is a little redundant since the hostnames look like ...
0
votes
1answer
45 views

Can't get datastax-agent to run on a new node

I'm trying to install the datastax-agent on a new CentOS node (there are 3 other nodes currently up and running correctly). After installing the datastax-agent via the Opscenter UI it appears to ...
0
votes
1answer
103 views

OpsCenter shows a datacenter as unknown even though the agents are connected

We added a datacenter to our cluster and it is shown as "Unknown DataCenter". The dashboard reports all the agents as connected, and neither the agents logs nor opscenter logs show any error. The ...
0
votes
1answer
77 views

opscenter build cluster failing on EC2

I'm trying to build a new Cassandra cluster on Amazon EC2 using Opscenter for development use. I have installed Opscenter (v4.1.3) on an EC2 instance using the instructions on ...
0
votes
1answer
18 views

Cassandra Opscenter historical view

I recently upgraded the underlying machines of my Cassandra cluster (In AWS, from "old" to "current" generation hardware). I thought I'd be able to see if this had a performance impact in Opscenter. ...
-2
votes
1answer
159 views

DataStax OpsCenter - can't connect with agents

I've installed DataStax OpsCenter (Apache Cassandra) and in OpsCenter, there is an error: "0 of 1 agents connected". When I click "fix", enter credentials and try to install nodes, i get error: ...
0
votes
0answers
15 views

Opscenter is connected to datastax agents but no data available

We installed opscenter and datastax agents on a cluster with private network through datastax community packages. Configurations seems to be ok and we don't have connectivity issues on jmx or stomp. ...
0
votes
0answers
47 views

Datastax opscenter 5.0.1: can't create a new cluster

I can't create a new cluster using datastax opscenter 5.0.1 I can add the datastax agent to node on a existing cluster but can't create one (ports are opened, ssh connection OK, sudo works for the ...
0
votes
0answers
46 views

Opscenter 5 setup error on adding existing cluster

I've got an existing Cassandra cluster (Datastax Community v2.1, Linux). I've downloaded 2.0.10 on a separate box (Win) just to use Opscenter (v5). I add ('manage') the existing cluster by simply ...
0
votes
0answers
216 views

Opscenter is unable to install agents due permission denied to /tmp

O am not able to install agents on 10.0.0.29 IP through opscenter. It says below error. The user is pavan and this user is having sudo access. Opscenter is unable to install the agents and I'm not ...
0
votes
0answers
100 views

Installation stage failed: Permission denied

I have installed OpsCenter on an AWS instance that uses RHEL. After starting the OpsCenter, I am trying to access the GUI from a windows machine (http:// my.ip:port). This brings up the interface ...
0
votes
0answers
38 views

Replace existing DataStax OpsCenter Installation in EC2

I'm using DataStax OpsCenter v3.2 installed on an EC2 instance. AWS is going to retire the instance, so I set up a new instance, installed OpsCenter, and tried to connect to my cluster. I got the ...
0
votes
0answers
56 views

datatstax opscenter v 4.1.2 short-os collection failed

I've installed Datastax opscenter v4.1.2. It was bundled with Datastax Cassandra Community edition version 2.0.8. I'm running these on Windows Server 2008 R2 64-bit. When I open opscenter all ...
0
votes
0answers
21 views

OpsCenter API return all null values for os-cpu-* metrics

Invoking the metrics API (e.g., /cluster/metrics/node/os-cpu-idle?start=1397746020&function=average), I get all null values: { "192.168.4.101": { "AVERAGE": [ [ 1397746020, ...
0
votes
0answers
72 views

NullPointerException during datastax agent startup

I installed DSE 4.0 and started the datastax agent and set up a 12-node cluster. When I look in the opscenter console I see 0 nodes connected. I see this exception in the agent log: INFO ...
0
votes
0answers
153 views

In DataStax Community Edition 2.0.6, OpsCenter appears to require OpenSSL for Windows

Until yesterday, I was running the DataStax Cassandra Community Edition 2.0.5 just fine, both with Cassandra 2.0.5 and later with the Apache Cassandra 2.0.6 inserted underneath it. I had to ...
0
votes
0answers
196 views

OpsCenter doesn't display disk space

I've looked through multiple forum posts, I've turned on debug et al, and I still cannot for the life of me figure out why the disk space isn't working. ALL other information is filled--except for ...
-2
votes
0answers
13 views

0 of 0 agents connected when accessing through windows

I've got a very weird error when accessing to Opscenter. Everything works fine when I'm connecting from one machine with Linux-Ubuntu ("All agents connected"). But at the same time, when I'm ...