0
votes
0answers
53 views

Apt-get install removed packages

During a puppet run, ia32-libs was installed, this seems to have caused several packages to be uninstalled but I'm not sure why.. Can anyone shine any light on the matter? Here's the apt log entry: ...
0
votes
1answer
26 views

Renaming debian package

I'm trying to build a customized version of a nginx package for Debian/Ubuntu which had a different set of modules opposed to the default version. What would be the fastest way to modify the debian/ ...
1
vote
1answer
300 views

How can I get APT to “ignore” a package?

I am running a VPS using Debian unstable with this kernel version: 2.6.32-274.7.1.el5.028stab095.1 I just upgraded my packages and for some odd reason APT wants me to install ...
0
votes
3answers
572 views

DEB: “Provides:” field ignored

I need to replace a package with a custom one, which gets its own name (foo-origpackage). To allow it to be used as drop-in replacement, I added the Provides: origpackage line to the control file. ...
0
votes
1answer
783 views

apt-get install doesn't get the package

I've installed ubuntu server on a VirtualBox virtual machine and now I'm trying to follow a tutorial that says I need to install a package called csh. When I type this line sudo apt-get install csh ...
1
vote
1answer
30 views

How to safely and smoothly update packages on server?(by apt)

On my own computer, I have been used to run apt-get upgrade directly for years. But few days ago I have a chance to admin a ubuntu server. I guess my old habit is bad. Should/how I update security ...
2
votes
1answer
8k views

How to force debian linux apt-get installer to install unstable/specific version of packages?

I want to force the install system on debian linux, apt-get, to install unstable (i.e. a later version) of a package, later than the stable one recognised by the debian package maintainer. This ...