The tag has no usage guidance.

learn more… | top users | synonyms

0
votes
2answers
43 views

Blacklisted client: why did Postfix not reject this email?

Answer The best answer was on the postfix-users mailing list and it is summarized here for the benefit of serverfault's users. I had forgotten soft_bounce = yes. Always switch it back to no after ...
0
votes
0answers
100 views

clamav installation with pcre in Amazon Linux

When we install ClamAV in our Amazon Linux ElasticBeanstalk instance with yum install clamav it gets installed without PCRE support, although the libraries are present in the instance. LibClamAV ...
0
votes
1answer
45 views

rewrite nginx not capture optional value

I'm migrating a configuration to a new CMS and there are urls with the structure in the current page "/view-article/ID", some shortening of links added parameters to the end as "/view-article/ID/{...
0
votes
1answer
407 views

util_pcre.c:104: undefined reference to `pcre_free' while compiling Apache HTTPD 2.4.17. collect2: error: ld returned 1 exit status

On a new EC2, I am facing one type of problem while compiling httpd. It seems like code of Apache cannot find functions / function definitions from libraries. Steps I took on a fresh RHEL to install ...
1
vote
1answer
86 views

dict_pcre.so missing on debian

I've installed postfix as I normally do, using apt-get install postfix, but for some reason it's not including dict_pcre.so in the install. Is there something I've overlooked, or rather how and where ...
0
votes
1answer
958 views

Varnish installer cannot find PCRE when it is already installed

I am trying to install Varnish-Cache 4 on my Mac OS X 10.9.3. But I get this error: checking for PCRE... no configure: error: Package requirements (libpcre) were not met: No package 'libpcre' found ...
0
votes
1answer
497 views

Postfix regex for smtpd_command_filter

Some of my users are using Gmail to send mail to our domain (The mail server for which is hosted on a CentOS 5 machine with postfix). Sometimes, but not all the time, when they do, they get a ...
2
votes
1answer
42 views

postfix HOLD Recieved non authenticated

i'm wondering if is possibile to put on hold emails that not have authenticated in Recieved header . i've tryed with a simple negate operazione with pcre !/^Received:.*Authenticated*/ HOLD but don'...
0
votes
1answer
2k views

postfix pcre conditional REPLACE

I need to modify the "From:" header line in incoming e-mail messages only if "Message-Id:" starts with a defined string. So in main.cf I put: header_checks = pcre:/etc/postfix/header_checks and ...
1
vote
1answer
3k views

pcregrep is not matching regex (multiline?)

I don't understand why is first two is a match/hit, yet third is a miss? -bash-3.2# cat 1361492805.M171838P41834.mx1.alexus.biz\,S\=12921\:2\,Sijm | pcregrep -q '.*languager.*' ; echo $? 0 -bash-3.2# ...
1
vote
4answers
672 views

greping multiple lines from MySql binlog

I have binlog from MySQL and I need to output certain time frame into a seperate file, how would I do that? here is sample of what binlog file contains: # at 460 #130120 0:09:17 server id 1 ...
0
votes
4answers
862 views

how to fix “Package pcre-6.6-6.el5_6.1.x86_64 already installed and latest version” alert need to update it to pcre-8.31?

Goodafternoon, I am trying to update my pcre-6.6-6.el5_6.1.x86_64 package to pcre-8.31 following is my steps to do so: Step 1: cd /etc/yum.repos.d Made repository utter-ramblings.repo in it. ...
1
vote
3answers
2k views

Postfix: postmap error with pcre

I am using postfix-pcre on debian linux. When I run postmap /etc/postfix/smtp_header_checks.pcre and postmap pcre:/etc/postfix/smtp_header_checks.pcre, I get the following error: postmap: warning: ...
8
votes
1answer
5k views

What are PCRE limits?

In ModSecurity there are PCRE limits exceeded errors. I know I can fix this by setting rules such as: SecPcreMatchLimit 150000 SecPcreMatchLimitRecursion 150000 But, what are these rules actually ...
-1
votes
1answer
692 views

How do I recompile apache in CentOS? [closed]

I need to recompile apache with an external PCRE library. Any help would be much appreciated. Thanks.
0
votes
2answers
5k views

Postfix, sender_bcc - send copy on multiple adress

I have sender_bcc_maps = pcre:/etc/postfix/conf/sender_bcc in my postfix in this file I have rules such as /foo@bar.tld/ bcchere@bar.tld Now i need to send blind copy to more than one email. ...
10
votes
2answers
12k views

mod_security - PCRE limits exceeded

Just about on every request I am getting the following error: Rule execution error - PCRE limits exceeded (-8): (null). After a bunch of googling the only solutions seem to be a) Add the following ...
0
votes
1answer
886 views

using regex “\.php$” requires PCRE library in nginx.conf

I noticed while make install nginx, it told me PCRE is not available. I installed PCRE: yum install -y pcre When I restarted nginx, it shows this error: using regex ".php$" requires PCRE ...
0
votes
1answer
1k views

Nginx can't find PCRE library on Ubuntu Server

I have been trying to get my Passenger and Nginx setup to work with php files but I am having problems with the PCRE regular expressions library. Install all went fine so I'm assuming it found the ...
0
votes
1answer
911 views

Using PCRE 8.20 with Nginx 1.0.11 and Passenger

I downloaded and extracted the nginx source to ~/nginx-1.0.11, then downloaded PCRE 8.20 directly since the latest version of the Passenger installer can't download it automatically. I did the typical ...
0
votes
1answer
312 views

CentOS 5.0 PCRE Unicode properties support solution

I am getting the output of "pcretest -C" UTF-8 support **No Unicode properties support** Newline character is LF Internal link size = 2 POSIX malloc threshold = 10 Default match limit = ...
3
votes
2answers
11k views

Fixing Shared PCRE Library on CentOS

This is less a question about PCRE, and more a question about updating shared libraries. The distribution of CentOS I'm running only allows for yum upgrades to version 6.6, or somewhere similar. I'm ...
4
votes
1answer
2k views

How to get pcre 8.x on Ubuntu 10.04 (Linode)

I'm trying to set up Bug Genie 3.x on my Linode server, and it is complaining because I have pcre 7.8 instead of 8.x. Doing an apt-get update and upgrade doesn't help and says that I have the latest ...
2
votes
2answers
19k views

PECL install/phpize error

This is my PHP setup ################################################################## # setup PHP ################################################################## # we use this to make inline ...
6
votes
2answers
778 views
0
votes
2answers
6k views

nginx folder redirect

I'm trying redirect from an exact folder in nginx.conf Given the URL: domain.com/path1/path2/path3 Redirect to: sub.domain.com/path1/path2/path3 Here's what I have so far: location ~* ^/path1[\/?]$...
3
votes
3answers
1k views

PHP Kohana CentOS 5

Trying to deploy a Kohana based project in CentOS 5. Installed PHP 5.3.1 but still getting the following error. Warning: preg_match() [function.preg-match]: Compilation failed: this version of PCRE ...
1
vote
1answer
1k views

PCRE isn't UTF8 enabled

I am attempting to run a regex on my site, and I am getting this response: Compilation failed: support for \P, \p, and \X has not been compiled at offset 1 After googling for a bit, I've ...