PHP Data Objects (PDO) defines a lightweight and consistent interface for accessing databases.

learn more… | top users | synonyms

1
vote
1answer
789 views

Can't get php+sqlite working

I'm struggling all morning to make php work with an sqlite database. Here is a piece of php code that I try to execute: #less /var/www/html/test.php <?php $db=new ...
0
votes
1answer
406 views

pdo_mysql installation

On my server I'm trying to instal PHProjekt (6). This requires pdo_mysql however. I thought this installation of pdo_mysql would be rather straightforward... I tried using pecl (pecl install ...
0
votes
1answer
465 views

IIS + PHP Data Objects + MS SQL?

We're migrating an LAOP server to Win 2k8 IIS7 MSSQL and PHP (WIMP?) at work, and I'm using the opportunity to clean up the PHP. Currently it doesn't use PDO, and I'd like to rewrite the PHP to use ...
2
votes
2answers
489 views

Why do I get a PHP 5.2.6 segmentation fault when using PDO_SQlite?

This is an installation on ModWest's shared hosting. I have enabled both PDO and PDO_sqlite on the server and phpinfo() verifies both are running. When I access PDO itself, I'm fine, and getting a ...
1
vote
2answers
22k views

PDO Disabled in PHP… how to enable it?

Sorry I'm still a bit of a novice with dedicated hosting. Anyway, we have a dedicated server running cPanel and WHM. I have full terminal access and all that. Basically I've tried to install Chive to ...
2
votes
1answer
6k views

How to install PostgreSQL extension for PDO in Linux?

I have the VPS. I can build my PHP version using Easy Apache. I can find the option for PDO support for MySQL, SQLite. But I don't have any option of PDO pgsql driver. How can I enable that? It says ...
1
vote
4answers
3k views

getting PHP PDO flavors to work on Mac OS X

I'm running OS X 10.5; it looks like it came with Apache and PHP installed (minus some minor configurations which I turned on per this page; I've used Apache before so I know the basics of how ...
0
votes
1answer
999 views

Compiling PHP 5.1.6 with PDO MySQL

UPDATE I Asked this over on StackOverflow as I hadn't got any answers on here at the time. Here's the link to the answers for completeness' sake. I'll like that page back over here once I've tried ...
0
votes
1answer
1k views

Apache won't restart with PDO MySQL enabled

I attempted to install the PDO MySQL driver onto a server with Solaris using the following commands: $ pecl download pdo_mysql $ tar xzf PDO_MYSQL-1.0.2.tgz $ cd PDO_MYSQL-1.0.2 $ phpize $ ...
3
votes
1answer
417 views

PDO_mysql for mac

Has anybody gotten PDO_mysql working on the default PHP installation on a mac? It works with MAMP but that's inconvenient. I'm developing for Zend Framework and mysql, and Zend_db uses PDO. The ...
14
votes
5answers
20k views

How do I tell Apache which PHP to use?

I am running Apache2 on a Mac OS X (10.5). I just compiled PHP 5.2.8 and finally got pdo-mysql working (or so I think). My command line "php --version" is showing 5.2.8 and I have the right modules ...