PEAR is the PHP Extension and Application Repository.

learn more… | top users | synonyms

0
votes
1answer
13 views

Install PHP PEAR on Windows non-interactively specifying target install directory

I want to install PHP PEAR on Windows non-interactively. If I just download http://pear.php.net/install-pear-nozlib.phar and run it like this: php install-pear-nozlib.phar It gets installed into ...
0
votes
0answers
14 views

how to install an older version of a pecl package

I have this code $passengerId = new \MongoId(oPassenger->getId()); return $this->createQueryBuilder('Device') ->update() ->multiple(true) ...
0
votes
2answers
72 views

Why would IIS use two different PHP installs?

I've inherited this Windows Server 2008 server that we use as our primary web server and have lately been running into some oddities. Previously, PHP was installed by just downloading a zip file, ...
2
votes
2answers
970 views

PECL command produces long list of errors

Currently running PHP 5.4 on CentOS 6.5. I installed the webtatic php55w package then installed PEAR+PECL without issue along with redis and mongo through PECL. Shortly after, I realized 5.5 is not ...
0
votes
1answer
654 views

Cannot install PEAR on Centos 6.5 and PHP 5.5

This is driving me nuts already and there's no information about this whatsoever in Google, only 2006 posts, but they don't really help me. I have CentOS 6.5 freshly updated, PHP 5.5, MySQL, Apache, ...
0
votes
3answers
2k views

Error - Unable to find `dot` command of the GraphViz package

Ubuntu precise (12.04.1 LTS) I'm rather new to PEAR. I installed PEAR. Then, using pear I installed phpdoc. It seems to be working great except for the graphing functions. I ran this command: ...
0
votes
1answer
181 views

Invalid package provider 'pear'

I'm creating a manifest to install LAMP on a CentOS 6 machine. Everything works except for installing some pear modules. When issuing puppet /etc/puppet/modules/webserver/manifests/init.pp I get the ...
0
votes
1answer
563 views

mod_fcgid: stderr: PHP Fatal error with Plesk 11.5.30 and php-pear

Just upgraded to Plesk 11.5.30 and found out that sending SMTP emails with php pear aren't working anymore with following error message: mod_fcgid: stderr: PHP Fatal error: require_once(): Failed ...
0
votes
1answer
74 views

Installing pear package debian squees

I try to install the php pear package on my debian server but I got the follow error ouput. :~# sudo apt-get install php-pear Reading package lists... Done Building dependency tree Reading ...
0
votes
1answer
933 views

Installing PHPUnit with PEAR on CentOS

I'm trying to install PHPUnit on my linux box running CentOS 5.8 and I'm getting a heap of problems. I'm running PHP version 5.4.12 (Remi install). The odd thing to note first is that I have what ...
0
votes
2answers
1k views

Horde webmail install - 'webmail-install not found'

I'm trying to install Horde Webmail on my Debian server, but I got stuck on error. I followed manual on http://www.horde.org/apps/webmail/docs/INSTALL. After installing through pear, I'm supposed to ...
0
votes
1answer
289 views

how to connect to postfix using php pear mail smtp class

I have the following script: <?php include('Mail.php'); include('Mail/mime.php'); $recip = "me <me@yahoo.com>"; $strSubject = "test subject"; $strMessage = "test message"; $crlf = "\n"; ...
1
vote
1answer
700 views

Install pecl extension on ubuntu after upgrading to php 5.4

I had php 5.3 installed and upgrade to 5.4 using this PPA https://launchpad.net/~ondrej/+archive/php5 - everything went smoothly. My old pecl extensions, such as oauth, wern't enabled, so I ...
1
vote
1answer
327 views

Can't connect to pear.php.net

If I try anything with PEAR, I get: # pear list-all Connection to `pear.php.net:80' failed: Connection timed out If I ping it, I get the following: # ping pear.php.net PING euk1.php.net ...
1
vote
0answers
91 views

PEAR errors - The Procedure entry point mysql_server_end could not be located in the dynamic library link LIBMYSQL.dll

I recently made the switch to a new server (Windows Server 2008, PLESK) and have realized that my includes in php do not work. I've installed PEAR using command line and ensured that php.ini refers ...
1
vote
1answer
83 views

Media Temple GS Problems Including Custom Pear Packages

I have PEAR setup and custom packages installed under the directory /home/######/data/pear/php I can ssh in and confirm the files are there, however I can not include them in my application as such ...
2
votes
1answer
979 views

Change pecl's temp directory? (installation issue)

I am trying to install imagick on a VPS running Centos 5.8. Typically, it's a quick fix, but the hosting provider will not allow (permission is already denied) me to use the typical fix, which is to ...
0
votes
0answers
159 views

pear install asking questions / auto accept defaults?

I need to install several Pear packages and one Pecl package in a bash script that configures an ubuntu server. One of the packages asks several questions, each of which has a default response if you ...
1
vote
3answers
902 views

1&1 Dedicated Linux Server w/ Plesk 10 - How to add PEAR without breaking?

I have a 1&1 Dedicated server, running Linux and I use Plesk 10 to administrate (although I do have root access). It appears to have been configured --without-pear - but I would like to add it ...
1
vote
0answers
420 views

Configure PEAR on CentOS 6 and PLESK

I'm hoping to get a little assistance with configuring PEAR to work properly. I have a PHP file that's calling PEAR's mail and mail-mime files, and I believe I am missing some steps because I keep ...
1
vote
2answers
1k views

Should one use “From”, “Reply-To” or both headers to reflect their client's email address when sending an email to yourself from a “Contact Us” page?

I have written a website that uses the PHP Pear Mail function to send a few email messages. Mainly to people who have lost their password and to me when somebody submits the "contact us" form. My ...
0
votes
1answer
963 views

Install PEAR Mail/Mime Dependency issues in pure EPEL installation

Newbie in the sysadm area. Using Centos 6.2. I am trying to install PEAR's Mime.php. I have successfully installed PEAR's Mail before. It's not going to well now for Mime.php. This is what I do: ...
2
votes
0answers
623 views

PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/json.so' undefined symbol: ZVAL_DELREF [duplicate]

I have an issue where I am unable to use JSON, which would appear to be because of the following error. There is another thread on this forum this touches on a similar issue, but it's not quite the ...
1
vote
1answer
926 views

How many emails per second is too fast?

I have a growing online business and a dedicated server that I use to send out the occasional newsletter. As it grows past a few thousand customers, I wonder how I can send emails faster without being ...
0
votes
2answers
1k views

How to use only Chef's “php_pear” provider from “php” cookbook

When using Vagrant (and subsequently Chef), I'm provisioning my VM using Zend Server CE, which automatically installs the usually *AMP stack. I'd like to install some packages via PEAR, for which the ...
0
votes
1answer
1k views

Installing xdiff locally with Apache + PHP [closed]

I'm trying to get the xdiff library for PHP installed on my localhost so that I can do some testing with it. My set up is PHP 5.3 + Apache + Mac OS X. Unfortunately, there is no macports port for ...
0
votes
1answer
553 views

Uninstall Dependant Pear Packages

How do I uninstall these pear packages when they depend each other? sh-3.2# ./pear uninstall saucelabs/PHPUnit_Selenium saucelabs/PHPUnit_Selenium (version >= 1.1.6) is required by installed ...
0
votes
1answer
492 views

Errors while installing php extenssion

I'm trying to install apc php extension for php 5.3.3 using the command pecl install apc but I get the following errors. I'm far from being server guru but as far as I can figure out this must be a ...
1
vote
2answers
365 views

How to install Text_Highlighter PEAR package?

I've tried a lot of possible solutions but no one helped: pear install Text_Highlighter Failed to download pear/Text_Highlighter within preferred state "stable", latest release is version 0.7.2, ...
1
vote
2answers
5k views

Installing PECL package on Ubuntu — cannot find config.m4

I've got a new Ubuntu installation set up and running, it servers PHP pages on Apache, everything works normally. I'm trying to install a PHP-PEAR package called SCA_SDO, there's an issue with some ...
1
vote
1answer
523 views

Compiling mysqlnd_uh plugin

I'm attempting to implement a mysql logger similar to what is described in the following article using the mysqlnd_uh extension. ...
1
vote
2answers
852 views

php go-pear.phar on Debian Testing does nothing

I have a fairly fresh Debian Testing install, and I am trying to install PEAR / PECL but when I run the command nothing happens. I don't want to install the PEAR package in the Debian repositories ...
1
vote
0answers
664 views

Trying to install PEAR (running go-pear batch file) - getting “php_pdo.dll is missing” error

I need PEAR installed. So, I tried running the go-pear batch file inside by PHP extract. But it gives this error - The program can't start because php_pdo.dll is missing from your computer. Try ...
3
votes
2answers
303 views

How to manage dependencies on PEAR packages

It seems to me that PEAR is picking up steam again, at least as a distribution mechanism. With the availability of simple PEAR channel servers that are actually simple (e.g. Pirum) it seems many ...
1
vote
1answer
923 views

How to make Horde connect to mysql with UTF-8 character set?

How to tell horde 3.3.11 to use UTF-8 for it's mysql connection? The $conf['sql']['charset'] only tells horde what is expected from the database. Horde uses MDB2 to connect to mysql. Is there way to ...
0
votes
2answers
220 views

PEAR_Installer_Role_Pear_Installer_role_doc error

I try to install imagick in mint 9 (lxde) and there is error nerkn@nerkn-laptop ~/siil $ sudo pecl install imagick downloading imagick-3.0.1.tgz ... Starting to download imagick-3.0.1.tgz (93,920 ...
2
votes
2answers
375 views

error installing php-pear on Debian Lenny

[ps]$ sudo apt-get install php-pear Reading package lists... Done Building dependency tree Reading state information... Done The following NEW packages will be installed: php-pear 0 upgraded, 1 ...
0
votes
1answer
647 views

SMTP implementation on EC2 using Pear Mail package (PHP)

I am working on sending out SMTP relay email's using Gmail as my server using Pear Mail package in PHP. I have installed Pear package using YUM. Also I have located the path for pear_dir and included ...
2
votes
1answer
4k views

Find path where PEAR library is installed to place in php.ini?

How can I find the path where a PEAR library is installed to correct it in php.ini?
1
vote
1answer
103 views

Issue when moving from Apache to Lighttpd

This might not be the right place, but we think its narrowed down to a Lighttpd config issue on our end, just cannot pinpoint. Asked in Virtuemart and Lighttpd forums with no luck. We have a live ...
1
vote
1answer
496 views

Can't install PHPUnit using PEAR on Linux

I'm trying to install PHPUnit on my system using pear. after discovering and updating the channel, when I try to install PHPUnit using the following command: sudo pear install phpunit/PHPUnit I get ...
0
votes
1answer
589 views

error_reporting showing unwanted NOTICE logs

I am getting following notices in php errorlog file. [10-Mar-2011 13:58:39] PHP Notice: require_once() [<a href='function.require-once'>function.require-once</a>]: 1. ...
1
vote
1answer
392 views

Centos 5.5 install PearDB

Disclaimer: I use Linux for some jobs but I am not a Linux admin. I have a Centos 5.4 machine which performs some server duties and doubles as a web site development machine. PHP 5.3.3 was installed ...
0
votes
1answer
364 views

PEAR Mail Queue Database Explaination

I recently set up a mail queue server to help with an issue sending a newsletter to 600+ recipients, which though untested at that volume, it should do the job... hopefully. However during testing I ...
1
vote
1answer
767 views

Having trouble installing PHPUnit with PEAR Installer (Windows)

I am trying to install phpunit/PHPUnit. I get something like below, I think the problem is that Archive/Tar.php is not found? I tried using the --alldeps switch and got the same error. Trying to ...
0
votes
1answer
119 views

PEAR MDB2 is slow. Can anything be done for it?

I am using PEAR MDB2 on a high load server. Trying to optimize things, I benchmarked (I know I should have done benchmarking way long ago :() and found that only to include the MDB2 files, takes ...
0
votes
1answer
408 views

Pear broken after PHP downgrade

I downgraded PHP from 5.3 to 5.2 by doing something similar to mrkandy's script Everything works fine except pear. pear list shows the pear packages I installed before the downgrade and they all work. ...
7
votes
4answers
4k views

Upgrading PEAR from 1.9.0 to 1.9.1 fails

I'm willing to install phpunit 5.3 with MAMP 1.9 and there for I need to upgrade PEAR to version 1.9.1. The current version installed is 1.9.0. When I try the to upgrade I get the following: sudo ...
4
votes
2answers
2k views

php pear: The default config file is not a valid config file or is corrupted

I'm really in deep sh*t here. While running "pear install HTTP", my server get rebooted, when everything back, I continue my work, and... $sudo pear install HTTP ERROR: The default config file is not ...
1
vote
2answers
510 views

Upgrade Pear Installer on a MediaTemple (dv) Dedicated-Virtual 3.5 server

All, Sorry in advance - I'm pretty naive when it comes to these things. Anyway, I'm trying to install the Pear Mail module. So, from the command line, I try this: pear install --alldeps Mail ...