PhantomJS is a headless WebKit with JavaScript API. It has fast and native support for various web standards: DOM handling, CSS selector, JSON, Canvas, and SVG.

learn more… | top users | synonyms

0
votes
0answers
9 views

CasperJS: How to obtain a persistent login when using a login script [migrated]

(background: I'm not a web developer, but someone with 20 years of IT and Unix/Infrastructure - so i would class myself as an intermediate skill scripting ) I have a CasperJS script which logs into ...
0
votes
1answer
736 views

Xvfb - phantomjs - linux redhat enterprise 5

I am trying to get phantomjs (a headless browser) working on my server... Bottom line is i'm not having any luck. The answer in the FAQ for phantomjs is to run it with Xvfb: ...
0
votes
0answers
92 views

phantomjs not working through browser anymore

We use phantomjs to generate pdf version of our web pages when user needs it. Unfortunately after recent whm/cpanel ugrapde it doesn't work through browser anymore. In log I see following error ( ...
0
votes
1answer
651 views

Phantomjs fails on Amazon EC2 (Ubuntu 12.04 AMI)

I'm trying to run Phantomjs (most specifically Casperjs) on a Amazon EC2, using Ubuntu latest image (12.4). To be sure, I tried with two different builds. One compiled on my dev machine (Phantomjs ...
1
vote
1answer
734 views

PhantomJS on CentOS 5.5 (glibc and libstdc++ versions)

I'm trying to run PhantomJS on CentOS, but I get the following: ./phantomjs: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./phantomjs) ./phantomjs: ...
6
votes
1answer
1k views

How to run PhantomJS on CentOS with SELinux?

I'm trying to make a screenshot using PhantomJS on my CentOS 5 machine, but I can't get it to work together with SELinux. It works on an identical machine with SELinux disabled, so I really suspect ...
2
votes
1answer
256 views

How to apply patches to phantomjs port in FreeBSD 9?

I have installed FreeBSD 9 and I need to install phantomjs. It is available in /usr/ports/lang/phantomjs but the version is 1.0 while I need a more recent version. There is a patch to update to ...